[Rseding91] [0.17.43] "Join server after sync" ends on blank title screen

This subforum contains all the issues which we already resolved.
Post Reply
SuperTux88
Burner Inserter
Burner Inserter
Posts: 5
Joined: Sat May 25, 2019 1:28 pm
Contact:

[Rseding91] [0.17.43] "Join server after sync" ends on blank title screen

Post by SuperTux88 » Sat May 25, 2019 2:35 pm

When I joined a modded multiplayer game, factorio offered me to sync the mods with the checkbox "Join server after sync". When this checkbox was enabled, it downloads the mods, restarts and I end on an empty menu screen, but without a menu, so just the background image. I then need to close factorio and restart (to have a menu again), search the game in the list and can join without any problems.

It looks like it somehow couldn't find the game to join anymore, because I saw the following in the output:

Code: Select all

  13.108 Info AppManagerStates.cpp:880: Connecting to game with gameID 4294967295
  13.108 Info HttpSharedState.cpp:54: Downloading https://multiplayer.factorio.com/get-game-details/4294967295
  13.596 Info HttpSharedState.cpp:146: Downloading https://multiplayer.factorio.com/get-game-details/4294967295
  13.596 Info HttpSharedState.cpp:147: Status code: 404
But I would at least expect to have the menu, so I can search the game again without the need of restarting the game again.

A few more information:
* I play on Linux, I don't know on which OS the host plays.
* The game was password protected (I don't know if that makes a difference?)
* I had this same problem already once with an older version (it was on March 30th, so probably 0.17.23, but I can't remember the exact version anymore. I also didn't look at the log back then, so I don't know if it has the same reason)

Full log output:

Code: Select all

   0.000  Initializing Steam API.
   0.000 2019-05-25 00:36:51; Factorio 0.17.43 (build 45140, linux64, steam)
   0.060 Operating system: Linux (Gentoo 1.0.0.59-r3)
   0.060 Program arguments: "/mnt/ssd-storage/gamestorage/SteamLibrary/steamapps/common/Factorio/bin/x64/factorio" 
   0.060 Read data path: /mnt/ssd-storage/gamestorage/SteamLibrary/steamapps/common/Factorio/data
   0.060 Write data path: /home/benjamin/.factorio [60723/440147MB]
   0.060 Binaries path: /mnt/ssd-storage/gamestorage/SteamLibrary/steamapps/common/Factorio/bin
   0.074 System info: [CPU:        Intel(R) Core(TM) i7-3930K CPU @ 3.20GHz, 12 cores, RAM: 48239 MB]
   0.074 Environment: DISPLAY=:0 WAYLAND_DISPLAY=<unset> DESKTOP_SESSION=gnome XDG_SESSION_DESKTOP=Xsession XDG_CURRENT_DESKTOP=<unset>
   0.074 Display options: [FullScreen: 0] [VSync: 1] [UIScale: automatic (100.0%)] [Native DPI: 1] [Screen: 255] [Special: 00] [Lang: en]
   0.261 Available displays: 3
   0.261  [0]: DELL U3014 30" - {[2560,0], 2560x1600, SDL_PIXELFORMAT_RGB888, 60Hz}
   0.261  [1]: DELL U3014 30" - {[0,0], 2560x1600, SDL_PIXELFORMAT_RGB888, 60Hz}
   0.261  [2]: HP ZR30w 30" - {[5120,0], 2560x1600, SDL_PIXELFORMAT_RGB888, 60Hz}
   0.469 Initialised OpenGL:[1] GeForce GTX TITAN/PCIe/SSE2; driver: 3.3.0 NVIDIA 430.09
   0.469   [Extensions] s3tc:yes; KHR_debug:yes; ARB_clear_texture:yes, ARB_copy_image:yes
   0.469   [Version] 3.3
   1.262 Graphics settings preset: very-high
   1.262   Dedicated video memory size 6144 MB
   1.262 Graphics options: [Graphics quality: high] [Video memory usage: all] [Light scale: 25%] [DXT: high-quality]
   1.262                   [Max load threads: 32] [Max texture size: 0] [Tex.Stream.: 0] [Rotation quality: normal] [Color: 32bit]
   1.535 Loading mod core 0.0.0 (data.lua)
   1.672 Loading mod base 0.17.43 (data.lua)
   1.979 Loading mod base 0.17.43 (data-updates.lua)
   2.123 Checksum for core: 29581630
   2.123 Checksum of base: 2106749062
   2.395 Loading sounds...
   2.476 Info PlayerData.cpp:69: Local player-data.json unavailable
   2.476 Info PlayerData.cpp:72: Cloud player-data.json available, timestamp 1554513558
   2.629 Crop bitmaps.
   6.624 Parallel Sprite Loader initialized (threads: 11)
  15.338 Initial atlas bitmap size is 16384
  15.367 Created atlas bitmap 16384x16360 [none]
  15.371 Created atlas bitmap 16384x11080 [none]
  15.371 Created atlas bitmap 8192x3892 [decal]
  15.371 Created atlas bitmap 16384x4288 [low-object]
  15.371 Created atlas bitmap 2048x192 [icon-background, not-compressed, linear-minification, linear-magnification, linear-mip-level, , no-crop, no-scale]
  15.372 Created atlas bitmap 8192x3584 [mipmap, linear-minification, linear-magnification, linear-mip-level]
  15.373 Created atlas bitmap 16384x6880 [terrain, mipmap, linear-minification, linear-mip-level, no-crop]
  15.373 Created atlas bitmap 4096x1600 [smoke, mipmap, linear-minification, linear-magnification]
  15.373 Created atlas bitmap 4096x1412 [not-compressed, mipmap, linear-minification, linear-magnification, linear-mip-level, no-crop, no-scale]
  15.373 Created atlas bitmap 8192x1496 [alpha-mask]
  15.376 Created atlas bitmap 16384x12632 [shadow, linear-magnification, alpha-mask]
  15.376 Created atlas bitmap 8192x2352 [shadow, mipmap, linear-magnification, alpha-mask]
  15.390 Texture processor created (2048). GPU accelerated compression Supported: yes, Enabled: yes/yes. Test passed. YCoCgDXT PSNR: 35.83, BC3 PSNR: 33.82
  15.843 Parallel Sprite Loader initialized (threads: 11)
  25.163 Sprites loaded
  25.218 Generated mipmaps (4) for atlas [3] of size 16384x4288   
  25.222 Generated mipmaps (3) for atlas [5] of size 8192x3584   
  25.417 Generated mipmaps (3) for atlas [6] of size 16384x6880   
  25.431 Generated mipmaps (3) for atlas [7] of size 4096x1600   
  25.447 Generated mipmaps (3) for atlas [8] of size 4096x1412   
  25.457 Generated mipmaps (3) for atlas [11] of size 8192x2352   
  25.541 Custom inputs active: 6
  25.838 Factorio initialised
  33.851 Info HttpSharedState.cpp:54: Downloading https://mods.factorio.com/api/mods?page_size=max&namelist=bobinserters&namelist=FactorioExtended-Plus-Core&namelist=FactorioExtended-Plus-Equipment&namelist=FactorioExtended-Plus-Logistics&namelist=FactorioExtended-Plus-Machines&namelist=FactorioExtended-Plus-Storage&namelist=FactorioExtended-Plus-Transport&namelist=FactorioExtended-Plus-Weaponry&namelist=FARL&namelist=Squeak%20Through&namelist=WaterWell&lang=en
  37.767 Info HttpSharedState.cpp:54: Downloading https://mods.factorio.com/api/mods?page_size=max&namelist=bobinserters&namelist=FactorioExtended-Plus-Core&namelist=FactorioExtended-Plus-Equipment&namelist=FactorioExtended-Plus-Logistics&namelist=FactorioExtended-Plus-Machines&namelist=FactorioExtended-Plus-Storage&namelist=FactorioExtended-Plus-Transport&namelist=FactorioExtended-Plus-Weaponry&namelist=FARL&namelist=Squeak%20Through&namelist=WaterWell&lang=en
  52.190 Info UDPSocket.cpp:27: Opening socket at (IP ADDR:({0.0.0.0:0}))
  70.255 Info UDPSocket.cpp:210: Closing socket
  70.255 Info UDPSocket.cpp:240: Socket closed
  70.255 Info UDPSocket.cpp:210: Closing socket
  70.261 Info HttpSharedState.cpp:54: Downloading https://mods.factorio.com/api/mods?page_size=max&namelist=FARL&namelist=bobinserters&namelist=long-reach&lang=en
  79.663 Info ModPortal.cpp:534: Downloading /download/FARL/5ce2552b2e27cc000c8e6d3c?username=SuperTux88&token=<private> to /home/benjamin/.factorio/temp/FARL_3.1.10.zip
  79.663 Info HttpSharedState.cpp:54: Downloading https://mods.factorio.com/download/FARL/5ce2552b2e27cc000c8e6d3c?username=SuperTux88&token=<private>
  80.413 Info ModPortal.cpp:534: Downloading /download/bobinserters/5cbf693eb3ce19000bd7e50e?username=SuperTux88&token=<private> to /home/benjamin/.factorio/temp/bobinserters_0.17.5.zip
  80.413 Info HttpSharedState.cpp:54: Downloading https://mods.factorio.com/download/bobinserters/5cbf693eb3ce19000bd7e50e?username=SuperTux88&token=<private>
  80.997 Info ModPortal.cpp:534: Downloading /download/long-reach/5c7efd790f327c000dcace73?username=SuperTux88&token=<private> to /home/benjamin/.factorio/temp/long-reach_0.0.13.zip
  80.997 Info HttpSharedState.cpp:54: Downloading https://mods.factorio.com/download/long-reach/5c7efd790f327c000dcace73?username=SuperTux88&token=<private>
  81.448 Info AppManager.cpp:1160: Restarting Factorio
  81.448 Restarting for reason other than update. Setting execute permission skipped.
  81.448 Info AppManager.cpp:1193: Executable path: /mnt/ssd-storage/gamestorage/SteamLibrary/steamapps/common/Factorio/bin/x64/factorio
  81.448 Info GlobalContext.cpp:683: Waiting for child processes to exit: 
  82.092 Steam API shutdown.
  82.193 Goodbye
   0.000  Initializing Steam API.
   0.002 2019-05-25 00:38:13; Factorio 0.17.43 (build 45140, linux64, steam)
   0.068 Operating system: Linux (Gentoo 1.0.0.59-r3)
   0.068 Program arguments: "/mnt/ssd-storage/gamestorage/SteamLibrary/steamapps/common/Factorio/bin/x64/factorio" "--join-game-by-steam-id" "76561198282219996" 
   0.068 Read data path: /mnt/ssd-storage/gamestorage/SteamLibrary/steamapps/common/Factorio/data
   0.068 Write data path: /home/benjamin/.factorio [60723/440147MB]
   0.068 Binaries path: /mnt/ssd-storage/gamestorage/SteamLibrary/steamapps/common/Factorio/bin
   0.076 System info: [CPU:        Intel(R) Core(TM) i7-3930K CPU @ 3.20GHz, 12 cores, RAM: 48239 MB]
   0.076 Environment: DISPLAY=:0 WAYLAND_DISPLAY=<unset> DESKTOP_SESSION=gnome XDG_SESSION_DESKTOP=Xsession XDG_CURRENT_DESKTOP=<unset>
   0.076 Display options: [FullScreen: 0] [VSync: 1] [UIScale: automatic (100.0%)] [Native DPI: 1] [Screen: 255] [Special: 00] [Lang: en]
   0.123 Available displays: 3
   0.123  [0]: DELL U3014 30" - {[2560,0], 2560x1600, SDL_PIXELFORMAT_RGB888, 60Hz}
   0.123  [1]: DELL U3014 30" - {[0,0], 2560x1600, SDL_PIXELFORMAT_RGB888, 60Hz}
   0.123  [2]: HP ZR30w 30" - {[5120,0], 2560x1600, SDL_PIXELFORMAT_RGB888, 60Hz}
   0.229 Initialised OpenGL:[1] GeForce GTX TITAN/PCIe/SSE2; driver: 3.3.0 NVIDIA 430.09
   0.229   [Extensions] s3tc:yes; KHR_debug:yes; ARB_clear_texture:yes, ARB_copy_image:yes
   0.229   [Version] 3.3
   0.258 Graphics settings preset: very-high
   0.258   Dedicated video memory size 6144 MB
   0.258 Graphics options: [Graphics quality: high] [Video memory usage: all] [Light scale: 25%] [DXT: high-quality]
   0.258                   [Max load threads: 32] [Max texture size: 0] [Tex.Stream.: 0] [Rotation quality: normal] [Color: 32bit]
   0.350 Info ModManager.cpp:240: Found duplicate mod bobinserters, using higher version (0.17.5 > 0.17.3).
   0.369 Loading mod settings FARL 3.1.10 (settings.lua)
   0.369 Loading mod settings bobinserters 0.17.5 (settings.lua)
   0.369 Loading mod settings long-reach 0.0.13 (settings.lua)
   0.371 Loading mod core 0.0.0 (data.lua)
   0.488 Loading mod base 0.17.43 (data.lua)
   0.735 Loading mod FARL 3.1.10 (data.lua)
   0.861 Loading mod bobinserters 0.17.5 (data.lua)
   0.992 Loading mod WaterWell 1.0.20 (data.lua)
   1.121 Loading mod base 0.17.43 (data-updates.lua)
   1.241 Loading mod FARL 3.1.10 (data-updates.lua)
   1.361 Loading mod bobinserters 0.17.5 (data-updates.lua)
   1.479 Loading mod Squeak Through 1.3.0 (data-updates.lua)
   1.607 Loading mod FARL 3.1.10 (data-final-fixes.lua)
   1.742 Checksum for core: 29581630
   1.742 Checksum of base: 2106749062
   1.742 Checksum of FARL: 2813802960
   1.742 Checksum of bobinserters: 690643741
   1.742 Checksum of long-reach: 4166847516
   1.742 Checksum of Squeak Through: 3677677690
   1.742 Checksum of WaterWell: 4254977431
   1.809 Warning EnergySourcePrototype.cpp:91: emissions in prototype definition, use emissions_per_second_per_watt (proposed value 0.0001) as emissions will be not used eventually: ROOT.assembling-machine.water-well-pump.energy_source
   1.962 Loading sounds...
   1.988 Info PlayerData.cpp:69: Local player-data.json unavailable
   1.988 Info PlayerData.cpp:72: Cloud player-data.json available, timestamp 1558737492
   2.146 Crop bitmaps.
   2.172 Parallel Sprite Loader initialized (threads: 0)
   2.235 Initial atlas bitmap size is 16384
   2.266 Created atlas bitmap 16384x16376 [none]
   2.270 Created atlas bitmap 16384x11120 [none]
   2.270 Created atlas bitmap 8192x3872 [decal]
   2.271 Created atlas bitmap 16384x4288 [low-object]
   2.271 Created atlas bitmap 2048x192 [icon-background, not-compressed, linear-minification, linear-magnification, linear-mip-level, , no-crop, no-scale]
   2.271 Created atlas bitmap 8192x3552 [mipmap, linear-minification, linear-magnification, linear-mip-level]
   2.272 Created atlas bitmap 16384x6880 [terrain, mipmap, linear-minification, linear-mip-level, no-crop]
   2.273 Created atlas bitmap 4096x1600 [smoke, mipmap, linear-minification, linear-magnification]
   2.273 Created atlas bitmap 4096x1436 [not-compressed, mipmap, linear-minification, linear-magnification, linear-mip-level, no-crop, no-scale]
   2.273 Created atlas bitmap 8192x1496 [alpha-mask]
   2.276 Created atlas bitmap 16384x12644 [shadow, linear-magnification, alpha-mask]
   2.276 Created atlas bitmap 8192x2352 [shadow, mipmap, linear-magnification, alpha-mask]
   2.290 Texture processor created (2048). GPU accelerated compression Supported: yes, Enabled: yes/yes. Test passed. YCoCgDXT PSNR: 35.83, BC3 PSNR: 33.82
   2.863 Parallel Sprite Loader initialized (threads: 11)
  12.476 Sprites loaded
  12.528 Generated mipmaps (4) for atlas [3] of size 16384x4288   
  12.532 Generated mipmaps (3) for atlas [5] of size 8192x3552   
  12.724 Generated mipmaps (3) for atlas [6] of size 16384x6880   
  12.737 Generated mipmaps (3) for atlas [7] of size 4096x1600   
  12.754 Generated mipmaps (3) for atlas [8] of size 4096x1436   
  12.760 Generated mipmaps (3) for atlas [11] of size 8192x2352   
  12.817 Custom inputs active: 13
  13.107 Factorio initialised
  13.108 Info AppManagerStates.cpp:880: Connecting to game with gameID 4294967295
  13.108 Info HttpSharedState.cpp:54: Downloading https://multiplayer.factorio.com/get-game-details/4294967295
  13.596 Info HttpSharedState.cpp:146: Downloading https://multiplayer.factorio.com/get-game-details/4294967295
  13.596 Info HttpSharedState.cpp:147: Status code: 404

FuryoftheStars
Fast Inserter
Fast Inserter
Posts: 124
Joined: Tue Apr 25, 2017 2:01 pm
Contact:

Re: [0.17.43] "Join server after sync" ends on blank title screen

Post by FuryoftheStars » Sat May 25, 2019 4:40 pm

I think someone else was reporting the same issue: viewtopic.php?f=29&t=70912

Rseding91
Factorio Staff
Factorio Staff
Posts: 9243
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.17.43] "Join server after sync" ends on blank title screen

Post by Rseding91 » Mon May 27, 2019 2:04 am

Thanks for the report and for the log file. It failed because you tried to join a steam networking enabled game but you disabled steam networking in the game settings.

The issue only shows up when you go through the sync-mods-and-join-server where it wasn't accounting for steam networking being disabled.

It's now fixed for the next version of 0.17.

Out of curiosity: why did you disable steam networking?
If you want to get ahold of me I'm almost always on Discord.

SuperTux88
Burner Inserter
Burner Inserter
Posts: 5
Joined: Sat May 25, 2019 1:28 pm
Contact:

Re: [Rseding91] [0.17.43] "Join server after sync" ends on blank title screen

Post by SuperTux88 » Mon May 27, 2019 10:10 pm

Interesting, I don't remember disabling steam networking, maybe it's disabled by default (or maybe I just forgot about it)? I don't even find where I can enable it? Can you tell me where this setting is?

Rseding91
Factorio Staff
Factorio Staff
Posts: 9243
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [Rseding91] [0.17.43] "Join server after sync" ends on blank title screen

Post by Rseding91 » Tue May 28, 2019 2:20 am

SuperTux88 wrote:
Mon May 27, 2019 10:10 pm
Interesting, I don't remember disabling steam networking, maybe it's disabled by default (or maybe I just forgot about it)? I don't even find where I can enable it? Can you tell me where this setting is?
It's in the config file under the "other settings" section.
If you want to get ahold of me I'm almost always on Discord.

SuperTux88
Burner Inserter
Burner Inserter
Posts: 5
Joined: Sat May 25, 2019 1:28 pm
Contact:

Re: [Rseding91] [0.17.43] "Join server after sync" ends on blank title screen

Post by SuperTux88 » Tue May 28, 2019 9:03 am

Oh, it's only in the file, I checked the UI yesterday and couldn't find it. But in the config.ini it's just commented out (and I think I never edited this file before):

Code: Select all

; Options: true, false
; enable-steam-networking=true
So I guess it uses the default then? Should the default be true or false?

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users