[0.16.51] Trains can path to stations of a different force instead

Bugs that are actually features.
Post Reply
User avatar
lovely_santa
Fast Inserter
Fast Inserter
Posts: 137
Joined: Sat Feb 18, 2017 9:41 pm
Contact:

[0.16.51] Trains can path to stations of a different force instead

Post by lovely_santa » Fri Feb 08, 2019 2:16 pm

Hi,

While modding, I came acros a nice bug, it also applies to vanilla.

Imagine 2 forces: force fA and force fB
A train on force fA: train tA

When I make a new train stop on force fA, I can choose an already existing stop name (backer_name) from the list, a list containing all train stop names of my force fA.

Let's say the other force fB also makes a train stop with that same name, his list didn't show that station name, becose it was on anoter force, but he could choose this manual. No problem.

The issue however, when a train paths to this stop, the train doesn't care about the force. Meaning the train tA could travel to the train stop of his force, fA, but also to the force fB (if it has a path).

The main issue for vanilla, quickly easly put together:
In the production challenge:
:arrow: How nice that the 'enemy' drops of his resources at my station instead of his... wondering where his resources are goiing
:arrow: They guess a station name of the enemies (maybe stream snyping?) and send a nice big artillery train to the other base to destroy it from the inside out! :lol:

For modding
:arrow: My trains are pathing to the wrong force :oops:

Kind regards,
lovely_santa
You can find all my mods on the mod portal.
Image

Twinsen
Factorio Staff
Factorio Staff
Posts: 903
Joined: Tue Sep 23, 2014 7:10 am
Contact:

Re: [0.16.51] Trains can path to stations of a different force instead

Post by Twinsen » Wed May 08, 2019 2:18 pm

I believe it's kind of agreed that this is ok behavior. Or some grey area between bug and feature.
Since it can lead to many interesting situations in multiplayer, it's currently regarded as working as intended.

Trains in general are force agnostic.

Post Reply

Return to “Not a bug”

Who is online

Users browsing this forum: No registered users