[0.16.51] Crash: "PathFinder::searchForPath"

Post your bugs and problems so we can fix them.
Post Reply
User avatar
ssilk
Global Moderator
Global Moderator
Posts: 10402
Joined: Tue Apr 16, 2013 10:35 pm
Contact:

[0.16.51] Crash: "PathFinder::searchForPath"

Post by ssilk » Sun Jan 13, 2019 2:13 pm

It crashed suddenly, while I was doing nothing but looking on screen. If you need the last autosave PM, cause it is very very large.

(Note for me: 2019-01-13-crash.zip)
Attachments
factorio-current.log
(21.74 KiB) Downloaded 15 times
Cool suggestion: Eatable MOUSE-pointers.
Have you used the Advanced Search today?
Need help, question? FAQ - Wiki - Forum help
I still like small signatures...

Loewchen
Global Moderator
Global Moderator
Posts: 4746
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: [0.16.51] Crash: "PathFinder::searchForPath"

Post by Loewchen » Sun Jan 13, 2019 2:57 pm

Does it crash again if you let the last save run without input?

User avatar
ssilk
Global Moderator
Global Moderator
Posts: 10402
Joined: Tue Apr 16, 2013 10:35 pm
Contact:

Re: [0.16.51] Crash: "PathFinder::searchForPath"

Post by ssilk » Fri Jan 18, 2019 10:45 pm

Sorry for the delay.

I started the last save. It says
"Corrupted map, contains id not in the dictionary: 16368"

I have tested the other 2 autosaves (I copied them all) and all are corrupt with the same error.

I dunno, if it's really worth to fix that, cause I think it happened cause the laptop had been saved memory to disk cause the power plug was not switched in some hours before that. Perhaps I need to say it's a MacBook.
Cool suggestion: Eatable MOUSE-pointers.
Have you used the Advanced Search today?
Need help, question? FAQ - Wiki - Forum help
I still like small signatures...

Post Reply

Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 2 guests