Visual bug by window of pipe

Post your bugs and problems so we can fix them.
Post Reply
User avatar
darkfrei
Smart Inserter
Smart Inserter
Posts: 1510
Joined: Thu Nov 20, 2014 11:11 pm

Visual bug by window of pipe

Post by darkfrei » Mon Dec 03, 2018 10:12 pm

I'm trying to make new graphics for pipes and I get some problems by prototypes definition. Don't move it to Modding help!

First Bu that I get comes from bigger window:

Code: Select all

data.raw.pipe.pipe.pictures.low_temperature_flow.width = 160 
data.raw.pipe.pipe.pictures.low_temperature_flow.height = 10
2018-12-03 22_54_58-Factorio 0.16.51.png
2018-12-03 22_54_58-Factorio 0.16.51.png (61.36 KiB) Viewed 75 times

Much bigger problem I get when I want to change the image by the flow:

Code: Select all

data.raw.pipe.pipe.pictures.low_temperature_flow.filename = mod_name..'/graphics/entities/'..'fluid-flow-low-temperature-32x8.png'
data.raw.pipe.pipe.pictures.low_temperature_flow.width = 32
data.raw.pipe.pipe.pictures.low_temperature_flow.height = 8
Here I have some image 32 pixels wide and 8 pixels high, but it doesn't move (it's png, but the same gif will be also static, here is no movement)
2018-12-03 23_07_50-Factorio 0.16.51.png
2018-12-03 23_07_50-Factorio 0.16.51.png (79.62 KiB) Viewed 75 times
It looks like some part of this prototype is hardcoded on the game side.
Attachments
fluid-flow-low-temperature-32x8.png
fluid-flow-low-temperature-32x8.png (407 Bytes) Viewed 63 times

Post Reply

Return to “Bug Reports”