[0.16.51] Crash: "this->state == RailConnectionDirection::None was not true"

Bugs that we were not able to reproduce, and/or are waiting for more detailed info.
Post Reply
immortal_sniper1
Filter Inserter
Filter Inserter
Posts: 450
Joined: Sun Jun 03, 2018 8:54 am
Contact:

[0.16.51] Crash: "this->state == RailConnectionDirection::None was not true"

Post by immortal_sniper1 » Fri Oct 12, 2018 10:23 am

https://pastebin.com/5gS6Lrwj

after i destroyed the last 2 wagons of a train with its own locomotive the train got stuck
i placed a wagon in front of the locomotive then it crashed i expected the train to unstuck after i placed the wagon
i used creative mod to test the new mk3 wagon it ende in 2 min so i dont have save or jpg of the setup
i only used a small rail circle and a 1-2 train mk3 locomotive and 2 fluid wagons
ALSO
https://mods.factorio.com/mod/fast_tran ... 000b8380ce

someone else had the same stuck bug


immortal_sniper1
Filter Inserter
Filter Inserter
Posts: 450
Joined: Sun Jun 03, 2018 8:54 am
Contact:

Re: [0.16.51] Crash: "this->state == RailConnectionDirection::None was not true"

Post by immortal_sniper1 » Fri Oct 12, 2018 12:06 pm

Loewchen wrote:
Fri Oct 12, 2018 11:06 am
Post the save please.
https://drive.google.com/open?id=17EFpO ... 3YouuiPxCB

is this ok?
i also added some more jpg s

User avatar
Klonan
Factorio Staff
Factorio Staff
Posts: 3644
Joined: Sun Jan 11, 2015 2:09 pm
Contact:

Re: [0.16.51] Crash: "this->state == RailConnectionDirection::None was not true"

Post by Klonan » Tue May 14, 2019 1:51 pm

If this happens in 0.17 please make a new bug report, this is outdated now, half the mods of the save are not available in 0.17, etc.

Post Reply

Return to “Pending”

Who is online

Users browsing this forum: No registered users