[0.16.48]Holding blueprint causes UPS drop

This subforum contains all the issues which we already resolved.
Post Reply
User avatar
Bilka
Factorio Staff
Factorio Staff
Posts: 1052
Joined: Sat Aug 13, 2016 9:20 am

[0.16.48]Holding blueprint causes UPS drop

Post by Bilka » Thu Jun 07, 2018 6:39 pm

No matter the size of the blueprint, holding a blueprint with some rails signals and rails will cause UPS (and FPS) to drop. The render preparation time keeps increasing.

Image
Attachments
factorio-current.log
(5.42 KiB) Downloaded 30 times
Last edited by Bilka on Thu Jun 07, 2018 6:56 pm, edited 1 time in total.
I'm an admin over at https://wiki.factorio.com. Feel free to contact me if there's anything wrong (or right) with it.

User avatar
Eaggra
Burner Inserter
Burner Inserter
Posts: 8
Joined: Sat Apr 22, 2017 10:16 am

Re: [0.16.48]Holding rail (signal) blueprint causes UPS drop

Post by Eaggra » Thu Jun 07, 2018 6:48 pm

In my case also blueprints without rail stuff cause UPS drops.
For me it seems the size of the bp is crucial.

EDIT: ok, a big blueprint only with solar panels, accumulators and a few substation causes no lag.
Last edited by Eaggra on Thu Jun 07, 2018 6:56 pm, edited 1 time in total.

Wackerstamfer
Long Handed Inserter
Long Handed Inserter
Posts: 78
Joined: Sat Oct 22, 2016 9:38 pm

Re: [0.16.48]Holding rail (signal) blueprint causes UPS drop

Post by Wackerstamfer » Thu Jun 07, 2018 6:51 pm

same issue here, deconstruction planner filters also seems to be affected (whitelist/blacklist)

ejg
Inserter
Inserter
Posts: 28
Joined: Fri May 05, 2017 9:15 am

Re: [0.16.48]Holding rail (signal) blueprint causes UPS drop

Post by ejg » Thu Jun 07, 2018 6:55 pm

Deconstruction planner has inconsistent behaviour when using a blacklist. Sometimes stuff is deconstructed sometimes it isnt.

Koub
Global Moderator
Global Moderator
Posts: 3865
Joined: Fri May 30, 2014 8:54 am

Re: [0.16.48]Holding rail (signal) blueprint causes UPS drop

Post by Koub » Thu Jun 07, 2018 6:56 pm

ejg wrote:Deconstruction planner has inconsistent behaviour when using a blacklist. Sometimes stuff is deconstructed sometimes it isnt.
Please don't hijack others' bug reports with your - different - bug, create your own report
Koub - Please consider English is not my native language.

cdp181
Burner Inserter
Burner Inserter
Posts: 7
Joined: Thu Jun 02, 2016 12:44 pm

Re: [0.16.48]Holding rail (signal) blueprint causes UPS drop

Post by cdp181 » Thu Jun 07, 2018 6:58 pm

On a very large old map I get this.... on a smaller map it doesn't happen. Also small Blueprints (2 items) do not cause the issue on the large map.

Blueprint contents doesn't seem to matter.

ejg
Inserter
Inserter
Posts: 28
Joined: Fri May 05, 2017 9:15 am

Re: [0.16.48]Holding rail (signal) blueprint causes UPS drop

Post by ejg » Thu Jun 07, 2018 7:01 pm

Koub wrote:
ejg wrote:Deconstruction planner has inconsistent behaviour when using a blacklist. Sometimes stuff is deconstructed sometimes it isnt.
Please don't hijack others' bug reports with your - different - bug, create your own report
Well both are probably related.. One update and both deconstruction and blueprints have issues.. Just saying.

Wackerstamfer
Long Handed Inserter
Long Handed Inserter
Posts: 78
Joined: Sat Oct 22, 2016 9:38 pm

Re: [0.16.48]Holding rail (signal) blueprint causes UPS drop

Post by Wackerstamfer » Thu Jun 07, 2018 7:01 pm

Koub wrote:
ejg wrote:Deconstruction planner has inconsistent behaviour when using a blacklist. Sometimes stuff is deconstructed sometimes it isnt.
Please don't hijack others' bug reports with your - different - bug, create your own report
I think this is the same bug causing both issues.

jcbris1978
Manual Inserter
Manual Inserter
Posts: 1
Joined: Thu Jun 07, 2018 7:09 pm

Re: [0.16.48]Holding blueprint causes UPS drop

Post by jcbris1978 » Thu Jun 07, 2018 7:11 pm

Having the same issue to the point the game has become unplayable since the last update :(

Updated with proper details.... :mrgreen:
factorio-current.log
(3.57 KiB) Downloaded 31 times
Blueprint.PNG
Blueprint.PNG (3.65 MiB) Viewed 1713 times
No blueprint.PNG
No blueprint.PNG (3.78 MiB) Viewed 1713 times
Last edited by jcbris1978 on Thu Jun 07, 2018 7:33 pm, edited 2 times in total.

User avatar
Gergely
Filter Inserter
Filter Inserter
Posts: 443
Joined: Sun Apr 10, 2016 8:31 pm

Re: [0.16.48]Holding blueprint causes UPS drop

Post by Gergely » Thu Jun 07, 2018 7:11 pm

Today is the day!

User avatar
BlacKcuD
Burner Inserter
Burner Inserter
Posts: 7
Joined: Sat Mar 05, 2016 3:50 am

Re: [0.16.48]Holding blueprint causes UPS drop

Post by BlacKcuD » Thu Jun 07, 2018 7:44 pm

Confirmed. FPS drops seem to be worse, the more complex cables/circuit stuff is in the blueprint. Rolling back until fixed :(
Angelbobs Megabases for life!

Pseudex
Manual Inserter
Manual Inserter
Posts: 1
Joined: Thu Jun 07, 2018 7:52 pm

Re: [0.16.48]Holding blueprint causes UPS drop

Post by Pseudex » Thu Jun 07, 2018 7:57 pm

I have the same prob. Unfortuanetly i also saved the game with this version. Looks like I can get to bed early :)
On one Instance it also didn't show the whole ghost of the blueprint at all.
20180607214401_1.jpg
20180607214401_1.jpg (899 KiB) Viewed 1684 times

Rseding91
Factorio Staff
Factorio Staff
Posts: 7975
Joined: Wed Jun 11, 2014 5:23 am

Re: [0.16.48]Holding blueprint causes UPS drop

Post by Rseding91 » Thu Jun 07, 2018 8:17 pm

Thanks for the report. It's now fixed for the next version of 0.16.
If you want to get ahold of me I'm almost always on IRC and Discord.

hypertrax99
Burner Inserter
Burner Inserter
Posts: 10
Joined: Mon Apr 24, 2017 6:21 pm

Re: [0.16.48]Holding blueprint causes UPS drop

Post by hypertrax99 » Fri Jun 08, 2018 6:26 am

i hope the next patch don't need days :/
my saves all with 0.48 :O ._.

Cutemine
Inserter
Inserter
Posts: 37
Joined: Mon Jun 27, 2016 8:00 pm

Re: [0.16.48]Holding blueprint causes UPS drop

Post by Cutemine » Fri Jun 08, 2018 12:21 pm

I just testet this in 0.16.49 and experienced a 30-50% drop in FPS/UPS when I hold a largeish blueprint over some existing stuff. While I hold it over a free area the FPS/UPS recover.
Hovever I did not play 0.16.48 an cant therefore compare them, but in 0.16.47 I did not have these drops.
https://www.youtube.com/watch?v=lrN3gy7R-LM

cronic-zombie
Manual Inserter
Manual Inserter
Posts: 2
Joined: Fri Jun 08, 2018 12:15 pm

Re: [0.16.48]Holding blueprint causes UPS drop

Post by cronic-zombie » Fri Jun 08, 2018 12:28 pm

my game has become un playable just a simple rail blueprint and my fps/ups goes from 60 to 6

and i cant roll back because the game save wont load


EDIT scap that just tested in 16.49 and its fixed


happy days

Hiladdar
Burner Inserter
Burner Inserter
Posts: 10
Joined: Mon May 14, 2018 6:47 pm

Re: [0.16.48]Holding blueprint causes UPS drop

Post by Hiladdar » Tue Jun 12, 2018 4:18 pm

I can confirm that this patch does fix this issue. It was not just a rail roads almost all blue prints.

Thanks guys!

Post Reply

Return to “Resolved Problems and Bugs”