[0.10.11] Mousebuttons & the GUI

This subforum contains all the issues which we already resolved.
Post Reply
boro
Fast Inserter
Fast Inserter
Posts: 135
Joined: Thu May 22, 2014 5:36 pm
Contact:

[0.10.11] Mousebuttons & the GUI

Post by boro » Mon Sep 15, 2014 12:49 pm

This is a continuation thread for this persisting bug described here
https://forums.factorio.com/forum/vie ... =11&t=5130 and
https://forums.factorio.com/forum/vie ... =11&t=4799

current situation in 0.10.11: non-interface actions bound to mousebuttons don't function when the cursor is over part of the GUI, except for actions bound to scroll wheel

I noticed that when the mousebutton press is initiated outside of gui, the action will work as long as the cursor is out of gui (even after passing over gui several times) for as long as the button remains pressed.
But when you start pressing the mousebutton over gui and keep it pressed, it will not work if you move out of the gui. Don't know if this has any relevance.

User avatar
pyrolytic_tungsten
Fast Inserter
Fast Inserter
Posts: 115
Joined: Fri Aug 01, 2014 4:29 am
Contact:

Re: [0.10.11] Mousebuttons & the GUI

Post by pyrolytic_tungsten » Mon Sep 15, 2014 1:55 pm

Admittedly, I don't usually mess with the mouse buttons when a gui is up. I tested binding actions to mouse button 4 which I normally set to pick up items on ground. A lot of the mouse buttons work for stuff with a gui up such as next weapon, connect train, or rotate (object in hand).

Stuff that doesn't work: pick up items on ground, directional buttons(default: wsad) and shoot enemy (you mean you're supposed to put capsules in the hotbar before combat?).

I run Factorio on Linux x64 (Kubuntu 14.04).

User avatar
micomico
Long Handed Inserter
Long Handed Inserter
Posts: 94
Joined: Thu Jul 24, 2014 10:55 pm
Contact:

Re: [0.10.11] Mousebuttons & the GUI

Post by micomico » Mon Sep 15, 2014 2:18 pm

0.10.11 is almost perfect and contains exactly 0.5 bugs, from which yours isn't one. It's going to be a stable release. You're most likely doing something wrong.

Please refrain from posting bugs with that version tag.
This is not a serious post. You probably noticed it, but still...

slpwnd
Factorio Staff
Factorio Staff
Posts: 1836
Joined: Sun Feb 03, 2013 2:51 pm
Contact:

Re: [0.10.11] Mousebuttons & the GUI

Post by slpwnd » Tue Sep 16, 2014 8:57 am

Thanks for the report, this should be properly fixed in the 0.10.12 (sigh :)).

boro
Fast Inserter
Fast Inserter
Posts: 135
Joined: Thu May 22, 2014 5:36 pm
Contact:

Re: [0.10.11] Mousebuttons & the GUI

Post by boro » Tue Sep 16, 2014 1:04 pm

Guys, it's fixed !

kovarex
Factorio Staff
Factorio Staff
Posts: 7424
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [0.10.11] Mousebuttons & the GUI

Post by kovarex » Tue Sep 16, 2014 1:18 pm

Great news :)

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users