[0.9.8] Evil train pathfinding #2

This subforum contains all the issues which we already resolved.
User avatar
Narc
Filter Inserter
Filter Inserter
Posts: 278
Joined: Mon Feb 11, 2013 7:25 am
Contact:

[0.9.8][slpwnd]Evil train pathfinding strikes again!

Post by Narc » Wed Apr 23, 2014 4:36 am

Given this setup:

Image

where the arrows mark one-directional track and there is exactly one more station at the end of the rails heading off the bottom-right corner, one would expect a train leaving from the Bryan Burr or Marc Jaisek stops to be capable of making its way to Paul 'Xanzibaarbarian' Cooper without much undue trouble -- it can just enter the one-directional section (the bottom of the two parallel horizontal tracks) and then branch off toward the north.

Unfortunately, what happens instead is the train ignores the branch and keeps going forward until realizing there's no path to its destination anymore. After that it stands there and shouts "No path!" at me like an idiot.

I've driven the path myself in the same train, so I'm certain it's valid (the switch is a switch, and once driven manually past it, the train is perfectly capable of reaching the Xanzibaarbarian station on its own), therefore I can only assume the track setup is too confusing for the poor thing.

The save, should you wish to poke at it, is available at http://dev.narc.ro/factorio/lousy-pathfind.zip. The train is stopped just after its recognition of its own mistake -- enter the leftmost locomotive, drive it forward a bit (towards the Bryan Burr/Marc Jaisek station complex), and then let it try again; it should make the same mistake every time. You may also verify for yourself that the Xanzibaarbarian station is perfectly reachable, though you'll have to navigate the train past the troublesome switch first.

Good luck!

User avatar
rk84
Filter Inserter
Filter Inserter
Posts: 556
Joined: Wed Feb 13, 2013 9:15 am
Contact:

Re: [0.9.8] Evil train pathfinding strikes again!

Post by rk84 » Wed Apr 23, 2014 5:50 am

I have forgot to report this one. If you put wagon in front of locomotive it will reverse left and right -controls.
Seems like problem is in both manual and automatic driving. I tested with another curve to opposited side of switch and it tries to turn but in wrong way.
wrongway.png
wrongway.png (974.82 KiB) Viewed 3788 times
Test mode
Searching Flashlight
[WIP]Fluid handling expansion
[WIP]PvP gamescript
[WIP]Rocket Express
Autofill: The torch has been pass to Nexela

User avatar
ssilk
Global Moderator
Global Moderator
Posts: 10555
Joined: Tue Apr 16, 2013 10:35 pm
Contact:

[0.9.8] Evil train pathfinding #2

Post by ssilk » Wed Apr 23, 2014 6:56 am

This is a split thread for rk84's post, cause I would say they are two different bugs.
Cool suggestion: Eatable MOUSE-pointers.
Have you used the Advanced Search today?
Need help, question? FAQ - Wiki - Forum help
I still like small signatures...

User avatar
Narc
Filter Inserter
Filter Inserter
Posts: 278
Joined: Mon Feb 11, 2013 7:25 am
Contact:

Re: [0.9.8] Evil train pathfinding #2

Post by Narc » Wed Apr 23, 2014 7:15 am

It might not be a different bug after all -- the pathfinding may have gone perfectly correctly, but the locomotive was given the wrong order ("turn left", when it should've been "turn right").

I guess the passing siding I'd built before was only accidentally working correctly -- the way to enter it when the train was driving backwards was to go straight forward, thus no turn action required. I did notice the inverted controls when manually driving, but would never have imagined the automatic driver would be using the same logic.

MF-
Smart Inserter
Smart Inserter
Posts: 1235
Joined: Sun Feb 24, 2013 12:07 am
Contact:

Re: [0.9.8] Evil train pathfinding #2

Post by MF- » Thu May 08, 2014 10:06 pm

Ha, that could easily be it.
Wrong turn-order interpretation between the train AI and junction.

Sounds like a simple bug in causing a wide variety of unrelated-looking issues.

slpwnd
Factorio Staff
Factorio Staff
Posts: 1836
Joined: Sun Feb 03, 2013 2:51 pm
Contact:

Re: [0.9.8][slpwnd]Evil train pathfinding strikes again!

Post by slpwnd » Wed Jun 25, 2014 3:02 pm

Thanks for the report. Took some time but it is now fixed for 0.10.2. The problem was not with the pathfinding, but with the path execution (moving the train to match the path). Because your train was moving "backwards".

User avatar
Narc
Filter Inserter
Filter Inserter
Posts: 278
Joined: Mon Feb 11, 2013 7:25 am
Contact:

Re: [0.9.8][slpwnd]Evil train pathfinding strikes again!

Post by Narc » Wed Jun 25, 2014 3:26 pm

slpwnd wrote:Thanks for the report. Took some time but it is now fixed for 0.10.2. The problem was not with the pathfinding, but with the path execution (moving the train to match the path). Because your train was moving "backwards".
Yay, thank you!

Sounds like /u/rk84 was right on the money when he initially replied (later split to https://forums.factorio.com/forum/vie ... f=7&t=3199). Would a mod be willing to re-merge that topic back into here, for forum cleanliness reasons?

slpwnd
Factorio Staff
Factorio Staff
Posts: 1836
Joined: Sun Feb 03, 2013 2:51 pm
Contact:

Re: [0.9.8] Evil train pathfinding #2

Post by slpwnd » Thu Jun 26, 2014 12:36 pm

Merged the issues. This one has been solved for the 0.10.2.

MF-
Smart Inserter
Smart Inserter
Posts: 1235
Joined: Sun Feb 24, 2013 12:07 am
Contact:

Re: [0.9.8] Evil train pathfinding #2

Post by MF- » Thu Jun 26, 2014 7:56 pm

I am confused by the post reshuffling, the link to the duplicite bug is dead now.

slpwnd
Factorio Staff
Factorio Staff
Posts: 1836
Joined: Sun Feb 03, 2013 2:51 pm
Contact:

Re: [0.9.8] Evil train pathfinding #2

Post by slpwnd » Fri Jun 27, 2014 6:57 am

MF- wrote:I am confused by the post reshuffling, the link to the duplicite bug is dead now.
Yeah, I guess I will stay away from merging topics next time and just cross reference them.

MF-
Smart Inserter
Smart Inserter
Posts: 1235
Joined: Sun Feb 24, 2013 12:07 am
Contact:

Re: [0.9.8] Evil train pathfinding #2

Post by MF- » Sat Jun 28, 2014 6:07 am

Actually.. re-merge of a previously split topic seems fine to me.
Just EITHER merge OR link :P

jakobeng1303
Long Handed Inserter
Long Handed Inserter
Posts: 57
Joined: Thu Jun 19, 2014 12:20 pm
Contact:

Re: [0.9.8] Evil train pathfinding #2

Post by jakobeng1303 » Mon Jun 30, 2014 3:30 pm

I still have that Bug in Mac Version 10.10.2

slpwnd
Factorio Staff
Factorio Staff
Posts: 1836
Joined: Sun Feb 03, 2013 2:51 pm
Contact:

Re: [0.9.8] Evil train pathfinding #2

Post by slpwnd » Tue Jul 01, 2014 10:00 am

jakobeng1303 wrote:I still have that Bug in Mac Version 10.10.2
Can you give more details / save / etc. ?

jakobeng1303
Long Handed Inserter
Long Handed Inserter
Posts: 57
Joined: Thu Jun 19, 2014 12:20 pm
Contact:

Re: [0.9.8] Evil train pathfinding #2

Post by jakobeng1303 » Thu Jul 03, 2014 4:56 pm

it is quiet a big train system with many stations and a lot of tracks. I use Signals and trains with two engines. During 9.0 I had no troubles with trains not finding their path, but since I updated nothing wanted to work anymore. The tracks can't be the problem! I can go around manually and there is no problem.
Attachments
Bildschirmfoto 2014-06-30 um 17.21.31.png
Thats just a small part of my system
Bildschirmfoto 2014-06-30 um 17.21.31.png (143.7 KiB) Viewed 2753 times
Bildschirmfoto 2014-06-30 um 17.21.09.png
Bildschirmfoto 2014-06-30 um 17.21.09.png (621.19 KiB) Viewed 2753 times

User avatar
ssilk
Global Moderator
Global Moderator
Posts: 10555
Joined: Tue Apr 16, 2013 10:35 pm
Contact:

Re: [0.9.8] Evil train pathfinding #2

Post by ssilk » Fri Jul 04, 2014 8:27 am

I think without save it isn't possible to debug this.

Please provide a save.
Cool suggestion: Eatable MOUSE-pointers.
Have you used the Advanced Search today?
Need help, question? FAQ - Wiki - Forum help
I still like small signatures...

jakobeng1303
Long Handed Inserter
Long Handed Inserter
Posts: 57
Joined: Thu Jun 19, 2014 12:20 pm
Contact:

Re: [0.9.8] Evil train pathfinding #2

Post by jakobeng1303 » Fri Jul 04, 2014 8:55 am

the only problem is that I can't find my saves. I already looked in several web pages encluding the wiki but all the clues were wrong.

User avatar
ssilk
Global Moderator
Global Moderator
Posts: 10555
Joined: Tue Apr 16, 2013 10:35 pm
Contact:

Re: [0.9.8] Evil train pathfinding #2

Post by ssilk » Fri Jul 04, 2014 10:12 am

Windows? Installed it from ZIP or Install-package? Install package: go into the users folder and make a search on your save-name. :) Look into internet, how you can do a search on some documents you have lost in this windows-kuddelmuddel. :)
Cool suggestion: Eatable MOUSE-pointers.
Have you used the Advanced Search today?
Need help, question? FAQ - Wiki - Forum help
I still like small signatures...

jakobeng1303
Long Handed Inserter
Long Handed Inserter
Posts: 57
Joined: Thu Jun 19, 2014 12:20 pm
Contact:

Re: [0.9.8] Evil train pathfinding #2

Post by jakobeng1303 » Fri Jul 04, 2014 12:16 pm

Nein. Ich verwende einen Mac und im angegeben Verzeichnis befindet sich kein Ordner der irgendwas mit Factorio zu tun hat. Selbst wenn ich den Inhalt von factorio seh find ich nirgendwo irgendwas wo meine Welt gespeichert sein könnte. Hab auch schon alles angeklickt usw..

slpwnd
Factorio Staff
Factorio Staff
Posts: 1836
Joined: Sun Feb 03, 2013 2:51 pm
Contact:

Re: [0.9.8] Evil train pathfinding #2

Post by slpwnd » Fri Jul 04, 2014 2:27 pm

ssilk is right, without the save there is not much I can do. But I would be quite interested in getting it :) So I will put this to pending and when you find it please post it.

User avatar
ssilk
Global Moderator
Global Moderator
Posts: 10555
Joined: Tue Apr 16, 2013 10:35 pm
Contact:

Re: [0.9.8] Evil train pathfinding #2

Post by ssilk » Fri Jul 04, 2014 2:33 pm

Well, under MacOS it is exactly as described.
But you don't see the "Library"-folder by default.
There are some ways out of that. But the easiest is make the the Library folder visible. You can google for that. Example page: http://finerthings.in/featured/lion-lib ... r-visible/

If you have still problems, please PM me.
Cool suggestion: Eatable MOUSE-pointers.
Have you used the Advanced Search today?
Need help, question? FAQ - Wiki - Forum help
I still like small signatures...

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: Google [Bot]