[0.8.7]Performance Drop after Exploring

This subforum contains all the issues which we already resolved.
Post Reply
Balthazar
Long Handed Inserter
Long Handed Inserter
Posts: 86
Joined: Tue Dec 10, 2013 10:58 am
Contact:

[0.8.7]Performance Drop after Exploring

Post by Balthazar »

Okay, trying this again, hopefully less fail. After exploring the top-left part of my map i suddenly had a drop in performance right after running into a big biter town. I thought it might just have been the biters, but after killing them the game still ran slowly. It's not a crippling drop in performance but it IS noticeable from before i ran into the base.

Savegame DL:

http://www.mediafire.com/download/urcq7 ... xplore.rar

kovarex
Factorio Staff
Factorio Staff
Posts: 7431
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [0.8.7]Performance Drop after Exploring

Post by kovarex »

Hello, thank you for the report and mainly for the save.
This is the biggest save I have seen so far.
9k solar panels 15k turrets, and lots of other stuff.
All I can say is, that we can use this save for testing the performance optimisations, I analysed quickly what makes the game slower, and big part of the stuff will be much faster when we implement some of the opmisations we have in mind.
But I didn't find any slowdowns related to enemies and explorations, just the factory machines update times.

P.S. The game was many times slower few versions back, and there was always someone who found the edge of the engine capabilities, and we always used the save to optimise the game to be smooth again in the next update, I believe it will be the case with your save, but until than there is nothing else I can do.

Balthazar
Long Handed Inserter
Long Handed Inserter
Posts: 86
Joined: Tue Dec 10, 2013 10:58 am
Contact:

Re: [0.8.7]Performance Drop after Exploring

Post by Balthazar »

I just found it really really weird because the game wasn't lagging until the exact moment i ran out and explored. The save is at a point where everything is paused, i had the same save running with 6 trains, 4k+ drones derping around and all the production lines running and i've never had a drop in performance before that.

Also as a sidenote you guys are doing an awesome job making this run as well as it's allready doing :D Always wanted to make big factories in buildcraft and performance just always tanked when you got just a coupple of quarries running, can't wait for oil will be sooo sweeet <3<3<3

kovarex
Factorio Staff
Factorio Staff
Posts: 7431
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [0.8.7]Performance Drop after Exploring

Post by kovarex »

I just want to let you know, that I'm not ignoring this and I'm working on the optimising for the few last days.
The game update time (of one tick) in your factory was 29ms (it needs to be less than 15 for fluent game as there are 1000 ms in second and the game is 60 fps).
I was able to get it from these 29ms to 18.2ms on my machine by optimising the logistic network in special case (You had a lot of pending robots that have not a destination for their cargo) and overall electric network update optimisations.
The next thing I need to go for are inserters, they eat a lot even when they have nothing to do.

kovarex
Factorio Staff
Factorio Staff
Posts: 7431
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [0.8.7]Performance Drop after Exploring

Post by kovarex »

So I got to update of 5.5 ms.
In other words, your game will be more than 5 times faster to simulate, so I consider this issue to be closed.

P.S. I have still lot of tricks saved for later :)

Gammro
Filter Inserter
Filter Inserter
Posts: 357
Joined: Wed Oct 09, 2013 1:45 pm
Contact:

Re: [0.8.7]Performance Drop after Exploring

Post by Gammro »

Wow, that is an incredible improvement :o
I'm now really looking forward to 0.9, considering my savegame was also starting to run slower and slower.
Ignore this

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users