[15.34] Crash after: "xrandr_fetch_output" in Arch Linux

Post your bugs and problems so we can fix them.

[15.34] Crash after: "xrandr_fetch_output" in Arch Linux

Postby zangermelon » Fri Oct 13, 2017 3:19 am

Hey,

I am getting the following output when trying to launch the game from steam on Arch Linux.

Code: Select all
   0.000 2017-10-12 19:53:00; Factorio 0.15.34 (build 30875, linux64, steam)
   0.000 Operating system: Linux
   0.000 Program arguments: "/home/jake/.local/share/Steam/steamapps/common/Factorio/bin/x64/factorio" "--fullscreen" "false"
   0.000 Read data path: /home/jake/.local/share/Steam/steamapps/common/Factorio/data
   0.000 Write data path: /home/jake/.factorio
   0.000 Binaries path: /home/jake/.local/share/Steam/steamapps/common/Factorio/bin
   0.003 System info: [CPU: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz, 8 cores, RAM: 16002MB]
   0.004 Display options: [FullScreen: 0] [VSync: 1] [UIScale: 100%] [MultiSampling: OFF] [Screen: 255] [Lang: en]
   0.023 Error CrashHandler.cpp:382: Received SIGSEGV
Factorio crashed. Generating symbolized stacktrace, please wait ...
   0.571 Warning Logger.cpp:413: Symbols.size() == 17, usedSize == 14
#0  0x0000000000a8c3fd in Logger::logStacktrace(StackTraceInfo*) at /tmp/factorio-5rqVNh/src/Util/Logger.cpp:438
#1  0x00000000006f1630 in CrashHandler::writeStackTrace() at /tmp/factorio-5rqVNh/src/Util/CrashHandler.cpp:122
#2  0x00000000006f1ac4 in CrashHandler::SignalHandler(int) at /tmp/factorio-5rqVNh/src/Util/CrashHandler.cpp:384
#3  0x00007fa2c44c0920 in ?? at ??:0
#4  0x00000000010217a2 in _al_vector_ref at /tmp/factorio-5rqVNh/libraries/Allegro/src/misc/vector.c:88
#5  0x0000000001094eca in xrandr_fetch_output at /tmp/factorio-5rqVNh/libraries/Allegro/src/x/xrandr.c:258
#6  0x000000000045bb02 in xrandr_map_adapter at /tmp/factorio-5rqVNh/libraries/Allegro/src/x/xrandr.c:292
#7  0x000000000085ca48 in xrandr_get_monitor_info at /tmp/factorio-5rqVNh/libraries/Allegro/src/x/xrandr.c:659
#8  0x000000000085e3c2 in getPrimaryDisplayIndex at /tmp/factorio-5rqVNh/src/Graphics/Display.cpp:387
#9  0x0000000000e4454b in getGlobalDisplayPreferredScreenIndex at /tmp/factorio-5rqVNh/src/Graphics/Display.cpp:365
#10 0x0000000000e8c477 in Display::Display(short, short) at /tmp/factorio-5rqVNh/src/Graphics/Display.cpp:99
#11 0x0000000000f06323 in GlobalContext::loadAllegro() at /tmp/factorio-5rqVNh/src/GlobalContext.cpp:769
#12 0x00007fa2c44acf6a in GlobalContext::init(bool, bool, bool) [clone .constprop.112650] at /tmp/factorio-5rqVNh/src/GlobalContext.cpp:380
#13 0x000000000040b2e9 in MainLoop::run(boost::filesystem::path const&, boost::filesystem::path const&, bool, bool, bool, std::function<void ()>, boost::filesystem::path const&, MainLoop::HeavyMode) at /tmp/factorio-5rqVNh/src/MainLoop.cpp:221 (discriminator 3)
   1.120 Warning Logger.cpp:413: Symbols.size() == 16, usedSize == 13
   1.120 Error Util.cpp:80: Unexpected error occurred. If you're running the latest version of the game you can help us solve the problem by posting the contents of the log file on the Factorio forums.
Please also include the save file(s), any mods you may be using, and any steps you know of to reproduce the crash.


After a lot of googling, and testing out drivers I still can't get the game to startup.

Here are my installed nvidia drivers
Code: Select all
➜  ~ pacman -Q | grep nvidia
lib32-nvidia-utils 387.12-1
nvidia 387.12-1
nvidia-settings 387.12-1
nvidia-utils 387.12-1

zangermelon
Manual Inserter
Manual Inserter
 
Posts: 4
Joined: Fri Oct 13, 2017 3:15 am

Re: Arch Linux Crash

Postby Loewchen » Fri Oct 13, 2017 3:37 am

Remove the launch options for factorio in steam.
Loewchen
Global Moderator
Global Moderator
 
Posts: 3396
Joined: Wed Jan 07, 2015 5:53 pm

Re: Arch Linux Crash

Postby zangermelon » Fri Oct 13, 2017 3:41 am

Same Thing

Code: Select all
   0.000 2017-10-12 20:40:30; Factorio 0.15.34 (build 30875, linux64, steam)
   0.000 Operating system: Linux
   0.000 Program arguments: "/home/jake/.local/share/Steam/steamapps/common/Factorio/bin/x64/factorio"
   0.000 Read data path: /home/jake/.local/share/Steam/steamapps/common/Factorio/data
   0.000 Write data path: /home/jake/.factorio
   0.000 Binaries path: /home/jake/.local/share/Steam/steamapps/common/Factorio/bin
   0.005 System info: [CPU: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz, 8 cores, RAM: 16002MB]
   0.024 Display options: [FullScreen: 1] [VSync: 1] [UIScale: 100%] [MultiSampling: OFF] [Screen: 255] [Lang: en]
   0.047 Error CrashHandler.cpp:382: Received SIGSEGV
Factorio crashed. Generating symbolized stacktrace, please wait ...
   0.641 Warning Logger.cpp:413: Symbols.size() == 17, usedSize == 14
#0  0x0000000000a8c3fd in Logger::logStacktrace(StackTraceInfo*) at /tmp/factorio-5rqVNh/src/Util/Logger.cpp:438
#1  0x00000000006f1630 in CrashHandler::writeStackTrace() at /tmp/factorio-5rqVNh/src/Util/CrashHandler.cpp:122
#2  0x00000000006f1ac4 in CrashHandler::SignalHandler(int) at /tmp/factorio-5rqVNh/src/Util/CrashHandler.cpp:384
#3  0x00007fb63619f920 in ?? at ??:0
#4  0x00000000010217a2 in _al_vector_ref at /tmp/factorio-5rqVNh/libraries/Allegro/src/misc/vector.c:88
#5  0x0000000001094eca in xrandr_fetch_output at /tmp/factorio-5rqVNh/libraries/Allegro/src/x/xrandr.c:258
#6  0x000000000045bb02 in xrandr_map_adapter at /tmp/factorio-5rqVNh/libraries/Allegro/src/x/xrandr.c:292
#7  0x000000000085ca48 in xrandr_get_monitor_info at /tmp/factorio-5rqVNh/libraries/Allegro/src/x/xrandr.c:659
#8  0x000000000085e3c2 in getPrimaryDisplayIndex at /tmp/factorio-5rqVNh/src/Graphics/Display.cpp:387
#9  0x0000000000e4454b in getGlobalDisplayPreferredScreenIndex at /tmp/factorio-5rqVNh/src/Graphics/Display.cpp:365
#10 0x0000000000e8c477 in Display::Display(short, short) at /tmp/factorio-5rqVNh/src/Graphics/Display.cpp:99
#11 0x0000000000f06323 in GlobalContext::loadAllegro() at /tmp/factorio-5rqVNh/src/GlobalContext.cpp:769
#12 0x00007fb63618bf6a in GlobalContext::init(bool, bool, bool) [clone .constprop.112650] at /tmp/factorio-5rqVNh/src/GlobalContext.cpp:380
#13 0x000000000040b2e9 in MainLoop::run(boost::filesystem::path const&, boost::filesystem::path const&, bool, bool, bool, std::function<void ()>, boost::filesystem::path const&, MainLoop::HeavyMode) at /tmp/factorio-5rqVNh/src/MainLoop.cpp:221 (discriminator 3)
   1.193 Warning Logger.cpp:413: Symbols.size() == 16, usedSize == 13
   1.193 Error Util.cpp:80: Unexpected error occurred. If you're running the latest version of the game you can help us solve the problem by posting the contents of the log file on the Factorio forums.
Please also include the save file(s), any mods you may be using, and any steps you know of to reproduce the crash.

zangermelon
Manual Inserter
Manual Inserter
 
Posts: 4
Joined: Fri Oct 13, 2017 3:15 am

Re: Arch Linux Crash

Postby Loewchen » Fri Oct 13, 2017 3:56 am

Hm, I think this is new. What graphics card do you use? How many monitors? Is your display setup exceptional in a way?
Loewchen
Global Moderator
Global Moderator
 
Posts: 3396
Joined: Wed Jan 07, 2015 5:53 pm

Re: Arch Linux Crash

Postby zangermelon » Fri Oct 13, 2017 4:03 am

I don't think anything is too exciting about my setup other than having 2 additional GPU's in the system.

3 GTX 1070's, 2 monitors plugged into 1 of the 3 gpus, i3 window manager
zangermelon
Manual Inserter
Manual Inserter
 
Posts: 4
Joined: Fri Oct 13, 2017 3:15 am

Re: Arch Linux Crash

Postby wheybags » Fri Oct 13, 2017 9:47 am

Could you maybe try with just one card in the machine? Seems like it's probably some bad handling of multiple gpus being present
User avatar
wheybags
Factorio Staff
Factorio Staff
 
Posts: 12
Joined: Fri Jun 02, 2017 1:50 pm

Re: Arch Linux Crash

Postby wheybags » Fri Oct 13, 2017 1:17 pm

Ok, I tried running the game on a debian box with two nvidia gpus, and couldn't reproduce it.
User avatar
wheybags
Factorio Staff
Factorio Staff
 
Posts: 12
Joined: Fri Jun 02, 2017 1:50 pm

Re: Arch Linux Crash

Postby zangermelon » Wed Oct 18, 2017 5:25 am

I'm still getting this, I have tried with just 1 gpu. Is there any additional information I could provide?
zangermelon
Manual Inserter
Manual Inserter
 
Posts: 4
Joined: Fri Oct 13, 2017 3:15 am


Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 6 guests