[0.12] Bugs, crashes & other issues

The raillayer; must have, if you want to play with railway.

Moderator: Choumiko

Creat
Inserter
Inserter
Posts: 38
Joined: Sun Jun 22, 2014 4:35 pm
Contact:

Re: [0.12] Bugs, crashes & other issues

Post by Creat » Sun May 28, 2017 9:48 pm

I can confirm the issue/conflict with petrochem reported above.

What I wanted to add is that it works fine with 1.0.8 so I have reverted to that for now at least.

Choumiko
Smart Inserter
Smart Inserter
Posts: 1277
Joined: Fri Mar 21, 2014 10:51 pm
Contact:

Re: [0.12] Bugs, crashes & other issues

Post by Choumiko » Mon May 29, 2017 8:47 am

Should be fixed in FARL 1.0.10

1.0.9 was a bad bad release :roll:

TAT3R_
Burner Inserter
Burner Inserter
Posts: 16
Joined: Tue Sep 13, 2016 11:35 am
Contact:

Re: [0.12] Bugs, crashes & other issues

Post by TAT3R_ » Fri Jun 09, 2017 2:05 am

Having an error with farl http://imgur.com/a/hzESA

Choumiko
Smart Inserter
Smart Inserter
Posts: 1277
Joined: Fri Mar 21, 2014 10:51 pm
Contact:

Re: [0.12] Bugs, crashes & other issues

Post by Choumiko » Fri Jun 09, 2017 8:55 am

The problem is More Locomotives, FARL and the others are only shown because they touch/change some stuff that More Locomotives adds.
There has been an update to More Locomotives ~2 hours ago, my game loads fine with FARL and More Locomotives enabled.

NeilN
Inserter
Inserter
Posts: 49
Joined: Sun Mar 27, 2016 4:24 pm
Contact:

Re: [0.12] Bugs, crashes & other issues

Post by NeilN » Mon Jul 03, 2017 7:05 pm

0.15.27 broke my FARL when loading a game. Probably this fix: viewtopic.php?t=50509
Attachments
shot_022.jpg
shot_022.jpg (7.87 KiB) Viewed 2719 times

puresilence2002
Manual Inserter
Manual Inserter
Posts: 2
Joined: Mon Jul 03, 2017 7:43 pm
Contact:

Re: [0.12] Bugs, crashes & other issues

Post by puresilence2002 » Mon Jul 03, 2017 7:48 pm

Update 0.15.27 broke my FARL 1.1.3

Error message is:

Attempt to remote call outside of an event.
stack traceback: __FARL__/control.lua:598: in main chunk

Choumiko
Smart Inserter
Smart Inserter
Posts: 1277
Joined: Fri Mar 21, 2014 10:51 pm
Contact:

Re: [0.12] Bugs, crashes & other issues

Post by Choumiko » Mon Jul 03, 2017 8:37 pm

fixed in the latest version on the mod portal

waduk
Filter Inserter
Filter Inserter
Posts: 362
Joined: Tue Feb 10, 2015 5:44 pm
Contact:

Re: [0.12] Bugs, crashes & other issues

Post by waduk » Tue Jul 04, 2017 12:40 am

Trying the Autopilot feature, then this happened :
Error
Then, after i exit the train, there is a ghost player (FARL player)

Also, on that loco, i use "Shuttle Train Lite mod" in equipment slot alongside with FARL. Could that be the case ?

Choumiko
Smart Inserter
Smart Inserter
Posts: 1277
Joined: Fri Mar 21, 2014 10:51 pm
Contact:

Re: [0.12] Bugs, crashes & other issues

Post by Choumiko » Tue Jul 04, 2017 7:40 am

waduk wrote:Then, after i exit the train, there is a ghost player (FARL player)

Also, on that loco, i use "Shuttle Train Lite mod" in equipment slot alongside with FARL. Could that be the case ?
Fixed in the last update.

Could have been 0.15.27 that broke it, got the same error without the shuttle mod. I'll probably release another one tomorrow that will get rid of the ghost players if an error happens. Should you end up with a ghost player again:
Move your mouse over the locomotive and use /c game.player.selected.driver.destroy() in the console. Or select the player (if it ends up outside of the locomotive) and do /c game.player.selected.destroy()

waduk
Filter Inserter
Filter Inserter
Posts: 362
Joined: Tue Feb 10, 2015 5:44 pm
Contact:

Re: [0.12] Bugs, crashes & other issues

Post by waduk » Tue Jul 04, 2017 10:12 am

Thankfully just before i try the auto-pilot, i saved the game first.

Thanks Choumiko. good to know there's a command to get rid ghost player if it ever happen again (and no backup save)

puresilence2002
Manual Inserter
Manual Inserter
Posts: 2
Joined: Mon Jul 03, 2017 7:43 pm
Contact:

Re: [0.12] Bugs, crashes & other issues

Post by puresilence2002 » Tue Jul 04, 2017 11:59 am

puresilence2002 wrote:Update 0.15.27 broke my FARL 1.1.3

Error message is:

Attempt to remote call outside of an event.
stack traceback: __FARL__/control.lua:598: in main chunk
Just updated FARL. Still 1.1.3 but error is gone. Works like a charm. THX

User avatar
nucleargen
Long Handed Inserter
Long Handed Inserter
Posts: 61
Joined: Sat May 07, 2016 4:51 pm
Contact:

Re: [0.12] Bugs, crashes & other issues

Post by nucleargen » Wed Jul 05, 2017 3:17 am

Found missing locale key for Mirror concrete setting:
GUI.lua, line 355:

Code: Select all

            GUI.add(settings, {type="checkbox", name="mirrorConcrete", caption="Mirror concrete"}, "mirrorConcrete")
The brightest future in the center of a nuclear explosion...2003©nucleargen

Choumiko
Smart Inserter
Smart Inserter
Posts: 1277
Joined: Fri Mar 21, 2014 10:51 pm
Contact:

Re: [0.12] Bugs, crashes & other issues

Post by Choumiko » Wed Jul 05, 2017 2:05 pm

Thanks, I will add it in the next update

aroner
Manual Inserter
Manual Inserter
Posts: 1
Joined: Sun Mar 06, 2016 5:33 pm
Contact:

Re: [0.12] Bugs, crashes & other issues

Post by aroner » Wed Jul 05, 2017 7:19 pm

Error while running event FARL::on_player_driving_changed_state (ID 26)
__FARL__/FARL.lua:276: attempt to compare nil with number
when i try to enter the train it gives me this error, am i doing something wrong?

Choumiko
Smart Inserter
Smart Inserter
Posts: 1277
Joined: Fri Mar 21, 2014 10:51 pm
Contact:

Re: [0.12] Bugs, crashes & other issues

Post by Choumiko » Wed Jul 05, 2017 8:55 pm

FARL requires at least Factorio 0.15.17. The error looks like your version is below that.

spitfire_23
Inserter
Inserter
Posts: 22
Joined: Fri Jun 24, 2016 3:36 am
Contact:

Re: [0.12] Bugs, crashes & other issues

Post by spitfire_23 » Sat Jul 15, 2017 4:46 am

Hi, I'm getting this error in the 'remove stone' function with Factorio 15.30/FARL 1.1.6:

Image

I get that error after a few seconds of driving with mostly default settings. Adding "if product.probability ~= nil" seems to fix it. Using Bob's Mods, Angel's Infinite Ores, few other mods.

CookieSplat
Manual Inserter
Manual Inserter
Posts: 1
Joined: Sat Jul 15, 2017 8:59 am
Contact:

Re: [0.12] Bugs, crashes & other issues

Post by CookieSplat » Sat Jul 15, 2017 9:05 am

spitfire_23 wrote:Hi, I'm getting this error in the 'remove stone' function with Factorio 15.30/FARL 1.1.6:

Image

I get that error after a few seconds of driving with mostly default settings. Adding "if product.probability ~= nil" seems to fix it. Using Bob's Mods, Angel's Infinite Ores, few other mods.
How exactly do you add that? Im getting the same error. Using RSO and Autofill.

Choumiko
Smart Inserter
Smart Inserter
Posts: 1277
Joined: Fri Mar 21, 2014 10:51 pm
Contact:

Re: [0.12] Bugs, crashes & other issues

Post by Choumiko » Sat Jul 15, 2017 11:09 am

Should be fixed in the latest version (1.1.7)

jeron_diovis
Manual Inserter
Manual Inserter
Posts: 2
Joined: Fri Jul 14, 2017 9:31 am
Contact:

Re: [0.12] Bugs, crashes & other issues

Post by jeron_diovis » Sat Jul 15, 2017 11:51 am

It seems that it does not work with higher tiers poles (in my case, from bob's mod). I created blueprint with big pole MK3, loaded it to FARL, but it still places ghost of big pole MK1 and so can't build it.

Choumiko
Smart Inserter
Smart Inserter
Posts: 1277
Joined: Fri Mar 21, 2014 10:51 pm
Contact:

Re: [0.12] Bugs, crashes & other issues

Post by Choumiko » Sat Jul 15, 2017 2:42 pm

jeron_diovis wrote:It seems that it does not work with higher tiers poles (in my case, from bob's mod). I created blueprint with big pole MK3, loaded it to FARL, but it still places ghost of big pole MK1 and so can't build it.
Works for me on latest versions of mods + Factorio
Make sure that both blueprints (horizontal and diagonal) contain the Mk3 pole and that FARL prints something like below after reading the blueprints:

Image

Post Reply

Return to “F.A.R.L”

Who is online

Users browsing this forum: No registered users