[0.18] Please post bugs and balance issues here.

Some mods, made by Bob. Basically streaks every Factroio-area.

Moderator: bobingabout

Post Reply
User avatar
bobingabout
Smart Inserter
Smart Inserter
Posts: 7329
Joined: Fri May 09, 2014 1:01 pm
Contact:

[0.18] Please post bugs and balance issues here.

Post by bobingabout »

The initial run of Bob's mods 0.18 mods have been released.
As usual, if you have any issues related to the 0.18 version of these mods, please list and discuss about them in this sub-forum.
Creator of Bob's mods. Expanding your gameplay since version 0.9.8.
I also have a Patreon.

Bilka
Factorio Staff
Factorio Staff
Posts: 2790
Joined: Sat Aug 13, 2016 9:20 am
Contact:

Re: [0.18] Please post bugs and balance issues here.

Post by Bilka »

Your burner generator uses the same internal name as the base game burner generator. While that isn't a problem in general, it might lead to confusion so I suggest renaming yours (+ your item).
I'm an admin over at https://wiki.factorio.com. Feel free to contact me if there's anything wrong (or right) with it.

User avatar
bobingabout
Smart Inserter
Smart Inserter
Posts: 7329
Joined: Fri May 09, 2014 1:01 pm
Contact:

Re: [0.18] Please post bugs and balance issues here.

Post by bobingabout »

Bilka wrote:
Thu Jan 23, 2020 2:05 pm
Your burner generator uses the same internal name as the base game burner generator. While that isn't a problem in general, it might lead to confusion so I suggest renaming yours (+ your item).
Thanks for taking a look at my mods.
I'll make a note of it for a possible change in future updates.
Creator of Bob's mods. Expanding your gameplay since version 0.9.8.
I also have a Patreon.

Artentus
Filter Inserter
Filter Inserter
Posts: 307
Joined: Sat Sep 24, 2016 8:16 pm
Contact:

Re: [0.18] Please post bugs and balance issues here.

Post by Artentus »

When trying to start Factorio 0.18.1 with Bob's Logistics 0.18.0 I get the following error:

Code: Select all

Failed to load mods: __boblogistics__/data-updates.lua:2: ...blogistics__/prototypes/recipe/robots-recipe-updates.lua:427: attempt to perform arithmetic on global 'bob' (a nil value)
stack traceback:
	...blogistics__/prototypes/recipe/robots-recipe-updates.lua:427: in main chunk
	[C]: in function 'require'
	__boblogistics__/data-updates.lua:2: in main chunk
stack traceback:
	[C]: in function 'require'
	__boblogistics__/data-updates.lua:2: in main chunk
Only enabled mods were Bob's Logistics and Bob's FUnctions Library. But I also tested with a couple other of your mods and same result.
All the other Bob's mods I tested worked fine though.

User avatar
bobingabout
Smart Inserter
Smart Inserter
Posts: 7329
Joined: Fri May 09, 2014 1:01 pm
Contact:

Re: [0.18] Please post bugs and balance issues here.

Post by bobingabout »

Artentus wrote:
Thu Jan 23, 2020 2:30 pm
When trying to start Factorio 0.18.1 with Bob's Logistics 0.18.0 I get the following error:

Code: Select all

Failed to load mods: __boblogistics__/data-updates.lua:2: ...blogistics__/prototypes/recipe/robots-recipe-updates.lua:427: attempt to perform arithmetic on global 'bob' (a nil value)
stack traceback:
	...blogistics__/prototypes/recipe/robots-recipe-updates.lua:427: in main chunk
	[C]: in function 'require'
	__boblogistics__/data-updates.lua:2: in main chunk
stack traceback:
	[C]: in function 'require'
	__boblogistics__/data-updates.lua:2: in main chunk
Only enabled mods were Bob's Logistics and Bob's FUnctions Library. But I also tested with a couple other of your mods and same result.
All the other Bob's mods I tested worked fine though.
I see the error, I forgot to include a name in quotes.
Installing vehicle equipment will solve it for now
Creator of Bob's mods. Expanding your gameplay since version 0.9.8.
I also have a Patreon.

sejbr
Manual Inserter
Manual Inserter
Posts: 2
Joined: Thu Jan 23, 2020 8:50 pm
Contact:

Re: [0.18] Please post bugs and balance issues here.

Post by sejbr »

Hello. There seems to be an incompatibility between Dectorio 0.10.0 and 0.18.0 version of the Warfare mod. Not sure if this is more of a Dectorio issue or Warfare.

Code: Select all

   1.992 Crop bitmaps.
   2.010 Parallel Sprite Loader initialized (threads: 0)
   2.035 Error AtlasSystem.cpp:1499: The given sprite rectangle (left_top=0x0, right_bottom=64x64) is outside the actual sprite size (left_top=0x0, right_bottom=32x32).
If this is being used as an icon you may need to define the icon_size property.: __bobwarfare__/graphics/icons/defender-capsule.png; mods: Dectorio
   2.050 Initial atlas bitmap size is 16384
   2.051 Created atlas bitmap 2048x432 [icon, not-compressed, mipmap, linear-minification, linear-magnification, linear-mip-level]
   2.055 Texture processor created (2048). GPU accelerated compression Supported: yes, Enabled: yes/yes. Test passed. YCoCgDXT PSNR: 35.83, BC3 PSNR: 33.82
   2.058 Parallel Sprite Loader initialized (threads: 7)
   2.075 Sprites loaded
   2.086 Generated mipmaps (5) for atlas [0] of size 2048x432   
   2.086 Custom mipmaps uploaded.
   2.089 Factorio initialised
   2.092 Mods to disable:Failed to load mods: The given sprite rectangle (left_top=0x0, right_bottom=64x64) is outside the actual sprite size (left_top=0x0, right_bottom=32x32).
If this is being used as an icon you may need to define the icon_size property.: __bobwarfare__/graphics/icons/defender-capsule.png

Mods to be disabled:
• Dectorio
 674.316 Quitting: user-quit.
 674.398 Steam API shutdown.
 674.404 Goodbye
Image

User avatar
bobingabout
Smart Inserter
Smart Inserter
Posts: 7329
Joined: Fri May 09, 2014 1:01 pm
Contact:

Re: [0.18] Please post bugs and balance issues here.

Post by bobingabout »

sejbr wrote:
Thu Jan 23, 2020 8:54 pm
Hello. There seems to be an incompatibility between Dectorio 0.10.0 and 0.18.0 version of the Warfare mod. Not sure if this is more of a Dectorio issue or Warfare.

Code: Select all

   1.992 Crop bitmaps.
   2.010 Parallel Sprite Loader initialized (threads: 0)
   2.035 Error AtlasSystem.cpp:1499: The given sprite rectangle (left_top=0x0, right_bottom=64x64) is outside the actual sprite size (left_top=0x0, right_bottom=32x32).
If this is being used as an icon you may need to define the icon_size property.: __bobwarfare__/graphics/icons/defender-capsule.png; mods: Dectorio
   2.050 Initial atlas bitmap size is 16384
   2.051 Created atlas bitmap 2048x432 [icon, not-compressed, mipmap, linear-minification, linear-magnification, linear-mip-level]
   2.055 Texture processor created (2048). GPU accelerated compression Supported: yes, Enabled: yes/yes. Test passed. YCoCgDXT PSNR: 35.83, BC3 PSNR: 33.82
   2.058 Parallel Sprite Loader initialized (threads: 7)
   2.075 Sprites loaded
   2.086 Generated mipmaps (5) for atlas [0] of size 2048x432   
   2.086 Custom mipmaps uploaded.
   2.089 Factorio initialised
   2.092 Mods to disable:Failed to load mods: The given sprite rectangle (left_top=0x0, right_bottom=64x64) is outside the actual sprite size (left_top=0x0, right_bottom=32x32).
If this is being used as an icon you may need to define the icon_size property.: __bobwarfare__/graphics/icons/defender-capsule.png

Mods to be disabled:
• Dectorio
 674.316 Quitting: user-quit.
 674.398 Steam API shutdown.
 674.404 Goodbye
Image

Code: Select all

data.raw.capsule["defender-capsule"].icons =
{
  {
    icon = "__bobwarfare__/graphics/icons/defender-capsule.png",
    icon_size = 32
  },
  {
    icon = "__base__/graphics/icons/defender.png",
    icon_size = 64,
    scale = 0.75 *0.5
  }
}
data.raw.capsule["distractor-capsule"].icons =
{
  {
    icon = "__bobwarfare__/graphics/icons/distractor-capsule.png",
    icon_size = 32
  },
  {
    icon = "__base__/graphics/icons/distractor.png",
    icon_size = 64,
    scale = 0.75 *0.5
  }
}
data.raw.capsule["destroyer-capsule"].icons =
{
  {
    icon = "__bobwarfare__/graphics/icons/destroyer-capsule.png",
    icon_size = 32
  },
  {
    icon = "__base__/graphics/icons/destroyer.png",
    icon_size = 64,
    scale = 0.75 *0.5
  }
}
The file in reference is the same as it has always been in my mods, and this is my only use of it. (I did a Grep search, it's definitely the only instance of the file being used)

If Dectorio tried to change the icon, then my file wouldn't even be used anymore, and my size wouldn't be referenced.
So, I'm guessing it's an error on his part, as all I can think is he must be referencing my file somehow, and setting the wrong icon_size for it.
Creator of Bob's mods. Expanding your gameplay since version 0.9.8.
I also have a Patreon.

sejbr
Manual Inserter
Manual Inserter
Posts: 2
Joined: Thu Jan 23, 2020 8:50 pm
Contact:

Re: [0.18] Please post bugs and balance issues here.

Post by sejbr »

Ok, I'll post the issue on Dectorio github.

User avatar
AmatorPhasma
Fast Inserter
Fast Inserter
Posts: 126
Joined: Sat Aug 05, 2017 8:20 pm
Contact:

Re: [0.18] Please post bugs and balance issues here.

Post by AmatorPhasma »

Hi,

By fixing a similar issue in my mod, I found some small issues with icon scaling/size in some technologies in your mod.

Attached images done with only your mods active.
Attachments
003.PNG
003.PNG (48.11 KiB) Viewed 3497 times
002.PNG
002.PNG (29.43 KiB) Viewed 3497 times
001.PNG
001.PNG (29.87 KiB) Viewed 3497 times

User avatar
AmatorPhasma
Fast Inserter
Fast Inserter
Posts: 126
Joined: Sat Aug 05, 2017 8:20 pm
Contact:

Re: [0.18] Please post bugs and balance issues here.

Post by AmatorPhasma »

sorry forgot a save file, if it is related to a specific mod settings combination. (I think I changed some of them...)

here it is.
Attachments
bob.zip
(1.42 MiB) Downloaded 55 times

jdubz
Manual Inserter
Manual Inserter
Posts: 1
Joined: Fri Jan 24, 2020 3:28 pm
Contact:

Re: [0.18.x] Bob's Mods: General Discussion

Post by jdubz »

Thanks for the fast updates! I'm not sure where to report things like this.

I'm seeing this error on start with boblogistics. I have disabled all other mods.

Image

enchant
Long Handed Inserter
Long Handed Inserter
Posts: 51
Joined: Mon Sep 10, 2018 6:38 pm
Contact:

Re: [0.18.x] Bob's Mods: General Discussion

Post by enchant »

jdubz wrote:
Fri Jan 24, 2020 3:33 pm
I'm seeing this error on start with boblogistics. I have disabled all other mods.
I got the exact same thing.

User avatar
bobingabout
Smart Inserter
Smart Inserter
Posts: 7329
Joined: Fri May 09, 2014 1:01 pm
Contact:

Re: [0.18.x] Bob's Mods: General Discussion

Post by bobingabout »

jdubz wrote:
Fri Jan 24, 2020 3:33 pm
Thanks for the fast updates! I'm not sure where to report things like this.

I'm seeing this error on start with boblogistics. I have disabled all other mods.

Image
Already been reported, I'll fix it soon.
Installing vehicle equipment will solve the problem until I release an update.
Creator of Bob's mods. Expanding your gameplay since version 0.9.8.
I also have a Patreon.

User avatar
bobingabout
Smart Inserter
Smart Inserter
Posts: 7329
Joined: Fri May 09, 2014 1:01 pm
Contact:

Re: [0.18] Please post bugs and balance issues here.

Post by bobingabout »

AmatorPhasma wrote:
Fri Jan 24, 2020 2:31 pm
Hi,

By fixing a similar issue in my mod, I found some small issues with icon scaling/size in some technologies in your mod.

Attached images done with only your mods active.
The screenshots are enough, I know those technologies, so I shouldn't need the save file.

EDIT: there was another 2, and all 5 were in different mods.
Creator of Bob's mods. Expanding your gameplay since version 0.9.8.
I also have a Patreon.

Mecejide
Fast Inserter
Fast Inserter
Posts: 165
Joined: Mon Sep 23, 2019 8:12 pm
Contact:

Re: [0.18] Please post bugs and balance issues here.

Post by Mecejide »

The base game battery is made in a chemical plant, but your batteries are made in an assembling machine.

User avatar
AmatorPhasma
Fast Inserter
Fast Inserter
Posts: 126
Joined: Sat Aug 05, 2017 8:20 pm
Contact:

Re: [0.18] Please post bugs and balance issues here.

Post by AmatorPhasma »

Quick and small note: two things that break with 0.18.02 sound changes.

Code: Select all

   1.097 Error ModManager.cpp:1385: Failed to load mod "bobenemies": __bobenemies__/data.lua:9: __bobenemies__/prototypes/biters.lua:91: attempt to call global 'make_biter_roars' (a nil value)
stack traceback:
	__bobenemies__/prototypes/biters.lua:91: in main chunk
	[C]: in function 'require'
	__bobenemies__/data.lua:9: in main chunk
stack traceback:
	[C]: in function 'require'
	__bobenemies__/data.lua:9: in main chunk
   1.099 Loading mod core 0.0.0 (data.lua)
   1.202 Checksum for core: 1993663991
   1.286 Error ModManager.cpp:1385: Error in assignID, recipe-category with name 'crafting' does not exist.

Source: default (utility-sprites).
   1.353 Initial atlas bitmap size is 16384
   1.353 Created atlas bitmap 2048x448 [icon, not-compressed, mipmap, linear-minification, linear-magnification, linear-mip-level]
   1.353 Created virtual atlas pages 4096x4096x0
   1.359 Texture processor created (2048). GPU accelerated compression Supported: yes, Enabled: yes/yes. Test passed. YCoCgDXT PSNR: 35.83, BC3 PSNR: 33.82
   1.366 Parallel Sprite Loader initialized (threads: 11)
   1.389 Sprites loaded
   1.400 Generated mipmaps (5) for atlas [0] of size 2048x448   
   1.400 Custom mipmaps uploaded.
   1.405 Factorio initialised
   1.405 Mods to disable:Failed to load mods: __bobenemies__/data.lua:9: __bobenemies__/prototypes/biters.lua:91: attempt to call global 'make_biter_roars' (a nil value)
stack traceback:
	__bobenemies__/prototypes/biters.lua:91: in main chunk
	[C]: in function 'require'
	__bobenemies__/data.lua:9: in main chunk
stack traceback:
	[C]: in function 'require'
	__bobenemies__/data.lua:9: in main chunk

Mods to be disabled:
• bobenemies

Code: Select all

   3.660 Error ModManager.cpp:1385: Failed to load mod "boblogistics": __boblogistics__/data.lua:31: __boblogistics__/prototypes/entity/robots.lua:186: attempt to call global 'flying_robot_sounds' (a nil value)
stack traceback:
	__boblogistics__/prototypes/entity/robots.lua:186: in main chunk
	[C]: in function 'require'
	__boblogistics__/data.lua:31: in main chunk
stack traceback:
	[C]: in function 'require'
	__boblogistics__/data.lua:31: in main chunk
   3.662 Loading mod core 0.0.0 (data.lua)
   3.779 Checksum for core: 1993663991
   3.864 Error ModManager.cpp:1385: Error in assignID, recipe-category with name 'crafting' does not exist.

Source: default (utility-sprites).
   3.930 Initial atlas bitmap size is 16384
   3.931 Created atlas bitmap 2048x448 [icon, not-compressed, mipmap, linear-minification, linear-magnification, linear-mip-level]
   3.931 Created virtual atlas pages 4096x4096x0
   3.936 Texture processor created (2048). GPU accelerated compression Supported: yes, Enabled: yes/yes. Test passed. YCoCgDXT PSNR: 35.83, BC3 PSNR: 33.82
   3.943 Parallel Sprite Loader initialized (threads: 11)
   3.965 Sprites loaded
   3.976 Generated mipmaps (5) for atlas [0] of size 2048x448   
   3.976 Custom mipmaps uploaded.
   3.981 Factorio initialised
   3.981 Mods to disable:Failed to load mods: __boblogistics__/data.lua:31: __boblogistics__/prototypes/entity/robots.lua:186: attempt to call global 'flying_robot_sounds' (a nil value)
stack traceback:
	__boblogistics__/prototypes/entity/robots.lua:186: in main chunk
	[C]: in function 'require'
	__boblogistics__/data.lua:31: in main chunk
stack traceback:
	[C]: in function 'require'
	__boblogistics__/data.lua:31: in main chunk

Mods to be disabled:
• boblogistics

galibert
Inserter
Inserter
Posts: 40
Joined: Fri Sep 15, 2017 7:42 am
Contact:

Re: [0.18] Please post bugs and balance issues here.

Post by galibert »

Today's update (0.18.2) broke all/most of the mods with a missing sound file issue.

OG.

User avatar
bobingabout
Smart Inserter
Smart Inserter
Posts: 7329
Joined: Fri May 09, 2014 1:01 pm
Contact:

Re: [0.18] Please post bugs and balance issues here.

Post by bobingabout »

AmatorPhasma wrote:
Tue Jan 28, 2020 3:01 pm
Quick and small note: two things that break with 0.18.02 sound changes.
it broke warfare too, working on fixing it now.
Creator of Bob's mods. Expanding your gameplay since version 0.9.8.
I also have a Patreon.

Isengrinn
Manual Inserter
Manual Inserter
Posts: 3
Joined: Mon May 20, 2019 9:52 pm
Contact:

Re: [0.18] Please post bugs and balance issues here.

Post by Isengrinn »

Same issue with entity demo-sound, I downgrade bobsennemi, bobswarframe and bobslogistic, the problem is solve (maybe not all 3 mods are implicated)

User avatar
bobingabout
Smart Inserter
Smart Inserter
Posts: 7329
Joined: Fri May 09, 2014 1:01 pm
Contact:

Re: [0.18] Please post bugs and balance issues here.

Post by bobingabout »

Isengrinn wrote:
Fri Jan 31, 2020 7:30 pm
Same issue with entity demo-sound, I downgrade bobsennemi, bobswarframe and bobslogistic, the problem is solve (maybe not all 3 mods are implicated)
Downgrade?
That would mean you're using the latest version of the mods with an older version of the game?
Creator of Bob's mods. Expanding your gameplay since version 0.9.8.
I also have a Patreon.

Post Reply

Return to “Bob's mods”