[Windows 7] Error trying login in game "InitializeSecurityContext failed: SEC_E_ILLEGAL_MESSAGE"

Anything that prevents you play the game properly. Do you have issues with paying for the game, downloading it or properly running it on your computer? Let us know here.
xenapan
Burner Inserter
Burner Inserter
Posts: 5
Joined: Tue Apr 30, 2019 8:52 pm
Contact:

[Windows 7] Error trying login in game "InitializeSecurityContext failed: SEC_E_ILLEGAL_MESSAGE"

Post by xenapan »

This is the error:
Getting a failed to reach auth server. Code 520. Error: schannel: next InitizalizeSecurityContext failed: SEC_E_ILLEGAL_MESSAGE(0X80090326) - This error usually occurs when a fatal SSL/TLS alsert is recieved (e.g. handshake failed.) More detail may be availible in the Windows System event log.
I'm getting it when I first load the game (it asks me to login). It will also happen when I try to login for access to the mod list.
According to another thread I tried refreshing my dns and restarting. (same error)
I've made sure factorio ss listed in the windows firewall exception.
I've checked the windows event log but I don't see any errors regarding this (maybe I'm not looking in the right place? but i filtered it down using source and time when I generate the error - factorio is not listed and there are no errors for the right time)

Any thoughts on how I can fix this?
Thanks!
Last edited by xenapan on Thu Aug 05, 2021 8:11 pm, edited 1 time in total.

Loewchen
Global Moderator
Global Moderator
Posts: 7183
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: Fresh install - can't logon [1.1.36 build 58829 win64] [win7]

Post by Loewchen »

Post the complete log after a session with the issue. Can you login on factorio.com with your credentials?

xenapan
Burner Inserter
Burner Inserter
Posts: 5
Joined: Tue Apr 30, 2019 8:52 pm
Contact:

Re: Fresh install - can't logon [1.1.36 build 58829 win64] [win7]

Post by xenapan »

Yes. No issues logging into the website (thats how I got the download so I know my username/password works)

log file is attached but I didn't see anything other than the error on it.
Attachments
factorio-current.log
(6.36 KiB) Downloaded 103 times

epaaj
Manual Inserter
Manual Inserter
Posts: 2
Joined: Fri Aug 06, 2021 11:05 am
Contact:

Re: [1.1.36][win7] Error trying login in game "InitializeSecurityContext failed: SEC_E_ILLEGAL_MESSAGE"

Post by epaaj »

I am also having this problem. It worked fine yesterday around 12:30 (UTC+2).
But today I get the same error message as xenapan. Also on Windows 7. My guess would be an certificate issue but I'm not sure what I can do. Have we reached the point where Windows 7 is not longer supported? By whoever created this certificate?

My friends on Windows 10 have no problems at all.
Attachments
factorio-current.log
(5.7 KiB) Downloaded 74 times

Loewchen
Global Moderator
Global Moderator
Posts: 7183
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: [1.1.36][win7] Error trying login in game "InitializeSecurityContext failed: SEC_E_ILLEGAL_MESSAGE"

Post by Loewchen »

epaaj wrote:
Fri Aug 06, 2021 11:13 am
...
Did you logout or how did you get the login prompt? Check if your player-data.json has your service token filled out, you might be able to bypass the issue by adding it manually.

Twinsen
Factorio Staff
Factorio Staff
Posts: 1235
Joined: Tue Sep 23, 2014 7:10 am
Contact:

Re: [1.1.36][win7] Error trying login in game "InitializeSecurityContext failed: SEC_E_ILLEGAL_MESSAGE"

Post by Twinsen »

Both errors are on Windows 7 SP1 which is indeed very old. Updating to a newer service pack should solve the issue.

Nonetheless if anyone else is having the issue and has more details, such as the error in the Windows event log, feel free to post.

Loewchen
Global Moderator
Global Moderator
Posts: 7183
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: [1.1.36][win7] Error trying login in game "InitializeSecurityContext failed: SEC_E_ILLEGAL_MESSAGE"

Post by Loewchen »

The latest version of Windows 7 still identifies as SP1.

User avatar
kenzo88
Burner Inserter
Burner Inserter
Posts: 5
Joined: Fri Aug 06, 2021 3:24 pm
Contact:

Re: [1.1.36][win7] Error trying login in game "InitializeSecurityContext failed: SEC_E_ILLEGAL_MESSAGE"

Post by kenzo88 »

hi , i got the same issue , and honestly i don't understand this kind of error, is not really possible to have access to the game with windows 7? I'm sorry but i don't want to install windows 10 . I just bought the game and it looks awesome and i wanted to play with a friend , and for what i can say , i tried to log yesterday and for a moment i was able to see the public servers and also i was able to download mods , so , i think is an issue that can be solved.

@Loewchen sadly filling service-token in the player-data.json does not work (i also tried to set the file to read only, it creates a backup and creates a new one with the token removed).

I'm trying to update windows 7 btw.

Khornar
Manual Inserter
Manual Inserter
Posts: 2
Joined: Wed Sep 09, 2020 11:00 am
Contact:

Re: [1.1.36][win7] Error trying login in game "InitializeSecurityContext failed: SEC_E_ILLEGAL_MESSAGE"

Post by Khornar »

Same problem.
First it started as multiplayer games browser error
Image
In my infinite wisdom, i've log out and got this as an error
Image
Log included.
Same error on standalone(1.36) and steam (1.37 experimental) clients.
And yes, i'm on Win 7.
Everything was fine yesterday.
Attachments
factorio-current.log
(42.73 KiB) Downloaded 58 times

User avatar
kenzo88
Burner Inserter
Burner Inserter
Posts: 5
Joined: Fri Aug 06, 2021 3:24 pm
Contact:

Re: [1.1.36][win7] Error trying login in game "InitializeSecurityContext failed: SEC_E_ILLEGAL_MESSAGE"

Post by kenzo88 »

Khornar wrote:
Fri Aug 06, 2021 4:07 pm
Same problem.
First it started as multiplayer games browser error
Image
In my infinite wisdom, i've log out and got this as an error
Image
Log included.
Same error on standalone(1.36) and steam (1.37 experimental) clients.
And yes, i'm on Win 7.
Everything was fine yesterday.
Yeah i remember , same thing happened to me first with the browser error , and then like you the same error below

User avatar
Klonan
Factorio Staff
Factorio Staff
Posts: 4985
Joined: Sun Jan 11, 2015 2:09 pm
Contact:

Re: [1.1.36][win7] Error trying login in game "InitializeSecurityContext failed: SEC_E_ILLEGAL_MESSAGE"

Post by Klonan »

Seems it might be due to our server provider Heroku updating their security prototcols, we are looking into how to fix it

EDIT: Update windows 7 to fix it: https://www.techspot.com/downloads/6676 ... pdate.html

User avatar
kenzo88
Burner Inserter
Burner Inserter
Posts: 5
Joined: Fri Aug 06, 2021 3:24 pm
Contact:

Re: [1.1.36][win7] Error trying login in game "InitializeSecurityContext failed: SEC_E_ILLEGAL_MESSAGE"

Post by kenzo88 »

Klonan wrote:
Fri Aug 06, 2021 4:22 pm
Seems it might be due to our server provider Heroku updating their security prototcols, we are looking into how to fix it
thank you klonan , i'm the same guy who sent you an email this morning , i think it was you who answered :)

User avatar
kenzo88
Burner Inserter
Burner Inserter
Posts: 5
Joined: Fri Aug 06, 2021 3:24 pm
Contact:

Re: [1.1.36][win7] Error trying login in game "InitializeSecurityContext failed: SEC_E_ILLEGAL_MESSAGE"

Post by kenzo88 »

guys : i don't know if the issue was fixed or what,but i can say that i updated my windows 7 and now i am able to log in , or at least for now the game recognized my steam profile.

epaaj
Manual Inserter
Manual Inserter
Posts: 2
Joined: Fri Aug 06, 2021 11:05 am
Contact:

Re: [1.1.36][win7] Error trying login in game "InitializeSecurityContext failed: SEC_E_ILLEGAL_MESSAGE"

Post by epaaj »

Loewchen wrote:
Fri Aug 06, 2021 11:45 am
epaaj wrote:
Fri Aug 06, 2021 11:13 am
...
Did you logout or how did you get the login prompt? Check if your player-data.json has your service token filled out, you might be able to bypass the issue by adding it manually.
I used a fresh version of Factorio I just downloaded from the website for the log file. I have a service token in my regular profile which I launch through Steam. I wanted to see if it was a Steam related problem or not. It seems it is not as both versions have the same error. And I still se this error just now.

I opened Event Viewer and then clicked on "System" but I cant find anything related. No new event seems to have fired when trying to log in into Factorio. I don't have much experience with looking in the Event Viewer but as far as I can see there's nothing related to this issue there on my system.

I guess I have to boot up Linux for the evening playing session. Hopefully that should work fine.

xenapan
Burner Inserter
Burner Inserter
Posts: 5
Joined: Tue Apr 30, 2019 8:52 pm
Contact:

Re: [1.1.36][win7] Error trying login in game "InitializeSecurityContext failed: SEC_E_ILLEGAL_MESSAGE"

Post by xenapan »

kenzo88 wrote:
Fri Aug 06, 2021 4:51 pm
guys : i don't know if the issue was fixed or what,but i can say that i updated my windows 7 and now i am able to log in , or at least for now the game recognized my steam profile.
what did you update on your windows7? Thats a pretty huge list of things you could have updated.

Mine still doesn't work. Tried filling out the player.json file too. Still nothing.

User avatar
kenzo88
Burner Inserter
Burner Inserter
Posts: 5
Joined: Fri Aug 06, 2021 3:24 pm
Contact:

Re: [1.1.36][win7] Error trying login in game "InitializeSecurityContext failed: SEC_E_ILLEGAL_MESSAGE"

Post by kenzo88 »

xenapan wrote:
Sun Aug 08, 2021 6:59 am
kenzo88 wrote:
Fri Aug 06, 2021 4:51 pm
guys : i don't know if the issue was fixed or what,but i can say that i updated my windows 7 and now i am able to log in , or at least for now the game recognized my steam profile.
what did you update on your windows7? Thats a pretty huge list of things you could have updated.

Mine still doesn't work. Tried filling out the player.json file too. Still nothing.
i updated all what i could

Khornar
Manual Inserter
Manual Inserter
Posts: 2
Joined: Wed Sep 09, 2020 11:00 am
Contact:

Re: [1.1.36][win7] Error trying login in game "InitializeSecurityContext failed: SEC_E_ILLEGAL_MESSAGE"

Post by Khornar »

xenapan wrote:
Sun Aug 08, 2021 6:59 am
kenzo88 wrote:
Fri Aug 06, 2021 4:51 pm
guys : i don't know if the issue was fixed or what,but i can say that i updated my windows 7 and now i am able to log in , or at least for now the game recognized my steam profile.
what did you update on your windows7? Thats a pretty huge list of things you could have updated.

Mine still doesn't work. Tried filling out the player.json file too. Still nothing.
I've installed all "important" windows updates (except the 2020 one, since it only adds a reminder that Win7 is no longer supported), and it works now.
I've also installed kb3140245 prior to that (no idea if it matters).

Honktown
Filter Inserter
Filter Inserter
Posts: 839
Joined: Thu Oct 03, 2019 7:10 am
Contact:

Re: [Windows 7] Error trying login in game "InitializeSecurityContext failed: SEC_E_ILLEGAL_MESSAGE"

Post by Honktown »

I just got this message - I haven't tried multiplayer in some days, though I did download mods recently (past few days). Nothing in the Event Viewer. I am on Windows 7 as well. Logged out (of Factorio) and tried to log back in, only to receive the same message and now I'm stuck logged out.
I have mods! I guess!
Link

posila
Factorio Staff
Factorio Staff
Posts: 5114
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [Windows 7] Error trying login in game "InitializeSecurityContext failed: SEC_E_ILLEGAL_MESSAGE"

Post by posila »

Honktown wrote:
Fri Aug 13, 2021 12:23 am
I just got this message - I haven't tried multiplayer in some days, though I did download mods recently (past few days). Nothing in the Event Viewer. I am on Windows 7 as well. Logged out (of Factorio) and tried to log back in, only to receive the same message and now I'm stuck logged out.
Can you try to install kb3140245?

Honktown
Filter Inserter
Filter Inserter
Posts: 839
Joined: Thu Oct 03, 2019 7:10 am
Contact:

Re: [Windows 7] Error trying login in game "InitializeSecurityContext failed: SEC_E_ILLEGAL_MESSAGE"

Post by Honktown »

posila wrote:
Fri Aug 13, 2021 4:43 am
Honktown wrote:
Fri Aug 13, 2021 12:23 am
I just got this message - I haven't tried multiplayer in some days, though I did download mods recently (past few days). Nothing in the Event Viewer. I am on Windows 7 as well. Logged out (of Factorio) and tried to log back in, only to receive the same message and now I'm stuck logged out.
Can you try to install kb3140245?
Didn't work. There are many other updates pending so I'll try to get everything and respond. (it's failing constantly, this'll be a while)
I have mods! I guess!
Link

Post Reply

Return to “Technical Help”