[1.1.34] Server error: Cannot send to IPv6 addresses when IPv6 socket is closed

Anything that prevents you play the game properly. Do you have issues with paying for the game, downloading it or properly running it on your computer? Let us know here.
Post Reply
oof2win2
Inserter
Inserter
Posts: 31
Joined: Wed Nov 18, 2020 8:13 am
Contact:

[1.1.34] Server error: Cannot send to IPv6 addresses when IPv6 socket is closed

Post by oof2win2 »

Hi. My server crashed when an IPv6 connection was attempted to be initiated. Not sure how this happened, as the host system doesn't have IPv6 enabled at all.

Anyways, I think that servers should definitely not crash when they attempt to create an IPv6 connection and no address is assigned to them.

Here is the line that it logged when crashing, otherwise it looks normal. Log file attached.
17342.081 Error Util.cpp:83: Cannot send to IPv6 addresses when IPv6 socket is closed
Attachments
factorio-current.log
(34.51 KiB) Downloaded 385 times

Rseding91
Factorio Staff
Factorio Staff
Posts: 11857
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [1.1.34] Server error: Cannot send to IPv6 addresses when IPv6 socket is closed

Post by Rseding91 »

As far as I know in order for a server to respond to an IPv6 connection attempt it has to have an IPv6 socket open and listening. So that means it would have gotten the connection attempt on the IPv6 socket and then tried to respond on it and it was closed. I have no idea how that would ever happen.

Has this server ever worked in the past? Did this just start happening some time recently?
If you want to get ahold of me I'm almost always on Discord.

oof2win2
Inserter
Inserter
Posts: 31
Joined: Wed Nov 18, 2020 8:13 am
Contact:

Re: [1.1.34] Server error: Cannot send to IPv6 addresses when IPv6 socket is closed

Post by oof2win2 »

This server has been online running Factorio (with updates etc.) since the start of Covid (March 2020) or maybe even before. Since I got admin access (summer 2020), nothing like this has happened to my knowledge. It is five servers running concurrently with different modpacks, some vanilla, some are scenarios only (appears like vanilla in the browser). Throughout this whole time, IPv6 has been disabled on the server itself (no IPv6 connections are allowed at all). Not sure what caused this to happen, but yeah, it's pretty recent (like this case only?). I'm not sure, but could it be related to the issue that Gerkiz talked about with you on Discord?

Post Reply

Return to “Technical Help”