[1.0.0] Bots no longer picking up stuff game freezing after a while

Anything that prevents you play the game properly. Do you have issues with paying for the game, downloading it or properly running it on your computer? Let us know here.
Post Reply
Aya
Burner Inserter
Burner Inserter
Posts: 7
Joined: Sun Jun 21, 2020 12:35 pm
Contact:

[1.0.0] Bots no longer picking up stuff game freezing after a while

Post by Aya »

What did you do? / What happened?
I've been running this base for about 3 years I think. Last night after doing some maintenance in outposts I saved the game and went to sleep.
In the morning I noticed I was standing next to a miner that was marked for deletion but my bots weren't picking it up.
I thought this was strange but proceeded to remove it by hand. Next I took a train to another station and the game started to slow down until a point it would just lock up.
I tried reloading the save but the same thing hapened. I could place an item on the ground but my bots would not pick it up.
As a final resort I reloaded a savegame from yesterday and waited half a day to see what would happen but the same issue came up again.
I removed all mods (the only gamechanging mod is waterwell). But still the same issue would appear.
I asked someone in discord to try my save and the same thing hapened.

What did you expect to happen instead? It might be obvious to you, but do it anyway!
I was hoping to be able to place bots and the game not crashing on me :)

Does it happen always, once, or sometimes?
It keeps hapening.
This is me showing the first sympthoms: http://ayaya.be/2020-11-15_13-42-16.mkv
This is my save: http://www.ayaya.be/18-UltraRich-2020-11-15-007b.zip
This is my logfile: http://ayaya.be/factorio-current.log

DScoffers
Inserter
Inserter
Posts: 33
Joined: Fri Sep 23, 2016 1:24 pm
Contact:

Re: [1.0.0] Bots no longer picking up stuff game freezing after a while

Post by DScoffers »

Weird.
I've tried downloading the map and I get the same bug without any mods installed. (Fresh install 1.1.3)
If you mark hundreds of entities for deconstruction they do get a red cross on them, but then the red crosses quickly get removed one by one.
It even sets trains to manual when trying to deconstruct them.

(By the way, I love the consistency on the 1000 hour Production statistics)

orzelek
Smart Inserter
Smart Inserter
Posts: 3783
Joined: Fri Apr 03, 2015 10:20 am
Contact:

Re: [1.0.0] Bots no longer picking up stuff game freezing after a while

Post by orzelek »

I'd go with a bug here.. unless mod could have changed something that remains changed in saved file after mod is no longer present.

It's strange... mark trees for deconstruction near you and x's vanish quite quickly with no other reaction.

Loewchen
Global Moderator
Global Moderator
Posts: 6469
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: [1.0.0] Bots no longer picking up stuff game freezing after a while

Post by Loewchen »

Can someone check how many ticks the save has run?

Rseding91
Factorio Staff
Factorio Staff
Posts: 11523
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [1.0.0] Bots no longer picking up stuff game freezing after a while

Post by Rseding91 »

orzelek wrote:
Wed Dec 02, 2020 5:50 pm
I'd go with a bug here.. unless mod could have changed something that remains changed in saved file after mod is no longer present.

It's strange... mark trees for deconstruction near you and x's vanish quite quickly with no other reaction.
Deconstruction time to live is part of the save and something mods can adjust.
If you want to get ahold of me I'm almost always on Discord.

DScoffers
Inserter
Inserter
Posts: 33
Joined: Fri Sep 23, 2016 1:24 pm
Contact:

Re: [1.0.0] Bots no longer picking up stuff game freezing after a while

Post by DScoffers »

The playtime is over 19,881 hours!!
So some quick mental arithmetic tells me that’s over 4.3 billion ticks.

Post Reply

Return to “Technical Help”

Who is online

Users browsing this forum: MbraY