Multiplayer game inside GUI binds to temporary IPv6

Anything that prevents you play the game properly. Do you have issues with paying for the game, downloading it or properly running it on your computer? Let us know here.
Post Reply
xZise
Manual Inserter
Manual Inserter
Posts: 1
Joined: Sat Oct 03, 2020 1:06 pm
Contact:

Multiplayer game inside GUI binds to temporary IPv6

Post by xZise »

Hello all,

I was trying to play with my brother yesterday using IPv6 (because I'm behind a CGNAT I cannot use IPv4). I'm on Windows 10 and used ipconfig to get my IPv6 addresses and my brother tried to connect to it. After some attempts I was looking at Wireshark what is actually happening and noticed that packets arrived on the correct IPv6 address (so there was no typo on his side) but Factorio was responding on my temporary IPv6 address. After I saw that I instructed him to use that address and it worked flawlessly.

Now I'm not 100% sure how IPv6 is actually working and whether this is normal behaviour, but it strikes me as odd. I wanted to give my brother a (more) permanent IPv6 address so that he could just connect to it the next time. So do I need to set up a headless server to bind it to a certain IPv6 address (maybe using the command line option "--bind") or is there some other option I need to turn on?

Thanks for you help in advance!

PS: 2a02:8108:...:2b is my brothers IPv6 while 2a02:8108:...:c308 (temporary) and 2a02:8108:...:41ca are my IP addresses.
Attachments
failed factorio.png
failed factorio.png (74.87 KiB) Viewed 77 times

Post Reply

Return to “Technical Help”

Who is online

Users browsing this forum: No registered users