[0.16.51] Sudden Performance Troubles

Anything that prevents you play the game properly. Do you have issues with paying for the game, downloading it or properly running it on your computer? Let us know here.
Post Reply
Hellkeeper
Burner Inserter
Burner Inserter
Posts: 14
Joined: Tue Jan 08, 2019 9:15 pm
Contact:

[0.16.51] Sudden Performance Troubles

Post by Hellkeeper » Fri Feb 01, 2019 3:09 pm

Hey there,
since yesterday I got massive Client Performance Troubles with one of my Maps (Game is hosted on Headless Linux Server) - and I struggle to find out what's causing the massive Drop in FPS! :-/
Maybe one of you can give me an Hint based on this info?

It's flucuating from 60 FPS down to 5FPS and up again (unregular)
9fps.jpg
9fps.jpg (404.73 KiB) Viewed 250 times
60fps.jpg
60fps.jpg (293.44 KiB) Viewed 250 times
thx, bye from Austria
Andreas

Eiermann
Burner Inserter
Burner Inserter
Posts: 14
Joined: Tue Jan 08, 2019 7:27 am
Contact:

Re: [0.16.51] Sudden Performance Troubles

Post by Eiermann » Fri Feb 01, 2019 3:57 pm

Maybe related: viewtopic.php?t=64418

You should upload your save-game + logs.

Loewchen
Global Moderator
Global Moderator
Posts: 4738
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: [0.16.51] Sudden Performance Troubles

Post by Loewchen » Fri Feb 01, 2019 4:25 pm

It's the standard "falling behind the server" issue, see the FAQ.

Hellkeeper
Burner Inserter
Burner Inserter
Posts: 14
Joined: Tue Jan 08, 2019 9:15 pm
Contact:

Re: [0.16.51] Sudden Performance Troubles

Post by Hellkeeper » Mon Feb 04, 2019 10:18 am

Loewchen - you nailed it ... it's excactly the "falling behind Server Problem" ... thx!
Sometimes I need to go to Game Speed 0.65 - not fun :-(

Even i'm a bit puzzled WHY this is happening - Task Manager shows that no CPU Core is maxed out (70-80% max Single-Core usage), enough free Memory, GPU usage is ~10-20% ...
Any chances to debug this further to find the "source" of this Problem? Would be a real pitty if we had to ditch this World because of those Performance Problems :-(

thx, bye from sunny Austria
Andreas

User avatar
BlueTemplar
Fast Inserter
Fast Inserter
Posts: 237
Joined: Fri Jun 08, 2018 2:16 pm
Contact:

Re: [0.16.51] Sudden Performance Troubles

Post by BlueTemplar » Mon Feb 04, 2019 11:12 am

Have you tried lowering Atlas Texture Size ?
(And generally lowering various graphic settings...)

Hellkeeper
Burner Inserter
Burner Inserter
Posts: 14
Joined: Tue Jan 08, 2019 9:15 pm
Contact:

Re: [0.16.51] Sudden Performance Troubles

Post by Hellkeeper » Mon Feb 04, 2019 12:18 pm

Hey BlueTemplar.

currently I'm running with those Settings:
2.jpg
2.jpg (65.18 KiB) Viewed 186 times
Will test Atlas Size later ...

Already killed all Enemies in sight - brought Game-Speed back up to ~0,75-0,80 instead of ~0,65-0,70
But still not where I want to be ... ;-)

User avatar
BlueTemplar
Fast Inserter
Fast Inserter
Posts: 237
Joined: Fri Jun 08, 2018 2:16 pm
Contact:

Re: [0.16.51] Sudden Performance Troubles

Post by BlueTemplar » Mon Feb 04, 2019 8:12 pm

English would be better :P

Jap2.0
Smart Inserter
Smart Inserter
Posts: 1857
Joined: Tue Jun 20, 2017 12:02 am
Contact:

Re: [0.16.51] Sudden Performance Troubles

Post by Jap2.0 » Mon Feb 04, 2019 10:30 pm

BlueTemplar wrote:
Mon Feb 04, 2019 8:12 pm
English would be better :P
Come on, you don't have the exact positions of everything in the graphics menu memorized?
There are 10 types of people: those who get this joke and those who don't.

Hellkeeper
Burner Inserter
Burner Inserter
Posts: 14
Joined: Tue Jan 08, 2019 9:15 pm
Contact:

Re: [0.16.51] Sudden Performance Troubles

Post by Hellkeeper » Wed Feb 06, 2019 8:39 am

tried with smaller Atlas Size - no luck at all ... also tried several other Settings ... all without any luck ... :-/
After testwise deleting the Main Bus ... well ... of course it went back up to 60 FPS/UPS ... but it's not really purposeful to play Factorio without Bus ... :roll: :lol:

Zavian
Smart Inserter
Smart Inserter
Posts: 1281
Joined: Thu Mar 02, 2017 2:57 am
Contact:

Re: [0.16.51] Sudden Performance Troubles

Post by Zavian » Wed Feb 06, 2019 8:56 am

Well looking at the first screenshot you posted in the OP, the game update part of the tick is taking around 15.24 ms. In order to run at 60 UPS, your computer needs to finish this in less than 16.66ms (less once you consider that rendering also takes time, and cpu cycles).

So no matter how much effort you put into optimising rendering, what you really need to do move to a more ups efficient base design. I would start thinking about what active entities you can reduce (eg inserters, assemblers, pipes, belts, etc). That is part of why people move to a beacon + module base, because that allows them to increase production without increasing the number of active entities. It is also why people move from nuclear to solar, since solar is essentially free from a UPS perspective, whilst nuclear needs on lots of pipes and heat pipes which use lots of cpu cycles every tick.

Eiermann
Burner Inserter
Burner Inserter
Posts: 14
Joined: Tue Jan 08, 2019 7:27 am
Contact:

Re: [0.16.51] Sudden Performance Troubles

Post by Eiermann » Wed Feb 06, 2019 1:30 pm

Zavian wrote:
Wed Feb 06, 2019 8:56 am
So no matter how much effort you put into optimising rendering, what you really need to do move to a more ups efficient base design. I would start thinking about what active entities you can reduce (eg inserters, assemblers, pipes, belts, etc). That is part of why people move to a beacon + module base, because that allows them to increase production without increasing the number of active entities. It is also why people move from nuclear to solar, since solar is essentially free from a UPS perspective, whilst nuclear needs on lots of pipes and heat pipes which use lots of cpu cycles every tick.
Do you have any good sources for ups-efficent base building / planning?

Loewchen
Global Moderator
Global Moderator
Posts: 4738
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: [0.16.51] Sudden Performance Troubles

Post by Loewchen » Wed Feb 06, 2019 3:34 pm

Eiermann wrote:
Wed Feb 06, 2019 1:30 pm
Do you have any good sources for ups-efficent base building / planning?
There are dozens of Gameplay Help topics about this. Generally: Use beacons and use trains over bots or belts, clear biter spawners beyond pollution range.

Post Reply

Return to “Technical Help”

Who is online

Users browsing this forum: No registered users and 3 guests