Quickbar shortcut doesn't work

Anything that prevents you play the game properly. Do you have issues with paying for the game, downloading it or properly running it on your computer? Let us know here.
Post Reply
Manual Inserter
Manual Inserter
Posts: 3
Joined: Fri Sep 12, 2014 8:48 pm

Quickbar shortcut doesn't work

Post by fanzeyi »

Everything works except quickbar shortcut & enter/leave vehicle. They work properly yesterday.

Version: 0.10.10 (Build 10744, mac) No Mods except `Base Mod`

I've tried to restart factorio & my computer, but the problem is still there...


https://www.dropbox.com/s/gzya3p641gbcx ... 5.png?dl=0

https://www.dropbox.com/s/c8xc4qxwrf7sk ... 8.png?dl=0


I tried to set another key other than number key. It works.. Seems like I can't use number key & enter key in factorio..

OS Version: Mac OS X 10.9.4

Burner Inserter
Burner Inserter
Posts: 12
Joined: Sat Sep 13, 2014 8:05 pm

Re: Quickbar shortcut doesn't work

Post by Vornicus »

I too am getting this error. Same OS and game version. Some more minutiae: US keyboard layout, with a non-Apple keyboard, with alt and winkey mapped to command and option respectively.

Setting the key bindings through the options works: I can set a binding to say it will respond to "1" easily, but the buttons do not work in the rest of the game.

Also, using numeric keypad versions of the numbers and enter key all work; these show up in the bindings list as "PAD 1" and so forth., and allow use in game.

This is most likely related to one of the issues dealt with in the 0.10.10 patch: "The number input box "consumes" only numeric input, other keys for walking or closing the still works when the field is selected. This is true as long as these are not mapped to numbers, bad luck in that case" (viewtopic.php?t=5741)

Post Reply

Return to “Technical Help”

Who is online

Users browsing this forum: No registered users