[1.1.59] Interface scaling to 200% on 1440x900 creates issues

Anything that prevents you play the game properly. Do you have issues with paying for the game, downloading it or properly running it on your computer? Let us know here.
Post Reply
MrGazWay
Manual Inserter
Manual Inserter
Posts: 4
Joined: Sat Jun 18, 2022 10:54 pm
Contact:

[1.1.59] Interface scaling to 200% on 1440x900 creates issues

Post by MrGazWay »

Pictures attached below for details.
Scaling from the "interface" setting to 200% with a 1440x900 resolution on Mac M1 creates severe issues. You can't change it back, since you can't "confirm changes", the green box that's usually at the right corner on every setting page. Other settings such as "Graphics", "Mod settings" and a few others doesn't suffer from the 200% scaling problem, where the green "confirm" box is visible. Pressing ESC only allows you to discard the settings and not apply new settings (ex. go back to 100% scaling...) Oh, and you can't quit the game in the proper way, because the main menu is also too big so there is no "Quit Game" button. Have to force quit the app. *Scrolling doesn't work horizontally

Really difficult to find the config file and change the interface setting back to normal. It's downloaded through Steam. Thought the path would be:
\Library\Application Support\Steam\steamapps\common\factorio\ then into the Contents folder, but i can't find the config file there.. Help :-)
Attachments
Skærmbillede 2022-06-19 kl. 00.46.36.png
Skærmbillede 2022-06-19 kl. 00.46.36.png (446.43 KiB) Viewed 143 times
Skærmbillede 2022-06-19 kl. 00.58.28.png
Skærmbillede 2022-06-19 kl. 00.58.28.png (1.62 MiB) Viewed 143 times


MrGazWay
Manual Inserter
Manual Inserter
Posts: 4
Joined: Sat Jun 18, 2022 10:54 pm
Contact:

Re: [1.1.59] Interface scaling to 200% on 1440x900 creates issues

Post by MrGazWay »

Loewchen wrote:
Sat Jun 18, 2022 11:20 pm
That is not a bug.
Not sure where to post it then. Isn't the confirm button supposed to be there? There isn't any conventionel solution to this, as far as i have looked, and it's game breaking as in you can't change it back. Is there somewhere else I could let the issue be known instead of the Bug section?

mmmPI
Smart Inserter
Smart Inserter
Posts: 1600
Joined: Mon Jun 20, 2016 6:10 pm
Contact:

Re: [1.1.59] Interface scaling to 200% on 1440x900 creates issues

Post by mmmPI »

MrGazWay wrote:
Sat Jun 18, 2022 11:09 pm
Really difficult to find the config file and change the interface setting back to normal. It's downloaded through Steam. Thought the path would be:
\Library\Application Support\Steam\steamapps\common\factorio\ then into the Contents folder, but i can't find the config file there.. Help
I think this is technical help :)

You can find the config.ini there : D:\Users\mmmPI\AppData\Roaming\Factorio\config

If your Disk has the letter D and your name is mmmPI

Then line 163 or CTRL-F to find this :

[interface]
; Options: true, false
automatic-ui-scale=false

custom-ui-scale=0.750000

where you must have something like 2.00000

Loewchen
Global Moderator
Global Moderator
Posts: 7452
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: [1.1.59] Interface scaling to 200% on 1440x900 creates issues

Post by Loewchen »

Oh I thought you just reported in general, not that you still cannot get it back. In windows the config file directory is hidden, can you not navigate to it through the terminal in mac os?
Or even simpler, can you not move the settings window to the left to show the confirm button or just press E to confirm?

User avatar
Silari
Filter Inserter
Filter Inserter
Posts: 387
Joined: Sat Jan 27, 2018 10:04 pm
Contact:

Re: [1.1.59] Interface scaling to 200% on 1440x900 creates issues

Post by Silari »

MrGazWay wrote:
Sat Jun 18, 2022 11:09 pm
Really difficult to find the config file and change the interface setting back to normal. It's downloaded through Steam. Thought the path would be:
\Library\Application Support\Steam\steamapps\common\factorio\ then into the Contents folder, but i can't find the config file there.. Help :-)
Per the wiki it should be in ~/Library/Application Support/factorio/config/config.ini

Also, escape is the cancel button, which is why it discards settings. You can hit E to confirm even if you can't see the confirm button.

Also also, Ctrl+NumPad- will lower the interface scaling on Windows - may be the same on Mac. Ctrl+Numpad0 resets it to automatic.

MrGazWay
Manual Inserter
Manual Inserter
Posts: 4
Joined: Sat Jun 18, 2022 10:54 pm
Contact:

Re: [1.1.59] Interface scaling to 200% on 1440x900 creates issues

Post by MrGazWay »

Loewchen wrote:
Sat Jun 18, 2022 11:48 pm
...
Or even simpler, can you not move the settings window to the left to show the confirm button or just press E to confirm?
Issue solved thanks to this.
Pressing E to confirm changes solves the issue! And dragging the menu window also makes the confirm button visible, thanks alot.


For anyone else trying to mess with the config.ini file on Mac OS, it's too much of a hassle and not worth it. I definitely recommend other solutions, although it's still do-able. See the next comment.

MrGazWay
Manual Inserter
Manual Inserter
Posts: 4
Joined: Sat Jun 18, 2022 10:54 pm
Contact:

Re: [1.1.59] Interface scaling to 200% on 1440x900 creates issues

Post by MrGazWay »

mmmPI wrote:
Sat Jun 18, 2022 11:47 pm
MrGazWay wrote:
Sat Jun 18, 2022 11:09 pm
Really difficult to find the config file and change the interface setting back to normal. It's downloaded through Steam. Thought the path would be:
\Library\Application Support\Steam\steamapps\common\factorio\ then into the Contents folder, but i can't find the config file there.. Help
I think this is technical help :)

You can find the config.ini there : D:\Users\mmmPI\AppData\Roaming\Factorio\config

If your Disk has the letter D and your name is mmmPI

Then line 163 or CTRL-F to find this :

[interface]
; Options: true, false
automatic-ui-scale=false

custom-ui-scale=0.750000

where you must have something like 2.00000
Works for Windows users^
For Mac OS users, the file path for the config is:
/Users/[name]/Library/Application Support/Steam/userdata/78029704/427520/remote/config.ini/

The first number in the file path "78029704" might be another number for you, but the "427520" number is Factorio's Steam ID.
In the config.ini file, copy paste the following under the [interface], if it's not shown already.
"
; Options: true, false
automatic-ui-scale=false

custom-ui-scale=0.750000 (where 0.75000 is the decimal scaling, equal to 75%)
"
Apparently this setting didn't show up for me, when i looked for it in the config.ini file. But it works by copy/pasting it into the file and saving it.

Post Reply

Return to “Technical Help”