Linux multi-monitor support weirdness

Anything that prevents you play the game properly. Do you have issues with paying for the game, downloading it or properly running it on your computer? Let us know here.
Post Reply
User avatar
ptx0
Smart Inserter
Smart Inserter
Posts: 1240
Joined: Wed Jan 01, 2020 7:16 pm
Contact:

Linux multi-monitor support weirdness

Post by ptx0 »

Hello there,

I run KDE on Ubuntu 20 and connected a 2ndary monitor. Linux thought it's the primary monitor, but I set up some scripts and configurations so that it is correct.

For example, my xrandr output shows:

Code: Select all

Screen 0: minimum 320 x 200, current 3840 x 1080, maximum 16384 x 16384
DisplayPort-0 disconnected (normal left inverted right x axis y axis)
DisplayPort-1 disconnected (normal left inverted right x axis y axis)
HDMI-A-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 531mm x 299mm
   1920x1080     60.00*+  50.00    59.94    59.99  
   1600x1200     60.00  
   1680x1050     59.88  
   1280x1024     75.02    60.02  
   1440x900      59.90  
   1280x960      60.00  
   1366x768      59.79  
   1280x800      60.00  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    72.81    66.67    60.00    59.94  
   720x400       70.08  
HDMI-A-1 disconnected (normal left inverted right x axis y axis)
DVI-D-0 connected primary 1920x1080+1920+0 (normal left inverted right x axis y axis) 698mm x 393mm
   1920x1080     60.00 + 144.00*  119.98    99.93    59.94  
   1680x1050     59.88  
   1400x1050     59.95  
   1280x1024     75.02    60.02  
   1440x900      59.90  
   1280x960      60.00  
   1280x800      60.00  
   1152x864      75.00  
   1280x720      60.00    59.94  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   640x480       75.00    72.81    66.67    60.00    59.94  
   720x400       70.08  
DVI-D-0 shows "connected primary" at 144Hz, which is the correct setup.
Screenshot_20220102_151437.png
Screenshot_20220102_151437.png (38.23 KiB) Viewed 80 times
my KDE display config applet also shows the rightmost monitor as the primary one.

However, Factorio starts up on the left display (Screen 2):
Screenshot_20220102_151524.png
Screenshot_20220102_151524.png (104.33 KiB) Viewed 80 times
so this is odd, I'm wondering how Factorio gets this information? not asking for it to be fixed, though if it can get the correct info from libxrandr that would probably fix the problem.
My Mods - Fish Per Minute base size metric - Use your crashed spaceship as a belt balancer?
• • •
Base: Bob's @ 1 Million SPM
• • •
Linear search and overflows are indicative of sloppy coding practices.

Post Reply

Return to “Technical Help”