[1.1.41] Modded - FPS/UPS drops

Anything that prevents you play the game properly. Do you have issues with paying for the game, downloading it or properly running it on your computer? Let us know here.
Post Reply
haise1123
Burner Inserter
Burner Inserter
Posts: 5
Joined: Wed Aug 18, 2021 7:04 pm
Contact:

[1.1.41] Modded - FPS/UPS drops

Post by haise1123 »

This has a lot of mods, but I consider 2 big mods are Krastorio and Space Exploration

And I'm using Rampants + Bob's enemies and a few mods to tweak the biters' side to give us some challenge!

FPS/UPS start to drop when Biters come, this save is from 1.1.38, but when FPS/UPS starts to drop, my friends drop out of the game and so I have no choice but to take a break from it, I'm just going back and loaded it back with 1.1.41 versions.

What I noticed in-game when using F4 and F5 to inspect is Entity updates are very high, but I don't think we have a mega factory yet consider our size comparing to others.

And a weird bug that our gun (or the Spidertron) keeps firing at the fire splash for a while (prob due to a mod), I don't know what it is, can someone give me some in-depth explains to improve or something to boost the FPS/UPS back and probably fix the firing at fire splash bug?

I don't know if the Devs are willing to solve a modding case but I hope someone could. Thank you.

Our gameplay goal is to defense in an apocalypse world where tons of biters keep rushing and rushing, to see if we can fight back against the odds or we'll die trying, or... perhaps have time to build the rocket in time to escape from that hellish planet to move to somewhere else safer and rebuild our strength to take the planet back into our hands and turn the biters to dust with more superior technology! (So... the game will contain a lot of biters *warning sight*!)

My PC:
Graphics card: GTX 1660 6GB
RAM: 16GB DDR4 2666Mhz
CPU: i5-9400F 6-Core 2.90 GHz Processor
The game runs in 500GB SSD Storage.

I'm testing offline since all my friends are gone, but just in case this is my internet speed.
Capture.PNG
Capture.PNG (32.51 KiB) Viewed 349 times
And we are playing at the lowest setting to make sure we have a better performance.

I hope to have some answers from anyone, I really appreciate it, and have a nice day if you are reading this!
Here's the saved file that I saved it. The game run at 42FPS cap (I remember setting the speed about 0.8 or 0.7 for everyone in-sync easier)
_autosave3.zip
(27.56 MiB) Downloaded 7 times
I'm planning on inviting them back to the fight but of course, I must know which cause the FPS/UPS drops so much, and we're planning on a new game btw, the save you're looking at is probably our weaken state... So in the new game, we wish to know what causes the problems to eliminate it or work things around to ease the problems (some mods are really nice to our personal taste, so please don't tell us to remove all the mods, we know it will solve our problem but it's not our "first to go" :( )

(Edit update)

This is when the biters come, as you can see, it dropped around 20-28 FPS/UPS for me consistently.
BitersCome.png
BitersCome.png (1.95 MiB) Viewed 327 times
And when the Biters are all wiped out, things back to normal, it gets back to 42FPS/UPS (which is the FPS/UPS I capped)
BitersGone.png
BitersGone.png (1.94 MiB) Viewed 327 times
I don't know about the logs so I will post the current and previous logs just in case.
Factorio-previous.log:
factorio-previous.log
(397.46 KiB) Downloaded 5 times
Factorio-current.log:
factorio-current.log
(379.66 KiB) Downloaded 5 times
Last edited by haise1123 on Fri Sep 24, 2021 6:31 pm, edited 3 times in total.


haise1123
Burner Inserter
Burner Inserter
Posts: 5
Joined: Wed Aug 18, 2021 7:04 pm
Contact:

Re: [1.1.41] Modded - FPS/UPS drops

Post by haise1123 »

Thanks for informing me, I'll run back into the game and update the post in a sec.

User avatar
Silari
Fast Inserter
Fast Inserter
Posts: 244
Joined: Sat Jan 27, 2018 10:04 pm
Contact:

Re: [1.1.41] Modded - FPS/UPS drops

Post by Silari »

Try removing Water Turret and see if that resolves the issue. The 'spidertrons shoot at fire' is probably caused by it, as from what the author has posted before it makes invisible entities the water turrets and ONLY those turrets are supposed to shoot at, but sounds like that isn't working right for some reason. And of course when biters attack your flame turrets fire, which creates a bunch of fire, so the timing lines up.

It's been known to cause slowdowns before due to how it works. I thought they fixed it but possibly not, maybe there's been a regression, this is some new issue, or maybe your map is just doing enough the previous fix wasn't enough. If removing the mod fixes it, report it to the author.

haise1123
Burner Inserter
Burner Inserter
Posts: 5
Joined: Wed Aug 18, 2021 7:04 pm
Contact:

Re: [1.1.41] Modded - FPS/UPS drops

Post by haise1123 »

Silari wrote:
Fri Sep 24, 2021 7:23 pm
Try removing Water Turret and see if that resolves the issue. The 'spidertrons shoot at fire' is probably caused by it, as from what the author has posted before it makes invisible entities the water turrets and ONLY those turrets are supposed to shoot at, but sounds like that isn't working right for some reason. And of course when biters attack your flame turrets fire, which creates a bunch of fire, so the timing lines up.

It's been known to cause slowdowns before due to how it works. I thought they fixed it but possibly not, maybe there's been a regression, this is some new issue, or maybe your map is just doing enough the previous fix wasn't enough. If removing the mod fixes it, report it to the author.
Thanks, I'll definitely check this out, Water Turret Gun mod is cool, like... vital for us, because that's what keep the biters in check, but from your words, seems to remove it is the only option right now for us, but I'll have to play again without it to know if it solves the problem or not, or does the game has some kind of debug field or something like that so I can quickly test it out?

haise1123
Burner Inserter
Burner Inserter
Posts: 5
Joined: Wed Aug 18, 2021 7:04 pm
Contact:

Re: [1.1.41] Modded - FPS/UPS drops

Post by haise1123 »

After following Silari's instructions, the "Spidertrons shoot at the fire" has been fixed due to removing of Water Turret Gun.

But the problems of dropping FPS/UPS are still there, the Entity update is spiked up significantly (this happen only when the biters engaging in the firefight), and when a wave is finished, it dropped down and everything is back to normal, I can even spectate the biters without dropping any FPS or UPS.
I don't know if this is the limitation of my PC - which leads to I can't handle this many biters and whatever "happens" during the firefight.
Or it is the mod that caused it (the fire that some biters leave on the ground after being killed, I guess it's counted as an entity, too). Or is it the limitation of the engine from the game itself?
Here's the video that I record after I remove the Water Turret Gun.

haise1123
Burner Inserter
Burner Inserter
Posts: 5
Joined: Wed Aug 18, 2021 7:04 pm
Contact:

Re: [1.1.41] Modded - FPS/UPS drops

Post by haise1123 »

After a while, looking at the long numbers of debugging mods statistics.

I decide to remove some mods like RPGSystem, Swarmegeddon (something called like that I don't quite remember) - this one gives biters ability to split into 2 after being killed, which I think it'll cause lots of UPS since more biters mean more entities I guess, and the Repair Turret and with some tweaking for Rampant mods in config. The Repair Turret somehow takes a lot of updates, in some cases, it'll even spike up to 5.x-10.x (the previous clip has some kind of numbers like that, too, I just don't know why or pay attention to it first because it's too much info happen on the screen). I even open the MSI Afterburner to see if my single core is at the limit or not but it seems that's not the case.

The game seems to be playable and I can maintain the FPS and UPS at desirable numbers now, but I don't know how things will work furthermore (ex: when we expand our factory, when more crazy stuff come to like more weapons in action, etc).

Here's the clip after I removing these mods, I'm testing at when I'm engaging the firefight with biters a bit, then I reload the save and try to tweak the game speed back to 0.8 (previous is 0.7) to check the turret in defense against the biters to see if any FPS/UPS drops to the point I consider it's significant, and then tweak the Rampant or something a little bit to see if there's any different (which I believe it does a little bit).
Here's a new save game, it's still like the previous but I remove some mods which I consider cause FPS and UPS drop.
TestingBiterHordes.zip
(25.18 MiB) Downloaded 59 times
I'm still hoping for more optimization helps, guides, instructions, etc. :)

Post Reply

Return to “Technical Help”