[0.12.4] [posila] Can't load my save game

Things that has been reported already before.
Post Reply
Tarif
Manual Inserter
Manual Inserter
Posts: 3
Joined: Sat Aug 22, 2015 11:08 pm
Contact:

[0.12.4] [posila] Can't load my save game

Post by Tarif »

I saved my game yesterday and wen I loaded the game today I got the error Unexpected error occurred. You can help us to solve the problem by posting the contents of the log file on the Factorio forums. The logfile is in the attachments and the save game is here https://www.dropbox.com/s/8bvqyvectmw81 ... 2.zip?dl=0 I hope anyone can help me.
Attachments
factorio-current.log
(12.45 KiB) Downloaded 217 times

bluegreenash
Manual Inserter
Manual Inserter
Posts: 4
Joined: Thu Apr 30, 2015 1:53 pm
Contact:

Re: Can't load my save game V0.12.4

Post by bluegreenash »

i've been getting this too, along with some random crashes.

included log file
Attachments
factorio-current.log
(1.37 KiB) Downloaded 121 times
factorio-previous.log
(4.24 KiB) Downloaded 145 times

posila
Factorio Staff
Factorio Staff
Posts: 4069
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [posila] Can't load my save game V0.12.4

Post by posila »

@Tarif: Thank you for the report. Your save contains rail segment that references rail entity that does not exist. Do you remember how you place rail on screenshot bellow? Did you place it manually, using construction robots or FARL? Did anything out of ordinary happen while placing the rail? Did you remove or rotate rails?
factorio-buggy-rail.jpg
factorio-buggy-rail.jpg (144.38 KiB) Viewed 9991 times

posila
Factorio Staff
Factorio Staff
Posts: 4069
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [posila] Can't load my save game V0.12.4

Post by posila »

@bluegreenash: Based on logs you provided, your crashes are not related to this bug. But it is similar to crash in following topic: https://forums.factorio.com/forum/vie ... =7&t=15221
If you can, upload your save game into that topic. Thanks,

Tarif
Manual Inserter
Manual Inserter
Posts: 3
Joined: Sat Aug 22, 2015 11:08 pm
Contact:

Re: [posila] Can't load my save game V0.12.4

Post by Tarif »

@ posila thanks for looking in to it I used the FARL to build the rail. I didnt remove the right rail. I did remove the left rail with construction robots and replaced it 1 block to the left with the FARL.

Choumiko
Smart Inserter
Smart Inserter
Posts: 1307
Joined: Fri Mar 21, 2014 10:51 pm
Contact:

Re: [posila] Can't load my save game V0.12.4

Post by Choumiko »

posila wrote:@Tarif: Thank you for the report. Your save contains rail segment that references rail entity that does not exist. Do you remember how you place rail on screenshot bellow? Did you place it manually, using construction robots or FARL? Did anything out of ordinary happen while placing the rail? Did you remove or rotate rails?
Tarif wrote:@ posila thanks for looking in to it I used the FARL to build the rail. I didnt remove the right rail. I did remove the left rail with construction robots and replaced it 1 block to the left with the FARL.
FARL stores some entities in global. But these get deleted once FARL is deactivated and checked with .valid before accessed. Would it be safer to add events when an entity gets mined and do the cleanup there?

Rseding91
Factorio Staff
Factorio Staff
Posts: 10105
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [posila] Can't load my save game V0.12.4

Post by Rseding91 »

Choumiko wrote:FARL stores some entities in global. But these get deleted once FARL is deactivated and checked with .valid before accessed. Would it be safer to add events when an entity gets mined and do the cleanup there?
Lua entity references can be held onto forever. Once the real entity is deleted they point to nullptr and have no ties to the real entity so they don't harm anyone by sticking around (other than memory usage/disk space).
If you want to get ahold of me I'm almost always on Discord.

posila
Factorio Staff
Factorio Staff
Posts: 4069
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [posila] Can't load my save game V0.12.4

Post by posila »

I still haven't figured out what caused the issue ... I don't think FARL is doing anything wrong. Anyway, even if we find out cause of the issue and fix it, your save is corrupted and won't be able to load ... Luckily, we were able to recover it so here is your repaired save: https://drive.google.com/file/d/0B725IS ... sp=sharing

Tarif
Manual Inserter
Manual Inserter
Posts: 3
Joined: Sat Aug 22, 2015 11:08 pm
Contact:

Re: [0.12.4] [posila] Can't load my save game

Post by Tarif »

thank you so dearly for recovering my savegame


dylloop
Burner Inserter
Burner Inserter
Posts: 10
Joined: Sat Aug 29, 2015 11:53 am
Contact:

Re: [0.12.4] [posila] Can't load my save game

Post by dylloop »

posting this here in the hopes that you can fix it I have a big stream tomorrow and need my save.
I just had this bug corupt both my youtube and stream save. is there a way to recover the save or is it lost? was messing with -root mode in 12.6 and it threw an error now it wont load. heres the save. https://www.dropbox.com/s/nf24b5ocvlzog ... m.zip?dl=0

Post Reply

Return to “Duplicates”

Who is online

Users browsing this forum: No registered users