Factorio not starting on new Framework laptop

Things that has been reported already before.
Post Reply
hawiianbat
Manual Inserter
Manual Inserter
Posts: 3
Joined: Wed Apr 03, 2024 2:35 am
Contact:

Factorio not starting on new Framework laptop

Post by hawiianbat »

Brand new Framework laptop, AMD Radeon Graphics RX 7700 S, drivers up to date. Brand new Win 11 install and all drivers up to date. System will nopt start the program. Log files attached. Any guidance available folks?
Attachments
factorio-dump-current.dmp
(535.38 KiB) Downloaded 6 times
factorio-current.log
(6.63 KiB) Downloaded 9 times


hawiianbat
Manual Inserter
Manual Inserter
Posts: 3
Joined: Wed Apr 03, 2024 2:35 am
Contact:

Re: Factorio not starting on new Framework laptop

Post by hawiianbat »

Thanks for that. I tried that solution and it made no difference. I then disabled the onboard in Device Manager, rebooted, and got Factorio to run, but it's running at 1 frame / sec. GPU usage is almost non-existent. I still suspect it's something to do with the GPU chipset, but I am not sure where to go from here.

hawiianbat
Manual Inserter
Manual Inserter
Posts: 3
Joined: Wed Apr 03, 2024 2:35 am
Contact:

Re: Factorio not starting on new Framework laptop

Post by hawiianbat »

So, one final quick follow up. After disabling the onboard, rebooting, and still not having any joy, I re-enabled the onboard and now the laptop is picking the right GPU and it's working perfectly. Why? No idea. Grateful to have it working.

Post Reply

Return to “Duplicates”