[1.1.46] Crash after grabbing BP from library

Place for things which are bugs but we have no idea how to solve them. Things related to hardware, libraries, strange setups, etc.
Post Reply
User avatar
Warger
Burner Inserter
Burner Inserter
Posts: 17
Joined: Thu Jan 14, 2021 3:26 pm
Contact:

[1.1.46] Crash after grabbing BP from library

Post by Warger »

Another random crash, this time after grabbing a bp from library. If necessary i can provide the bps.
I am starting to suspect my HW.

crash:
https://clips.twitch.tv/EagerYummyShall ... kTR4newGlg
Attachments
factorio-dump-current.dmp
(983.67 KiB) Downloaded 34 times
factorio-current.log
(13.21 KiB) Downloaded 47 times

User avatar
Warger
Burner Inserter
Burner Inserter
Posts: 17
Joined: Thu Jan 14, 2021 3:26 pm
Contact:

Re: [1.1.46] Crash after grabbing BP from library

Post by Warger »

as a follow-up i run some RAM stability test and i verified that it is 100% working.
So i would exclude HW (at least RAM) related issues for now.

lyvgbfh
Inserter
Inserter
Posts: 22
Joined: Fri Jul 10, 2020 6:48 pm
Contact:

Re: [1.1.46] Crash after grabbing BP from library

Post by lyvgbfh »

Warger wrote:
Thu Nov 18, 2021 9:53 am
as a follow-up i run some RAM stability test and i verified that it is 100% working.
So i would exclude HW (at least RAM) related issues for now.
You may wish to give a short run of Prime95 and see if any of the worker threads fail. That's been an indicator for other users

Loewchen
Global Moderator
Global Moderator
Posts: 7180
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: [1.1.46] Crash after grabbing BP from library

Post by Loewchen »

Two crashes on the same machine, cannot be reproduced, nobody else reported and are in different parts of code that both have not been changed recently still seems more likely to be a hardware issue.

User avatar
Warger
Burner Inserter
Burner Inserter
Posts: 17
Joined: Thu Jan 14, 2021 3:26 pm
Contact:

Re: [1.1.46] Crash after grabbing BP from library

Post by Warger »

So i did a bunch of testing and i found some weird things. The memcheck from windows didn't report any errors, however when running prime95 some workers stopped immediately due to some errors.
So i disabled XMP and i ran prime95 again and it worked flawlessly.
then i re-enabled XMP and i ran prime95 yet again and it wroked flawlessly here as well (i did a sort of extensive test here of few hours).

This is extremely weird for me as when i built this machine some months ago i checked for stability with a 12h test with prime95+furmark that returned 0 errors.

I don't really understand what happened as i haven't touched my bios since... however i would say that it could have been indeed an hardware error that was resolved by turning off and on the xmp profile... extremely weird.

Loewchen
Global Moderator
Global Moderator
Posts: 7180
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: [1.1.46] Crash after grabbing BP from library

Post by Loewchen »

I wouldn't trust results from software that checks memory as application within windows. Use http://memtest.org/#downiso or https://www.memtest86.com/download.htm instead and let it run several complete loops, best overnight. If it does not find any issue then, you can be reasonably confident that it is not a memory issue.

kovarex
Factorio Staff
Factorio Staff
Posts: 8055
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [1.1.46] Crash after grabbing BP from library

Post by kovarex »

I'm moving this to magic then.

Post Reply

Return to “1 / 0 magic”