[1.1.8] inconsistencies with underground ghosts when upgrading

Bugs that are actually features.
Post Reply
Xebedee
Manual Inserter
Manual Inserter
Posts: 1
Joined: Wed Jan 13, 2021 12:16 pm
Contact:

[1.1.8] inconsistencies with underground ghosts when upgrading

Post by Xebedee »

When manually placing on a ghost yellow underground with the actual yellow underground , you have to place both ends, when placing a red (on the yellow ghost) it places both ends (as red)

User avatar
Lou
Factorio Staff
Factorio Staff
Posts: 58
Joined: Mon Nov 30, 2020 10:50 am
Contact:

Re: [1.1.8] inconsistencies with underground ghosts when upgrading

Post by Lou »

Hello,

thank you for the input. However in my attempt to reproduce this, both red and yellow underground belt ghosts needed both ends to be manually revived (placed on by real entity). Could you please post more information how you got into the situation?

Xorimuth
Filter Inserter
Filter Inserter
Posts: 438
Joined: Sat Mar 02, 2019 9:39 pm
Contact:

Re: [1.1.8] inconsistencies with underground ghosts when upgrading

Post by Xorimuth »

I can easily reproduce it as described by the OP:

- Place ghost yellow underground
- Place 2nd ghost yellow underground connected to the first
- Place real red underground on top of one of the ghost yellows
- The 2nd ghost yellow will have been automatically placed

User avatar
Lou
Factorio Staff
Factorio Staff
Posts: 58
Joined: Mon Nov 30, 2020 10:50 am
Contact:

Re: [1.1.8] inconsistencies with underground ghosts when upgrading

Post by Lou »

So the inconsistency OP referred to is not between yellow/red underground belt, but between same/different underground belt ...

kovarex
Factorio Staff
Factorio Staff
Posts: 8058
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [1.1.8] inconsistencies with underground ghosts when upgrading

Post by kovarex »

Moving to minor issues. The upgrading of ghost is just a side effect of manual upgrading real ones.

Xorimuth
Filter Inserter
Filter Inserter
Posts: 438
Joined: Sat Mar 02, 2019 9:39 pm
Contact:

Re: [1.1.8] inconsistencies with underground ghosts when upgrading

Post by Xorimuth »

Lou wrote:
Wed Jan 13, 2021 3:10 pm
So the inconsistency OP referred to is not between yellow/red underground belt, but between same/different underground belt ...
Correct. You can see the same bug(?) when placing a blue underground on a red ghost.

Post Reply

Return to “Not a bug”