[0.15.26] Inserter base rotates, hand doesn't without power

Bugs that are actually features.
Post Reply
London_
Inserter
Inserter
Posts: 21
Joined: Sat Jul 01, 2017 12:53 am
Contact:

[0.15.26] Inserter base rotates, hand doesn't without power

Post by London_ » Sat Jul 01, 2017 3:22 am

If I remember correctly, inserter bases and hands rotates at the same time in previous versions (maybe just back in .14?).
Currently only the base rotates, making it appear as if the inserter wasn't rotated in the first place if not for the arrow when hovering over the inserter.
The Burner Inserter works fine however.

Gif of issue: https://gyazo.com/16e550595bd16e5c319c283656a77e51

I feel like this issue can be reproduced in vanilla as well, but haven't tried yet.


Log attached.

save: https://drive.google.com/open?id=0B_pLi ... TA3UlRGbE0

mods: https://drive.google.com/open?id=0B_pLi ... XN2R1VFS1U
Attachments
factorio-current.log
(6.23 KiB) Downloaded 12 times

Rseding91
Factorio Staff
Factorio Staff
Posts: 9261
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.15.26] Inserter base rotates, hand doesn't without power

Post by Rseding91 » Sat Jul 01, 2017 10:30 am

Thanks for the report but that's working as intended. The inserter requires power to rotate - it has always worked this way :)
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Not a bug”

Who is online

Users browsing this forum: No registered users