[1.1.56] Entity preview "missing"

Bugs that are actually features.
Post Reply
Honktown
Filter Inserter
Filter Inserter
Posts: 886
Joined: Thu Oct 03, 2019 7:10 am
Contact:

[1.1.56] Entity preview "missing"

Post by Honktown »

On 1920x1080 and 125% zoom, the entity preview disappears and there's no option to disable this behavior:
entity.png
entity.png (109.24 KiB) Viewed 359 times
Presumably it's because of: "Some GUI fixes and improvements for screen resolutions under 1920×1080".

1) my screen is 1920x1080, so this description doesn't sound as if it should apply.
2) I can understand why: to improve the readability of tooltips. Unfortunately I do (did) use it in certain situations to check a belt is facing the direction I want it to, wire connections on a pole, etc.

I would like to request an option to enable/disable the behavior, if it's intended to act at >100% zoom @ 1920x1080. If I may suggest, it would probably be best as an option for *all* resolutions and scales.

Edit: not really a "preview", but "zoom", "excision", "the thing" in the "entity info gui" (related: https://wiki.factorio.com/Prototype/Entity#drawing_box) .
I have mods! I guess!
Link

Twinsen
Factorio Staff
Factorio Staff
Posts: 1240
Joined: Tue Sep 23, 2014 7:10 am
Contact:

Re: [1.1.56] Entity preview "missing"

Post by Twinsen »

This is working as intended.

The tooltip space is limited event at 100% scale, as exemplified by the many recurring bug reports complaining about the fact that the tooltip gets clipped sometimes.
Our minimum resolution is 1080p at 100% scale. Increasing the scale will cause the "desperate" GUI fixes to kick in.

So my solution is unfortunately that you should play at 100% scale, or get a bigger screen and play at 100% scale, or get a bigger screen with bigger resolution and play at 125% scale(or possibly more).

Post Reply

Return to “Not a bug”