Flamethrower Turrets do not give back fluid on deconstruct

Bugs that are actually features.
Post Reply
gallomimia
Long Handed Inserter
Long Handed Inserter
Posts: 51
Joined: Fri Apr 22, 2016 6:20 pm
Contact:

Flamethrower Turrets do not give back fluid on deconstruct

Post by gallomimia »

So I have this outpost that I'm deconstructing (just the walls and turrets) because it is now inside safe territory, walled off against water chokepoints. I'm just now noticing that the flamethrower turrets don't dump their fluid-contents back into the pipes! Not cool....
I tested by isolating one turret and deconstructing it by hand.

Factorio 1.1.14
Several mods like swarmageddon, extra armor, electric trains... nothing that affects flame turrets.

Can you at least explain why this is so if it is not-a-bug or working as intended?


User avatar
ickputzdirwech
Filter Inserter
Filter Inserter
Posts: 643
Joined: Sun May 07, 2017 10:16 am
Contact:

Re: Flamethrower Turrets do not give back fluid on deconstruct

Post by ickputzdirwech »

gallomimia wrote:
Sat Oct 09, 2021 7:01 pm
Can you at least explain why this is so if it is not-a-bug or working as intended?
Actually a reasonable question imo.
Mods: Shortcuts for 1.1, ick's Sea Block, ick's vanilla tweaks
Tools: Atom language pack
Text quickly seems cold and unfriendly. Be careful how you write and interpret what others have written.
- A reminder for me and all who read what I write

Loewchen
Global Moderator
Global Moderator
Posts: 7113
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: Flamethrower Turrets do not give back fluid on deconstruct

Post by Loewchen »

If someone has gameplay questions there are subforums to ask those, Bug reports is not the shortcut to get a dev response.

mrvn
Smart Inserter
Smart Inserter
Posts: 4647
Joined: Mon Sep 05, 2016 9:10 am
Contact:

Re: Flamethrower Turrets do not give back fluid on deconstruct

Post by mrvn »

The question isn't how to use flamethrower turrets but why it's not a bug that flamethrower turrets destroy fluids on deconstruction when other entities transfer the fluid to other connected entities.

If the answer is something like that the turret has 2 fluid boxes, one for the connection and one for the flame, and fluids in the second box get lost then that would be all the explanation needed.

User avatar
boskid
Factorio Staff
Factorio Staff
Posts: 1611
Joined: Thu Dec 14, 2017 6:56 pm
Contact:

Re: Flamethrower Turrets do not give back fluid on deconstruct

Post by boskid »

mrvn wrote:
Mon Oct 11, 2021 3:24 pm
If the answer is something like that the turret has 2 fluid boxes, one for the connection and one for the flame, and fluids in the second box get lost then that would be all the explanation needed.
That sounds like viewtopic.php?p=526664#p526664

User avatar
ickputzdirwech
Filter Inserter
Filter Inserter
Posts: 643
Joined: Sun May 07, 2017 10:16 am
Contact:

Re: Flamethrower Turrets do not give back fluid on deconstruct

Post by ickputzdirwech »

Does this mean this is considered a minor issue?
Mods: Shortcuts for 1.1, ick's Sea Block, ick's vanilla tweaks
Tools: Atom language pack
Text quickly seems cold and unfriendly. Be careful how you write and interpret what others have written.
- A reminder for me and all who read what I write

User avatar
boskid
Factorio Staff
Factorio Staff
Posts: 1611
Joined: Thu Dec 14, 2017 6:56 pm
Contact:

Re: Flamethrower Turrets do not give back fluid on deconstruct

Post by boskid »

Does it change anything here whether it is Minor issue or Not a bug?

Its just a tiny loss of fluid (~100), simillar loss may happen during pipe deconstruction when it is full and all the neighbours are also full so there is no place to dump the content. It does not strictly go to "Not a bug" because it was not designed to intentionally get rid of fluids, it just does not have any huge implications into gameplay and this saves couple of weird corner cases like what if the internal buffer has different fluid than the fluidbox.

Post Reply

Return to “Not a bug”