[0.16.51] Multiplayer desync after setting opengl as graphics option

Desyncs in modded game will be ignored most of the time, until it is clearly proven that the desync is not caused by scripting.
Post Reply
TheBearKing
Inserter
Inserter
Posts: 24
Joined: Wed Jul 05, 2017 12:01 pm
Contact:

[0.16.51] Multiplayer desync after setting opengl as graphics option

Post by TheBearKing » Sun Feb 03, 2019 7:11 pm

Friends and I have a long history in Factorio multiplayer, both heavily modded as vanilla. In our latest run we are trying Pyanodons mods. When running those mods, I found that Pyanodons mods double the memory usage of Factorio (from 10 GB to 20 GB memory usage). This is something inherent to Pyanodons mods and I opened a forum thread on the relevant forum addressing the issue and asking for some help on it, see forum thread. Out of that thread I got the suggestion to switch my graphics driver from Direct3D to openGL, which I did, and which halved my memory usage. I achieved this via steam launch options: --force-opengl

I suggested this trick to my friends as well and when we started our multiplayer again, we suddenly got desync issues and we couldn't get the game running. The desync happened the moment I downloaded the map and was about the start the session. We tried 3 times, each time resulting in a desync. The screen would stay black and my pc didn't have the change to even load the map.

When my friend (who was hosting the game) switched his graphics driver again to Direct3D (or removed the steam launch option), we were able to run the game again without any issue (I still had opengl enabled). Since it seems that the graphics driver caused the issue, I am posting here to ask for help on this issue. Before switching to opengl, we had multiple multiplayer sessions on this map with no issues. Any idea what could be the issue?

I have included one desync report below, but if that fails I have included a weTransfer link with the three desync reports.
Wetransfer-link with 3 desync reports: Download link

Post Reply

Return to “Desyncs with mods”

Who is online

Users browsing this forum: No registered users