personal roboport SLOW RESPONSE when fixing vehicles and other stuff.(v0.17.79)

Don't know how to use a machine? Looking for efficient setups? Stuck in a mission?
SharpDShot
Inserter
Inserter
Posts: 26
Joined: Thu Jul 11, 2019 5:33 pm
Contact:

personal roboport SLOW RESPONSE when fixing vehicles and other stuff.(v0.17.79)

Post by SharpDShot »

[mp4]Hello :)

Wanted to report this problem it's becoming anoying actully it's been there for a quite some time now..

i didn't try to do anything.. i just knew the problem wasn't on my end or anything..

straight to the problem.. now i'm driving a car or a tank and i have my personal roboport and i have a lot of batteries and all of them are charged 100% also the robotport also 100% fully charged and i have a lot of construction bots but when a tank or car get damaged by a bitter or just got damaged the bots won't fix the car or the tank.... a weird problem this problem wasn't there a couple versions back.....

The bots were like Mad dogs ! If anything got damaged they rush towards it like hell ! and fix it doesn't matter if it's a car or a tank or anything but now they won't do anything !

Sometimes when i get damaged they go out and fix my tank or car and sometimes they won't most of the times (90%) they won't !

And also when i'm inside my base and i shoot my tank to see if the bots in my base will do something about it... THEY JUST DON'T CARE ABOUT IT !

But when i damage a wall or any building they go and fix it or replace it ASAP ! but they ignore tanks and cars !

Like this video here i damaged my walls and they repairing it and just moving by the tank like it's nothing there !

https://vimeo.com/405613383

LINK FIXED.

Please help...

Kind Regards.
Last edited by SharpDShot on Thu Apr 09, 2020 6:45 pm, edited 3 times in total.

Rseding91
Factorio Staff
Factorio Staff
Posts: 10756
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: personal roboport BUGGED ! won't fix cars or tanks.. (v0.17.79)

Post by Rseding91 »

You probably have a personal robot off in nowhere land slowly trying to fly back to your car.

Enable the debug option "show personal robots" and it will draw a line to it.
If you want to get ahold of me I'm almost always on Discord.

SharpDShot
Inserter
Inserter
Posts: 26
Joined: Thu Jul 11, 2019 5:33 pm
Contact:

Re: personal roboport BUGGED ! won't fix cars or tanks.. (v0.17.79)

Post by SharpDShot »

Thanks for your replay sir..

I'll try it right now.
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

found nothing unfortunately :(

I did find the word in Debug (Show Player Robots)

And find nothing on the map, (Searched every square of it)

And when i click on (SHow logistics robot on the map)

I see all the robots that are currently working and building stuff or repairing inside my base, But my personal roboport have nothing outside..

As i said sometimes they go and fix the car when for an example i move beside it (Meaning the tank got inside my personal roboport building green grid) and one of'em go and fix my car or the tank 90% they don't when it happens it's like a Miracle.. :)

Found another problem yesterday when i reported this.. when i build a wall and damage it or it got damaged by bitters they fix it half of it 50% or 70% and leave it and never go back and try to fully fix it.. even if it's the Roboport inside my base or even my Personal roboport !
(I can record a video for it, if you want a prove.)


Kind Regards.


From what i see right here is a slow response from them a really SLOOOOOW RESPOND......

PyroFire
Filter Inserter
Filter Inserter
Posts: 343
Joined: Tue Mar 08, 2016 8:18 am
Contact:

Re: personal roboport BUGGED ! won't fix cars or tanks.. (v0.17.79)

Post by PyroFire »

SharpDShot wrote:
Thu Apr 09, 2020 7:54 am
From what i see right here is a slow response from them a really SLOOOOOW RESPOND......
I take it you mean, they'll repair the car eventually .. but it takes a while to detect that repairs are needed.

afaik this is working as intended, particularly if your map is very large and you have a lot of robots.
Technical limitations.

SharpDShot
Inserter
Inserter
Posts: 26
Joined: Thu Jul 11, 2019 5:33 pm
Contact:

Re: personal roboport BUGGED ! won't fix cars or tanks.. (v0.17.79)

Post by SharpDShot »

PyroFire wrote:
Thu Apr 09, 2020 8:34 am
SharpDShot wrote:
Thu Apr 09, 2020 7:54 am
From what i see right here is a slow response from them a really SLOOOOOW RESPOND......
I take it you mean, they'll repair the car eventually .. but it takes a while to detect that repairs are needed.

afaik this is working as intended, particularly if your map is very large and you have a lot of robots.
Technical limitations.
Sir... ones i had a save with massive factory just building bots i had tooooooons of them the screen was really crowded but everything was working like it meant to be.. like when i need a quick repair i go to my base walls and wait just a sec and i see a bot coming to aid me with repairing.
But now when i go near my walls or even inside my base the RoboPort won't even send me one to fix my vehicle ! this is on Roboport and Personal Roboport.

Or when i attack a nest and i got damaged never mind if it's a car or a tank when i just get damaged and i just stop (STATIONARY) the bot go out and fix it without even thinking what to do. (This was before back in the old versions.)

Regards.

SharpDShot
Inserter
Inserter
Posts: 26
Joined: Thu Jul 11, 2019 5:33 pm
Contact:

Re: personal roboport BUGGED ! won't fix cars or tanks.. (v0.17.79)

Post by SharpDShot »

I've tried to go far as i can from the base to test my Personal Roboport and here what i did..

turned OFF my Personal Roboport..

I fired couple rounds on my tank and turned my Roboport ON

And nothing happened...

i waited about 10-20sec without doing anything and here he IS.... the bot went to repair the tank !

and i have done all the above steps again, Without turning off my personal roboport..

shot my tank and he went in a blink on an eye fixing the tank every time i damage it..

BUT......

When i drove the tank just a couple meters away and throw some grenades on the way and damaging the tank while i'm in the move and stop to see if he will fix it... he won't ! :x :x :x :x :x :x :x :x :x :x :x :x

What i see here is a really SLOW RESPONSE.

tried the same thing on v0.18.17 also the same problem JUST THE SAME.

Please advice.

User avatar
MEOWMI
Long Handed Inserter
Long Handed Inserter
Posts: 90
Joined: Wed May 22, 2019 12:21 pm
Contact:

Re: personal roboport BUGGED ! won't fix cars or tanks.. (v0.17.79)

Post by MEOWMI »

Your video link doesn't work.

Do you have low battery on your personal armor or something? If you don't have robots lost in the wild chasing you, they will go repair immediately, assuming you aren't in a moving vehicle.

Also note that base roboports won't always send the closest robot & robots nearby won't change their tasks on the fly.

SharpDShot
Inserter
Inserter
Posts: 26
Joined: Thu Jul 11, 2019 5:33 pm
Contact:

Re: personal roboport BUGGED ! won't fix cars or tanks.. (v0.17.79)

Post by SharpDShot »

MEOWMI wrote:
Thu Apr 09, 2020 11:23 am
Your video link doesn't work.

Do you have low battery on your personal armor or something? If you don't have robots lost in the wild chasing you, they will go repair immediately, assuming you aren't in a moving vehicle.
https://vimeo.com/405613383

It's working now.

And no sir i don't have robots lost on the map.

And i have about 3k bot stand by and they do nothing but chilling out ! :D
Last edited by SharpDShot on Thu Apr 09, 2020 2:13 pm, edited 1 time in total.

SharpDShot
Inserter
Inserter
Posts: 26
Joined: Thu Jul 11, 2019 5:33 pm
Contact:

Re: personal roboport BUGGED ! won't fix cars or tanks.. (v0.17.79)

Post by SharpDShot »

MEOWMI wrote:
Thu Apr 09, 2020 11:23 am

Also note that base roboports won't always send the closest robot & robots nearby won't change their tasks on the fly.
I know.. a fresh one come out from the closest Base RoboPort and start doing his thing.

SharpDShot
Inserter
Inserter
Posts: 26
Joined: Thu Jul 11, 2019 5:33 pm
Contact:

Re: personal roboport SLOW RESPONSE when fixing vehicles and other stuff.(v0.17.79)

Post by SharpDShot »

I'm open for any suggestions or advices or anything..,.


SharpDShot
Inserter
Inserter
Posts: 26
Joined: Thu Jul 11, 2019 5:33 pm
Contact:

Re: personal roboport SLOW RESPONSE when fixing vehicles and other stuff.(v0.17.79)

Post by SharpDShot »

Loewchen wrote:
Thu Apr 09, 2020 8:29 pm
Post the save.
Here it is.

I know there is a lot needs reparing and there is no repair packs in the base i was just going to build a whole factory for just repair packs and i found this problem and i stopped playing since..

Just put that away from our problem..

my problem is just with the Personal roboport only.

https://drive.google.com/file/d/1QXvAWF ... sp=sharing

Loewchen
Global Moderator
Global Moderator
Posts: 5942
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: personal roboport SLOW RESPONSE when fixing vehicles and other stuff.(v0.17.79)

Post by Loewchen »

There are hundreds of jobs open that can not be performed because you fail to provide repair packs in the base. Wait a minute until the repair order for your tank starts or fix your repair pack production.

SharpDShot
Inserter
Inserter
Posts: 26
Joined: Thu Jul 11, 2019 5:33 pm
Contact:

Re: personal roboport SLOW RESPONSE when fixing vehicles and other stuff.(v0.17.79)

Post by SharpDShot »

Loewchen wrote:
Thu Apr 09, 2020 9:29 pm
There are hundreds of jobs open that can not be performed because you fail to provide repair packs in the base. Wait a minute until the repair order for your tank starts or fix your repair pack production.
If this is the problem i'll fix it right now... but one question the base roboport and the personal roboport are separate things right ?

I mean base roboport have his own jop and the personal also have his own jops or they connected to each other ?

I'll try to build small factory to provide them with all the repair packs they need and post the results.

hale42
Inserter
Inserter
Posts: 23
Joined: Tue Apr 03, 2018 6:26 am
Contact:

Re: personal roboport SLOW RESPONSE when fixing vehicles and other stuff.(v0.17.79)

Post by hale42 »

they are and they aren't. It seems like the game checks everything in an order, so if you have 2000 "work orders" and 400 of them cant be completed then the game rechecks periodically and it will bog down the game (not in a speed since but a time to complete orders). to fix the problem you have to satisfy the orders there.

SharpDShot
Inserter
Inserter
Posts: 26
Joined: Thu Jul 11, 2019 5:33 pm
Contact:

Re: personal roboport SLOW RESPONSE when fixing vehicles and other stuff.(v0.17.79)

Post by SharpDShot »

Loewchen wrote:
Thu Apr 09, 2020 9:29 pm
There are hundreds of jobs open that can not be performed because you fail to provide repair packs in the base. Wait a minute until the repair order for your tank starts or fix your repair pack production.
Well... as i expected... i managed to get the base fixed from +700 repairs needed to none and still same problem a really slow response from personal roboport bots to fix my damaged items or vehicles..

This is 1000% a bug and you guys should fix it this is not a future in the game ! i never saw this or face it before in the older versions !
Last edited by SharpDShot on Fri Apr 10, 2020 1:31 am, edited 2 times in total.

SharpDShot
Inserter
Inserter
Posts: 26
Joined: Thu Jul 11, 2019 5:33 pm
Contact:

Re: personal roboport SLOW RESPONSE when fixing vehicles and other stuff.(v0.17.79)

Post by SharpDShot »

hale42 wrote:
Thu Apr 09, 2020 9:53 pm
they are and they aren't. It seems like the game checks everything in an order, so if you have 2000 "work orders" and 400 of them cant be completed then the game rechecks periodically and it will bog down the game (not in a speed since but a time to complete orders). to fix the problem you have to satisfy the orders there.
I managed to fix the factory a bit and made small repair packs as soon as the first pack got crafted they took it and repair the entire base

and i waited till they finished repairing everything and tested and still the same SLOW RESPONSE.

Rseding91
Factorio Staff
Factorio Staff
Posts: 10756
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: personal roboport SLOW RESPONSE when fixing vehicles and other stuff.(v0.17.79)

Post by Rseding91 »

Your save file has 2992 repair jobs that robots are waiting to work on. That means it's going to take at 1 per tick 49 seconds before any robot responds to a single job.

It's not 700, it's 2992. You need to go repair your base.

You can use

Code: Select all

/c game.player.print_robot_jobs()
to see how many of what jobs you have outstanding.
If you want to get ahold of me I'm almost always on Discord.

SharpDShot
Inserter
Inserter
Posts: 26
Joined: Thu Jul 11, 2019 5:33 pm
Contact:

Re: personal roboport SLOW RESPONSE when fixing vehicles and other stuff.(v0.17.79)

Post by SharpDShot »

Rseding91 wrote:
Fri Apr 10, 2020 3:12 am
Your save file has 2992 repair jobs that robots are waiting to work on. That means it's going to take at 1 per tick 49 seconds before any robot responds to a single job.

It's not 700, it's 2992. You need to go repair your base.

You can use

Code: Select all

/c game.player.print_robot_jobs()
to see how many of what jobs you have outstanding.
I'm sorry my bad. :roll:

I fixed the entire base after sir Loewchen told me about the repairs.

Here is the latest save and it's from v0.18.18 i tested a lot of things both are the same in 0.17.79 and v0.18.18 same results

https://drive.google.com/open?id=1I3pPf ... J-3qzxCRcI

Loewchen
Global Moderator
Global Moderator
Posts: 5942
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: personal roboport SLOW RESPONSE when fixing vehicles and other stuff.(v0.17.79)

Post by Loewchen »

SharpDShot wrote:
Fri Apr 10, 2020 8:54 am
Here is the latest save and it's from v0.18.18 i tested a lot of things both are the same in 0.17.79 and v0.18.18 same results
https://drive.google.com/open?id=1I3pPf ... J-3qzxCRcI
No clue what "a lot of things" are, but if something in this save gets damaged in personal roboport range it gets instantly repaired.

Post Reply

Return to “Gameplay Help”

Who is online

Users browsing this forum: No registered users