Construction Bots Unresponsive [Bug Maybe?]

Don't know how to use a machine? Looking for efficient setups? Stuck in a mission?
Post Reply
KingCold999
Manual Inserter
Manual Inserter
Posts: 2
Joined: Thu Nov 15, 2018 2:56 am
Contact:

Construction Bots Unresponsive [Bug Maybe?]

Post by KingCold999 » Thu Nov 15, 2018 6:59 pm

Save File, in case this helps

Having some trouble with my robot network I need help with. The construction bots are completely unresponsive.. for no reason. The network went dead randomly after a huge problem with bots not being able to travel home in a linear way (they would return part way, stop, turn around to recharge, then attempt to go again). Fixed this, they worked for a short time, now nothing.

One bot is missing from the network (hasn't returned in almost 2 hours, so assuming its gone). The network seems to be completely hooked up, but the bots won't build anything in the main network.

Logistics still works, you can request things and they will deliver. Just construction side.

Anyone encounter this / know what might be causing it?

-> Everything is powered
-> Construction items are in logistics chests
-> Everything is within the same network that I'm trying to build on
-> Disabling all mods did nothing (None of the mods should have affected the network anyways, mostly just RSO / Picker Extended / GDIW)

Bilka
Factorio Staff
Factorio Staff
Posts: 1751
Joined: Sat Aug 13, 2016 9:20 am
Contact:

Re: Construction Bots Unresponsive [Bug Maybe?]

Post by Bilka » Thu Nov 15, 2018 8:08 pm

This will do that :D
Image

You should connect the northern bot network to your main base so that the robots can build the rails and concrete there, or remove the concrete blueprints so that the game doesn't have that many ghosts to check.

Take a look at 28675 for more information.
I'm an admin over at https://wiki.factorio.com. Feel free to contact me if there's anything wrong (or right) with it.

Jap2.0
Smart Inserter
Smart Inserter
Posts: 1934
Joined: Tue Jun 20, 2017 12:02 am
Contact:

Re: Construction Bots Unresponsive [Bug Maybe?]

Post by Jap2.0 » Thu Nov 22, 2018 6:05 am

Bilka wrote:
Thu Nov 15, 2018 8:08 pm
This will do that :D
Image

You should connect the northern bot network to your main base so that the robots can build the rails and concrete there, or remove the concrete blueprints so that the game doesn't have that many ghosts to check.

Take a look at 28675 for more information.
Iirc tile and entity ghosts will be in separate queues in 0.17, which will help.
There are 10 types of people: those who get this joke and those who don't.

Post Reply

Return to “Gameplay Help”

Who is online

Users browsing this forum: No registered users