[Twinsen][1.1.4]LuaPlayer.set_personal_logistic_slot not updating moved request

This subforum contains all the issues which we already resolved.
Post Reply
Choumiko
Smart Inserter
Smart Inserter
Posts: 1352
Joined: Fri Mar 21, 2014 10:51 pm
Contact:

[Twinsen][1.1.4]LuaPlayer.set_personal_logistic_slot not updating moved request

Post by Choumiko »

When using LuaPlayer.set_personal_logistic_slot to set a request for an item that is already set as a request, the logistic tab doesn't update correctly.

To reproduce:
- Open logistics tab

Code: Select all

/c game.player.set_personal_logistic_slot(10, {name = "iron-plate", min = 100})
Gui updates as expected

Code: Select all

/c game.player.set_personal_logistic_slot(31, {name = "iron-plate", min = 100})
Gui shows iron plate 2 times
- Close and open gui, item is shown in slot 31

Code: Select all

/c game.player.set_personal_logistic_slot(10, {name = "iron-plate", min = 100})
Gui shows iron plate 2 times again
- Close and open gui, item is shown in slot 10

A bit more testing showed that appears to only not work as expected when setting the item forces Factorio to add a new row to the gui. Setting another item at slot 40 and then repeating the commands works as expected.
Same issue when using set_vehicle_logistic_slot on the spidertron

Twinsen
Factorio Staff
Factorio Staff
Posts: 1234
Joined: Tue Sep 23, 2014 7:10 am
Contact:

Re: [Twinsen][1.1.4]LuaPlayer.set_personal_logistic_slot not updating moved request

Post by Twinsen »

Fixed in Version: 1.1.6
Thanks for the report.

Post Reply

Return to “Resolved Problems and Bugs”