[kovarex] [1.1.2] When loading 1.1.1 save, some Spidertrons are gone

This subforum contains all the issues which we already resolved.
Post Reply
maxcreeger
Manual Inserter
Manual Inserter
Posts: 2
Joined: Thu Jun 21, 2018 9:36 pm
Contact:

[kovarex] [1.1.2] When loading 1.1.1 save, some Spidertrons are gone

Post by maxcreeger »

What I did:
I have a megabase, full vanilla in 1.1.1.
  • I was standing next to my Spidertron army (1x Red leader, 4x blacks following the leader), each with full Equipment grid, lots of inventory inside, and lots of logistic requests being filled
  • I saved in 1.1.1 (https://drive.google.com/file/d/1YmgMY ... p=sharing) - the save snapshot helpfully shows me standing next to the army in the shot.
  • I Updated to 1.1.2
  • I Loaded the save in 1.1.2
What happened:
Save file loads & I can play, but:
  • Missing half of my army: red leader Spidertron gone, only 2/4 black Spidertron still standing)
  • The Remote cthat was controlling the Red Spidertron is now controlling nothing
No crash, I can keep playing.
Can't tell if the Spidertrons are missing in the 1.1.1 save, or ignered during 1.1.2 loading.

What I expected:
I expect to see my full Spidertron army!

I have 3 Autosaves showing me next to my spidertron, I loaded one and it also only loads up half the army in 1.1.2 (the same Spideretrons go missing) so there seems to be a pattern there.
Attachments
factorio-previous.log
(7.5 KiB) Downloaded 29 times
factorio-current.log
(6.53 KiB) Downloaded 31 times
config.ini
(27.24 KiB) Downloaded 28 times

sorahn
Long Handed Inserter
Long Handed Inserter
Posts: 62
Joined: Tue Mar 17, 2020 11:35 pm
Contact:

[1.1.2] Spidertrons disappeared upgrading from 1.1.1

Post by sorahn »

When we upgraded our server to 1.1.2 a bunch of spidertrons disappeared from the map.

If you load the attached save in 1.1.1 you can see various groups of them sitting around. A group of 5 near -76,-108, and another group of 3 near -29,-39, and if you load it in 1.1.2 most of them are gone.

1.1.1
1.1.2
Attachments
Disappearing Spidertrons.zip
(26.34 MiB) Downloaded 31 times

sorahn
Long Handed Inserter
Long Handed Inserter
Posts: 62
Joined: Tue Mar 17, 2020 11:35 pm
Contact:

Re: [1.1.2] Spidertrons disappeared upgrading from 1.1.1

Post by sorahn »

A little bit more info when looking through more auto-saves. It seems that the ones that were clustered really close together are the ones that disappeared. In the screenshots/save I posted 2 from the attack group are a little farther apart and survived the upgrade. But on the actual server they had moved somewhere else and were all sitting almost directly on top of each other and none survived that.

BinarySpike
Burner Inserter
Burner Inserter
Posts: 5
Joined: Tue Jun 28, 2016 2:15 am
Contact:

Re: [1.1.2] Spidertrons disappeared upgrading from 1.1.1

Post by BinarySpike »

I'm having the same issue, I had a conga-line of 4. I lost the middle two.

kovarex
Factorio Staff
Factorio Staff
Posts: 8053
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [1.1.2] Spidertrons disappeared upgrading from 1.1.1

Post by kovarex »

Thanks for the report, fixed for the next verison.

TheRaph
Fast Inserter
Fast Inserter
Posts: 193
Joined: Sun Sep 24, 2017 6:31 pm
Contact:

Re: [1.1.2] Spidertrons disappeared upgrading from 1.1.1

Post by TheRaph »

kovarex wrote:
Sat Nov 28, 2020 8:01 pm
Thanks for the report, fixed for the next verison.
Will they reapear in my 1.1.2-Save or have I to load original save from 1.1.1?

User avatar
NotRexButCaesar
Smart Inserter
Smart Inserter
Posts: 1046
Joined: Sun Feb 16, 2020 12:47 am
Contact:

Re: [1.1.2] Spidertrons disappeared upgrading from 1.1.1

Post by NotRexButCaesar »

TheRaph wrote:
Sun Nov 29, 2020 11:50 pm
Will they reapear in my 1.1.2-Save or have I to load original save from 1.1.1?
You’ll need to load the 1.1.1 save.
: Alea jacta est. Determine what you intend to accomplish with an action before execution.
Have you ever heard the gospel? Most have not.

Post Reply

Return to “Resolved Problems and Bugs”