[Rseding91] [1.0.0] Grid cannot be accessed in Locomotive with void energy source

This subforum contains all the issues which we already resolved.
Post Reply
Schallfalke
Fast Inserter
Fast Inserter
Posts: 162
Joined: Sun Oct 28, 2018 7:57 am
Contact:

[Rseding91] [1.0.0] Grid cannot be accessed in Locomotive with void energy source

Post by Schallfalke »

Problem:
Vehicle grids (introduced by mods) on train carriages are normally accessible, except for one case: an locomotive using "void" energy source. The "Fuel" tab is disabled with the tooltip saying "Locomotive doesn't need energy", making the grid inaccessible.

Steps to reproduce:
1. Use my mods Schall Tank Platoon, Schall Armoured Train, Schall Perpetual Machine.
2. Look at any locomotives using void energy source (All with a "∞" prefix in the names, and have a shiny red ball on top left of their icons) and having grids. As an example, both my "Armoured locomotive MK2" (normal burner energy source) and "∞ Armoured locomotive MK2" (void energy source) have same 9×9 grid.
3. The grid screen (from "Fuel" tab) is only accessible on locomotive with normal burner energy source, but not the one with void energy source.
Locomotive Void Grid.png
Locomotive Void Grid.png (217.16 KiB) Viewed 1274 times
In principle, you can make a new locomotive with void energy source and equipment grid to reproduce the same bug.
My mods are just one way to show it.

Rseding91
Factorio Staff
Factorio Staff
Posts: 12146
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [1.0.0] Grid cannot be accessed in Locomotive with void energy source

Post by Rseding91 »

Thanks for the report. This is now fixed for the next release.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved Problems and Bugs”