[Wheybags] [0.18.17] Certain translations fail with keyboard binds

This subforum contains all the issues which we already resolved.
Post Reply
User avatar
BluePsyduck
Burner Inserter
Burner Inserter
Posts: 13
Joined: Thu Jun 08, 2017 4:52 pm
Contact:

[Wheybags] [0.18.17] Certain translations fail with keyboard binds

Post by BluePsyduck »

While looking through different aspects of the game (what else to do when the workplace has been shut down atm :D) I came across an issue regarding certain translations and key binds:
failed-translation.jpg
failed-translation.jpg (65.66 KiB) Viewed 1310 times
As you can see, the translation reads:
Kann auch durch bad control sequence, alt control locales only valid for mouse button inputs zum manuellen Verbinden...
The underlined part is where the translations fail. There should be the assigned key printed there.

Cause of the issue:

The German description of copper-cable uses the placeholder "__ALT_CONTROL__1__build__", which is an alternative translation of "__CONTROL__build__" to better match the grammar. But these alternative translations are only available for mouse inputs: When you change the input to a keyboard key, the translation fails with "bad control sequence, alt control locales only valid for mouse button inputs" instead of printing the assigned key in some way.

Reproduction steps:
  1. Change the game language to German. Restart the game to apply the change.
  2. Change the keybind of "Build" (or "Bauen" in German) to any key on the keyboard, lets say "P" for "problem" :P
  3. Start a new game, and hover over the copper cable. You see the miss-translated description as shown in the screenshot.
Image

User avatar
wheybags
Former Staff
Former Staff
Posts: 328
Joined: Fri Jun 02, 2017 1:50 pm
Contact:

Re: [Wheybags] [0.18.17] Certain translations fail with keyboard binds

Post by wheybags »

Thanks for the report!

I've added support for keyboard keys and mouse scroll to the alt control system, they will be available in 1.1. The new keys will be described here when 1.1 is released. It will work pretty much the same as it does for mouse buttons atm.

Post Reply

Return to “Resolved Problems and Bugs”