[Klonan] [0.18.4] Construction bot becomes invisible while repairing something

This subforum contains all the issues which we already resolved.
Post Reply
traycer
Inserter
Inserter
Posts: 37
Joined: Fri Jul 07, 2017 5:40 am
Contact:

[Klonan] [0.18.4] Construction bot becomes invisible while repairing something

Post by traycer »

Construction bots temporarily disappear while they are repairing an entity. The glow and sparks remain visible, but the sprite of the robot itself is invisible.

Example video: https://streamable.com/k6es9

billbo99
Fast Inserter
Fast Inserter
Posts: 124
Joined: Fri Nov 02, 2018 9:19 am
Contact:

[0.18.4] Construction Robot missing "working" property

Post by billbo99 »

Something changed for "Construction Robot" in 0.18.4 and the "working" property for RotatedAnimation has been removed.


I am told the WIKI is a little out of date, but in the 0.18.4 release notes there was no mention of this property being removed.
https://wiki.factorio.com/Prototype/Con ... ot#working


Was it accidently removed with some of the sound updates ?

billbo99
Fast Inserter
Fast Inserter
Posts: 124
Joined: Fri Nov 02, 2018 9:19 am
Contact:

Re: [0.18.4] Construction bot becomes invisible while repairing something

Post by billbo99 »

This coud be related to my post .. viewtopic.php?f=7&t=80985

The ".working" property that sets the animation for the bots while busy appears to have been removed.

User avatar
Deadlock989
Smart Inserter
Smart Inserter
Posts: 2384
Joined: Fri Nov 06, 2015 7:41 pm

Re: [0.18.4] Construction Robot missing "working" property

Post by Deadlock989 »

Can't reproduce with modded construction bots that define their own .working property from scratch - they are behaving normally in 0.18.4 - so it's not that the property has been removed.

However the vanilla bots seem to have nothing defined for that property (or something that produces an empty sprite) and become invisible when working on something.
"If Stalin had a good writeup on programming, would linking that be dangerous?"

User avatar
Klonan
Factorio Staff
Factorio Staff
Posts: 4934
Joined: Sun Jan 11, 2015 2:09 pm
Contact:

Re: [Klonan] [0.18.4] Construction bot becomes invisible while repairing something

Post by Klonan »

I did some reorginization of the files, and missed the working animation

Fixed for the next release

LennyNLD
Manual Inserter
Manual Inserter
Posts: 2
Joined: Mon Mar 27, 2017 11:18 pm
Contact:

Re: [Klonan] [0.18.4] Construction bot becomes invisible while repairing something

Post by LennyNLD »

Sounds like an oeps :lol: :lol:

User avatar
ptx0
Smart Inserter
Smart Inserter
Posts: 1080
Joined: Wed Jan 01, 2020 7:16 pm
Contact:

Re: [Klonan] [0.18.4] Construction bot becomes invisible while repairing something

Post by ptx0 »

sounds like a perfect use case for some unit regression tests to be implemented that will catch these errors before being committed to the master branch.
My Mods - Fish Per Minute base size metric - Use your crashed spaceship as a belt balancer?
• • •
Base: Bob's @ 1 Million SPM
• • •
Linear search and overflows are indicative of sloppy coding practices.

Post Reply

Return to “Resolved Problems and Bugs”