[posila] [0.17.62] Items switch lanes after player incorrectly extends underground belt span

This subforum contains all the issues which we already resolved.
Post Reply
OkraDonkey
Burner Inserter
Burner Inserter
Posts: 13
Joined: Sat Dec 16, 2017 1:24 pm
Contact:

[posila] [0.17.62] Items switch lanes after player incorrectly extends underground belt span

Post by OkraDonkey »

Problem description/reproduction:

Let's say you have one belt with two different items on it, for example copper and steel. To cross an obstacle, you have installed an underground belt with a span of 1 tile between hoods. Later, you decide that you need to increase the span to 2 tiles between hoods.

Best practice is to first delete the "exit hood," then install a new "exit hood" one tile further away. Done in this fashion, everything works as expected. Some items that were underground are picked up into inventory, but others on the belt continue on their way after the hood is replaced.

Underground-Correct.png
Underground-Correct.png (2.43 MiB) Viewed 1783 times

However, if you mistakenly place the new "exit hood" first, then subsequently mine the original "exit hood", you'll soon notice that the underground has been oriented in the wrong direction (this new intended "exit hood" has become an "entrance hood"). The direction is easy to fix, though; just mouseover either hood and type R to reverse the direction. The problem is that during this particular sequence, at the moment the original "exit hood" is mined, exactly two items from each lane, near the opening of the original "entrance hood," will magically switch lanes. Now you have two pieces of steel in your copper lane, and two pieces of copper in your steel lane.

Underground-Incorrect.png
Underground-Incorrect.png (2.42 MiB) Viewed 1783 times

Expected behavior:
Items on the belt/underground should stay in their lanes, even if the direction of travel is reversed by the original-exit-hood-mining operation; Behavior should be consistent with reversing direction by the mouseover-R command. Instead, items currently behave as if a portion of the belt segment has been rotated laterally 180 degrees.

Discussion:
Defaulting to always orient a newly placed underground belt as if it was an entrance (unless it lines up as an exit to an existing hood) makes sense, and the result of a reversed orientation is a fairly obvious and easily correctable mistake. However, it is not nearly as visually obvious that a couple of items have switched lanes, and this lane-switching behavior doesn't make intuitive sense. This can cause unforeseen problems down the production line, and may go unnoticed for hours (or players may notice the problem later with no understanding of its cause).

I understand that one response might be to advise players to simply remember to delete the original exit hood before placing the new exit hood. This would be ideal, but in my opinion, a mistake like this should produce an appropriate outcome (wrong-way underground; belt throughput halted) instead of an unintuitive one (wrong-way underground plus several potentially hard-to-see items switched lanes).

Thank you for considering my feedback.
Attachments
factorio-current.log
(4.99 KiB) Downloaded 64 times

posila
Factorio Staff
Factorio Staff
Posts: 5154
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [0.17.62] Items switch lanes after player incorrectly extends underground belt span

Post by posila »

Thank you for taking the time to write up the bug report.

It should be fixed for 0.17.64

OkraDonkey
Burner Inserter
Burner Inserter
Posts: 13
Joined: Sat Dec 16, 2017 1:24 pm
Contact:

Re: [0.17.62] Items switch lanes after player incorrectly extends underground belt span

Post by OkraDonkey »

Awesome! Thank you!

Post Reply

Return to “Resolved Problems and Bugs”