[Rseding91] [0.17.54] No GUI after Mod sync game restart, if MP lobby server returns HTTP 404

This subforum contains all the issues which we already resolved.
Post Reply
Posts: 32
Joined: Thu Jun 01, 2017 12:59 pm

[Rseding91] [0.17.54] No GUI after Mod sync game restart, if MP lobby server returns HTTP 404

Post by luziferius »

I tried to join a vanilla multiplayer game, while I had some mods enabled. When the Game restarted after the mod sync process, the MP lobby server somehow returned an HTTP 404 error, causing the restarted game instance to get stuck without a GUI.

I expected the game to either throw me back into the main menu or show a dialogue window allowing me to cancel and go back.

What I did:
  1. I opened the Multiplayer game list, chose to join a vanilla game.
  2. I accepted the sync dialogue, disabled all mods
  3. I let the game restart
  4. The new game starts, but no GUI shows up. Nothing. Needed Alt+F4 to exit.
What I think needs to be done to reproduce:
  1. Start a modded factorio instance
  2. Start a vanilla factorio server.
  3. Join the vanilla server. During the mod sync process, enable to automatically join after the restart process
  4. During the mod sync process, maybe during game load after restart, kill/stop the running factorio server.
  5. Now the game automatically tries to connect to a non-existing server and shows no GUI.
Log of first instance (with mods, worked):

Code: Select all

   0.000 2019-07-06 20:54:19; Factorio 0.17.54 (build 46015, linux64, steam)
   0.100 Operating system: Linux (Ubuntu 19.04)
   0.100 Program arguments: "/mnt/Spiele/Steam/steamapps/common/Factorio/bin/x64/factorio" 
   0.100 Read data path: /mnt/Spiele/Steam/steamapps/common/Factorio/data
   0.100 Write data path: /home/thomas/.factorio [28888/100665MB]
   0.100 Binaries path: /mnt/Spiele/Steam/steamapps/common/Factorio/bin
   0.167 System info: [CPU: AMD Phenom(tm) II X6 1055T Processor, 6 cores, RAM: 16036 MB]
   0.167 Display options: [FullScreen: 1] [VSync: 0] [UIScale: custom (100.0%)] [Native DPI: 1] [Screen: 255] [Special: 0000] [Lang: de]
   0.348 Available displays: 2
   0.349  [0]: Hanns.G HA222 22" - {[0,0], 1680x1050, SDL_PIXELFORMAT_RGB888, 60Hz}
   0.349  [1]: Philips 220SW 22" - {[1680,0], 1680x1050, SDL_PIXELFORMAT_RGB888, 60Hz}
   0.434 Initialised OpenGL:[0] GeForce GTX 1070/PCIe/SSE2; driver: 3.3.0 NVIDIA 430.26
   0.434   [Extensions] s3tc:yes; KHR_debug:yes; ARB_clear_texture:yes, ARB_copy_image:yes
   0.434   [Version] 3.3
   0.754 Graphics settings preset: very-high
   0.754   Dedicated video memory size 8192 MB
   0.754 Graphics options: [Graphics quality: high] [Video memory usage: all] [Light scale: 25%] [DXT: none]
   0.754                   [Max load threads: 32] [Max texture size: 0] [Tex.Stream.: 0] [Rotation quality: normal] [Color: 32bit]
   1.779 Loading mod core 0.0.0 (data.lua)
   2.067 Loading mod base 0.17.54 (data.lua)
   3.526 Loading mod BlackMarket 1.2.2 (data.lua)
   3.823 Loading mod bullet-trails 0.4.1 (data.lua)
   4.019 Loading mod Vehicle Wagon 1.2.6 (data.lua)
   4.207 Loading mod base 0.17.54 (data-updates.lua)
   4.394 Loading mod bullet-trails 0.4.1 (data-updates.lua)
   4.572 Loading mod DiscoScience 0.1.12 (data-final-fixes.lua)
   4.835 Checksum for core: 2486543994
   4.835 Checksum of base: 2542100768
   4.835 Checksum of BlackMarket: 844091046
   4.835 Checksum of bullet-trails: 3671570151
   4.835 Checksum of DiscoScience: 976323401
   4.835 Checksum of Vehicle Wagon: 3996728634
   5.646 Loading sounds...
   6.621 Info PlayerData.cpp:69: Local player-data.json unavailable
   6.621 Info PlayerData.cpp:72: Cloud player-data.json available, timestamp 1562424325
   6.928 Crop bitmaps.
  31.567 Parallel Sprite Loader initialized (threads: 5)
  51.430 Initial atlas bitmap size is 16384
  51.480 Created atlas bitmap 16384x16370 [not-compressed]
  51.487 Created atlas bitmap 16384x11305 [not-compressed]
  51.487 Created atlas bitmap 8192x3842 [decal, not-compressed]
  51.488 Created atlas bitmap 16384x4312 [low-object, not-compressed]
  51.488 Created atlas bitmap 8192x3664 [not-compressed, mipmap, linear-minification, linear-magnification, linear-mip-level]
  51.490 Created atlas bitmap 16384x6880 [terrain, not-compressed, mipmap, linear-minification, linear-mip-level]
  51.490 Created atlas bitmap 4096x1592 [smoke, not-compressed, mipmap, linear-minification, linear-magnification]
  51.491 Created atlas bitmap 4096x1728 [icon, not-compressed, mipmap, linear-minification, linear-magnification, linear-mip-level]
  51.491 Created atlas bitmap 2048x192 [icon-background, not-compressed, mipmap, linear-minification, linear-magnification, linear-mip-level, ]
  51.491 Created atlas bitmap 8192x1496 [alpha-mask]
  51.497 Created atlas bitmap 16384x12640 [shadow, linear-magnification, alpha-mask]
  51.497 Created atlas bitmap 8192x2352 [shadow, mipmap, linear-magnification, alpha-mask]
  51.546 Texture processor created (2048). GPU accelerated compression Supported: yes, Enabled: yes/yes. Test passed. YCoCgDXT PSNR: 35.83, BC3 PSNR: 33.82
  52.503 Parallel Sprite Loader initialized (threads: 5)
  72.864 Sprites loaded
  73.022 Generated mipmaps (4) for atlas [3] of size 16384x4312   
  73.092 Generated mipmaps (3) for atlas [4] of size 8192x3664   
  73.295 Generated mipmaps (3) for atlas [5] of size 16384x6880   
  73.309 Generated mipmaps (3) for atlas [6] of size 4096x1592   
  73.329 Generated mipmaps (4) for atlas [7] of size 4096x1728   
  73.334 Generated mipmaps (3) for atlas [11] of size 8192x2352   
  73.348 Custom mipmaps uploaded.
  73.414 Custom inputs active: 0
  73.964 Factorio initialised
 103.801 Info HttpSharedState.cpp:54: Downloading https://auth.factorio.com/api-login?api_version=2
 104.641 Info AuthServerConnector.cpp:171: Got token from auth server for username(luziferius).
 104.806 Info UDPSocket.cpp:27: Opening socket at (IP ADDR:({}))
 239.204 Info UDPSocket.cpp:210: Closing socket
 239.205 Info UDPSocket.cpp:240: Socket closed
 239.205 Info UDPSocket.cpp:210: Closing socket
 245.818 Info AppManager.cpp:1163: Restarting Factorio
 245.818 Restarting for reason other than update. Setting execute permission skipped.
 245.818 Info AppManager.cpp:1196: Executable path: /mnt/Spiele/Steam/steamapps/common/Factorio/bin/x64/factorio
 246.264 Steam API shutdown.
 246.269 Goodbye
Shortened log of restarted instance (hung after game load, when it should connect to the MP server):

Code: Select all

  26.042 Factorio initialised
  26.044 Info AppManagerStates.cpp:880: Connecting to game with gameID 4294967295
  26.152 Info HttpSharedState.cpp:54: Downloading https://multiplayer.factorio.com/get-game-details/4294967295
  26.689 Info HttpSharedState.cpp:145: Downloading https://multiplayer.factorio.com/get-game-details/4294967295
  26.689 Info HttpSharedState.cpp:146: Status code: 404
 151.795 Quitting: window closed.
 152.249 Steam API shutdown.
 152.256 Goodbye
No GUI visible, log visible on the right
No GUI visible, log visible on the right
Screenshot_20190706_210040.png (2.55 MiB) Viewed 1802 times
(5.07 KiB) Downloaded 79 times
(4.4 KiB) Downloaded 77 times

Factorio Staff
Factorio Staff
Posts: 12277
Joined: Wed Jun 11, 2014 5:23 am

Re: [Rseding91] [0.17.54] No GUI after Mod sync game restart, if MP lobby server returns HTTP 404

Post by Rseding91 »

Thanks for the report. It's now fixed for the next version of 0.17.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved Problems and Bugs”