[kovarex] [0.17.50] Crash During Auto-Save With Keypress (connection.rail->segment->hasSignal(this) was not true)

This subforum contains all the issues which we already resolved.
Post Reply
wizard07ksu
Inserter
Inserter
Posts: 23
Joined: Fri Dec 29, 2017 11:00 am
Contact:

[kovarex] [0.17.50] Crash During Auto-Save With Keypress (connection.rail->segment->hasSignal(this) was not true)

Post by wizard07ksu »

  1. What did I do? I pressed 'Q' while mouse was hovering over an angled rail signal attached to a rail segment just after the auto-save progress bar dialog appeared.
  2. What happened? The progress bar froze for several seconds, then the "game has crashed dialog" appeared.
  3. What did I expect to happen? I didn't expect the game to crash just because I pressed a key during the auto-save dialog. I know that some features of the game are still enabled during auto-save (can still go through blueprints), but I would have expected all other actions to be explicitly disabled for the duration of the save.
I have only experienced this bug once.
Attachments
_autosave3.zip
Most recent auto-save from the game. Should be 5 minutes before crash.
(14.26 MiB) Downloaded 33 times
factorio-current.log
(10.12 KiB) Downloaded 37 times

1cec0ld
Manual Inserter
Manual Inserter
Posts: 3
Joined: Thu Jun 20, 2019 2:59 am
Contact:

Re: [0.17.50] Crash During Auto-Save With Keypress

Post by 1cec0ld »

I suspect I'm also a victim of this one, just occurred. I wasn't paying attention to what I was doing, just know it crashed as the autosave popup began.
Attachments
_autosave3.tmp.zip
looks like a temp file, timestamp is 5 minutes after autosave2, so possibly a partial save before crash
(1.05 MiB) Downloaded 33 times
_autosave2.zip
autosave 5 min before crash
(43.53 MiB) Downloaded 33 times
factorio-current.log
(10.72 KiB) Downloaded 36 times

User avatar
boskid
Factorio Staff
Factorio Staff
Posts: 1568
Joined: Thu Dec 14, 2017 6:56 pm
Contact:

Re: [0.17.50] Crash During Auto-Save With Keypress

Post by boskid »

wizard07ksu log
This is something new, trains related
---
1cec0ld's log
1cec0ld log
Also trains related but different assertion failed. May be Duplicate 72006

wizard07ksu
Inserter
Inserter
Posts: 23
Joined: Fri Dec 29, 2017 11:00 am
Contact:

Re: [0.17.50] Crash During Auto-Save With Keypress (connection.rail->segment->hasSignal(this) was not true)

Post by wizard07ksu »

Two more pieces of info:
  1. Factorio created a partial save file and said it was corrupt when I next started the game. I didn't explicitly try to load it, the game auto-selected the file and told me it was corrupt via a dialog with a "Confirm" button. When I looked for that file in the saves directory just now, it wasn't there.
  2. After loading the save file I did upload, I was able to play past the point where the game crashed. This map is still small enough that saves go pretty quickly - I have another, much larger base where saving takes several seconds. I can attempt to recreate the bug there if that will help?

Mihu
Manual Inserter
Manual Inserter
Posts: 2
Joined: Sun Jul 16, 2017 9:57 pm
Contact:

Re: [0.17.50] Crash During Auto-Save With Keypress (connection.rail->segment->hasSignal(this) was not true)

Post by Mihu »

For me this had nothing to do with keypresses - see viewtopic.php?f=47&t=72733 for a simple repro (was marked as duplicate).

kovarex
Factorio Staff
Factorio Staff
Posts: 8053
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [kovarex] [0.17.50] Crash During Auto-Save With Keypress (connection.rail->segment->hasSignal(this) was not true)

Post by kovarex »

Hello, this is most probably related to a bug already fixed for the next version.

Post Reply

Return to “Resolved Problems and Bugs”