[0.17.6] Mod active version non-functional

This subforum contains all the issues which we already resolved.
Post Reply
Artentus
Fast Inserter
Fast Inserter
Posts: 237
Joined: Sat Sep 24, 2016 8:16 pm
Contact:

[0.17.6] Mod active version non-functional

Post by Artentus » Wed Mar 06, 2019 3:00 pm

I'm not sure if this is actually a bug or if this feature just hasn't been fully implemented yet, that's why I'm asking.

0.17 introduced a new feature that allows for multiple versions of the same mod to be installed simultaneously, which fixes many incompatibility issues with servers.
All of the installed versions can be seen in the "Active version" drop down like shown here:
Image

However the problem is it appears the selection in this drop down is not being saved anywhere. After every restart of Factory or just when manually selecting a version, then leaving and reentering the mod list, the selection is reset to the latest version.
I wondered then why the drop down even exists if it doesn't do anything. My conclusion is this is either a bug or missing functionality.

Rseding91
Factorio Staff
Factorio Staff
Posts: 9670
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.17.6] Mod active version non-functional

Post by Rseding91 » Thu Mar 07, 2019 5:21 pm

Thanks for the report. It was broken and it's now fixed for the next version of 0.17.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users