[posila] [0.17.3] game fails to start (macOS Sierra)

This subforum contains all the issues which we already resolved.
karock
Burner Inserter
Burner Inserter
Posts: 14
Joined: Tue Feb 26, 2019 7:17 pm
Contact:

Re: [posila] [0.17.3] game fails to start (macOS Sierra)

Post by karock » Mon Mar 04, 2019 2:11 pm

posila wrote:
Mon Mar 04, 2019 1:24 pm
After 0.17.5 is released, please post new crashlogs from crashed druing game startup.
will do. is there an ETA for 0.17.5 yet or should I just check back periodically throughout the day?

posila
Factorio Staff
Factorio Staff
Posts: 3519
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [posila] [0.17.3] game fails to start (macOS Sierra)

Post by posila » Mon Mar 04, 2019 2:57 pm

Probably in four or so hours from now.

rob123
Manual Inserter
Manual Inserter
Posts: 1
Joined: Mon Mar 04, 2019 8:36 pm
Contact:

Re: [posila] [0.17.3] game fails to start (macOS Sierra)

Post by rob123 » Mon Mar 04, 2019 8:39 pm

Hi, I'm not the OP, but i had the same issues.

I'm on El Capitan - 10.11.6, and had the same bad_variant_access log on 0.17.[0-3] before any windows even appeared. In 0.17.4 the game was beginning to load (saw the logo with the progress bar and everything) but before finishing it prompted me to open the crash.log folder and then stalled until I force quit it.

Now in 0.17.5 (with the added stack trace) I've got the new log:

https://pastebin.com/CWC1eM4g

karock
Burner Inserter
Burner Inserter
Posts: 14
Joined: Tue Feb 26, 2019 7:17 pm
Contact:

Re: [posila] [0.17.5] game fails to start (macOS Sierra)

Post by karock » Tue Mar 05, 2019 2:49 am

Code: Select all

   0.066 2019-03-04 21:48:19; Factorio 0.17.5 (build 43269, mac, alpha)
   0.066 Operating system: macOS 10.12.6
   0.068 Program arguments: "/Applications/Games/factorio.app/Contents/MacOS/factorio" 
   0.068 Read data path: /Applications/Games/factorio.app/Contents/data
   0.068 Write data path: /Volumes/NewDrive/ty/Dropbox/factorio [3478014/4768487MB]
   0.068 Binaries path: /Applications/Games/factorio.app/Contents
   0.114 System info: [CPU: Intel(R) Xeon(R) CPU           W3680  @ 3.33GHz, 12 cores, RAM: 24576 MB]
   0.116 Display options: [FullScreen: 0] [VSync: 1] [UIScale: automatic (100.0%)] [MultiSampling: OFF] [Screen: 255] [Lang: en]
   0.401 Available displays: 2
   0.402  [0]: LED Cinema Display - {[0,0], 2560x1440, SDL_PIXELFORMAT_ARGB8888, 60Hz}
   0.402  [1]: Cinema HD - {[2560,0], 1920x1200, SDL_PIXELFORMAT_ARGB8888, 60Hz}
   0.518 Initialised OpenGL:[0] NVIDIA GeForce GTX 760 OpenGL Engine; driver: 4.1 NVIDIA-10.17.5 355.10.05.45f01
   0.518   [Extensions] s3tc:yes; KHR_debug:NO; ARB_clear_texture:NO, ARB_copy_image:NO
   0.518   [Version] 4.1
   0.698 Graphics settings preset: very-high
   0.698   Dedicated video memory size 4096 MB (detected from GeForce GTX 760)
   0.698 Graphics options: [Graphics quality: high] [Video memory usage: all] [Light scale: 50%] [DXT: high-quality]
   0.698                   [Max load threads: 32] [Max texture size: 0] [Tex.Stream.: 0] [Low quality rotation: 0]
   1.195 Loading mod core 0.0.0 (data.lua)
   1.304 Loading mod base 0.17.5 (data.lua)
   1.649 Loading mod base 0.17.5 (data-updates.lua)
   1.769 Checksum for core: 3928040144
   1.769 Checksum of base: 3918046970
   2.599 Loading sounds...
   3.066 Info PlayerData.cpp:67: Local player-data.json available, timestamp 1551470273
   3.066 Info PlayerData.cpp:74: Cloud player-data.json unavailable
   3.250 Crop bitmaps.
   9.587 Parallel Sprite Loader initialized (threads: 11)
  19.208 Initial atlas bitmap size is 16384
  19.236 Created atlas bitmap 16384x16384 [none]
  19.238 Created atlas bitmap 16384x11292 [none]
  19.239 Created atlas bitmap 16384x2116 [decal]
  19.239 Created atlas bitmap 16384x3808 [low-object]
  19.239 Created atlas bitmap 16384x1888 [mipmap, linear-minification, linear-magnification, linear-mip-level, no-crop, no-scale]
  19.239 Created atlas bitmap 16384x6880 [terrain, mipmap, linear-minification, linear-mip-level, no-crop]
  19.239 Created atlas bitmap 16384x480 [smoke, mipmap, linear-minification, linear-magnification]
  19.240 Created atlas bitmap 16384x456 [not-compressed, mipmap, linear-minification, linear-magnification, linear-mip-level, no-crop, no-scale]
  19.240 Created atlas bitmap 16384x748 [alpha-mask]
  19.241 Created atlas bitmap 16384x12632 [shadow, linear-magnification, alpha-mask]
  19.241 Created atlas bitmap 16384x1264 [shadow, mipmap, linear-magnification, alpha-mask]
  20.253 Error CrashHandler.cpp:515: Received SIGSEGV
Factorio crashed. Generating symbolized stacktrace, please wait ...
#1  0x0000000105ad0322 in Logger::logStacktrace(StackTraceInfo*) + 0x12
#2  0x0000000105ab992d in CrashHandler::writeStackTrace(CrashHandler::CrashReason) + 0x9d
#3  0x0000000105aba5b4 in CrashHandler::commonSignalHandler(int) + 0x74
#4  0x0000000105ab9819 in CrashHandler::SignalHandler(int) + 0x9
#5  0x00007fff8f6a9b3a in _sigtramp + 0x1a
#6  0x00007fff74dcb86d in <unknown> + 0x0
#7  0x00007fff74dc582f in <unknown> + 0x0
#8  0x00007fff74dbeaa5 in <unknown> + 0x0
#9  0x00007fff74ce636b in <unknown> + 0x0
#10 0x00007fff74f46c1f in gldReadTextureData + 0xaaf9d
#11 0x00007fff74f47588 in gldReadTextureData + 0xab906
#12 0x00007fff74e64902 in <unknown> + 0x0
#13 0x00007fff74e662d0 in <unknown> + 0x0
#14 0x00007fff74f51e0b in gldReadTextureData + 0xb6189
#15 0x00007fff74f5182e in gldReadTextureData + 0xb5bac
#16 0x00007fff74f516aa in gldReadTextureData + 0xb5a28
#17 0x00007fff74e65eb7 in <unknown> + 0x0
#18 0x00007fff74e6b13f in <unknown> + 0x0
#19 0x00007fff7529925e in gldBlitFramebufferData + 0x30f963
#20 0x00007fff752994e6 in gldBlitFramebufferData + 0x30fbeb
#21 0x00007fff752995d7 in gldBlitFramebufferData + 0x30fcdc
#22 0x00007fff74e6dd3d in <unknown> + 0x0
#23 0x00007fff74f881ad in gldUpdateDispatch + 0x411
#24 0x000000010b15b32a in gleDoDrawDispatchCoreGL3 + 0x208
#25 0x000000010b10cbd9 in gleDrawArraysOrElements_Entries_Body + 0x80
#26 0x000000010b105ff0 in glDrawElements_GL3Exec + 0xcf
#27 0x00000001052aff3b in GraphicsInterfaceOpenGL::drawIndexed(VideoBuffer*, VideoBuffer*, unsigned int, unsigned int) + 0xcb
#28 0x000000010524b71b in TextureProcessor::testGpuAcceleratedCompression(GraphicsInterface&) + 0xbcb
#29 0x000000010524105e in AtlasSystem::createTextureProcessor() + 0x7e
#30 0x000000010523f43b in AtlasSystem::loadSprites(bool) + 0x12b
#31 0x000000010524c70c in AtlasSystem::tryLoadSpritesWithFallbackToMinimalMode(bool) + 0x2c
#32 0x000000010522876a in AtlasSystem::build() + 0x1fa
#33 0x00000001052248bd in GlobalContext::init(bool, bool, bool) + 0x22fd
#34 0x000000010570e7ea in MainLoop::run(Filesystem::Path const&, Filesystem::Path const&, bool, bool, std::__1::function<void ()>, Filesystem::Path const&, MainLoop::HeavyMode) + 0xea
#35 0x0000000104d275ba in main + 0x1361a
Stack trace logging done
  20.371 Error Util.cpp:97: Unexpected error occurred. If you're running the latest version of the game you can help us solve the problem by posting the contents of the log file on the Factorio forums.
Please also include the save file(s), any mods you may be using, and any steps you know of to reproduce the crash.
  32.016 Received SIGTERM, shutting down

badams
Burner Inserter
Burner Inserter
Posts: 7
Joined: Wed Feb 27, 2019 6:58 pm
Contact:

[0.17.5] game fails to start (macOS Sierra)

Post by badams » Tue Mar 05, 2019 4:47 am

I'm still having problems in 0.17.5 that look like the 0.17.4 ones. It gets to the "Cropping bitmaps" stage and then hits an "Unexpected error occurred":

Code: Select all

   0.000 2019-03-04 23:45:28; Factorio 0.17.5 (build 43269, mac, alpha)
   0.000 Operating system: macOS 10.12.6
   0.000 Program arguments: "/Applications/factorio 0.17.5.app/Contents/MacOS/factorio" 
   0.000 Read data path: /Applications/factorio 0.17.5.app/Contents/data
   0.000 Write data path: /Users/badams/Library/Application Support/factorio [98301/715300MB]
   0.000 Binaries path: /Applications/factorio 0.17.5.app/Contents
   0.005 System info: [CPU:       Intel(R) Core(TM) i7-3820QM CPU @ 2.70GHz, 8 cores, RAM: 16384 MB]
   0.006 Display options: [FullScreen: 0] [VSync: 1] [UIScale: automatic (100.0%)] [MultiSampling: OFF] [Screen: 255] [Lang: en]
   0.201 Available displays: 3
   0.201  [0]: Color LCD - {[0,0], 1440x900, SDL_PIXELFORMAT_ARGB8888, 60Hz}
   0.201  [1]: EA231WMi - {[-1080,-1710], 1080x1920, SDL_PIXELFORMAT_ARGB8888, 60Hz}
   0.211  [2]: BenQ LCD - {[0,-1440], 2560x1440, SDL_PIXELFORMAT_ARGB8888, 60Hz}
   0.341 Initialised OpenGL:[0] NVIDIA GeForce GT 650M OpenGL Engine; driver: 4.1 NVIDIA-10.17.5 355.10.05.45f01
   0.341   [Extensions] s3tc:yes; KHR_debug:NO; ARB_clear_texture:NO, ARB_copy_image:NO
   0.341   [Version] 4.1
   0.461   Dedicated video memory size 1024 MB (detected from GeForce GT 650M)
   0.461 Graphics options: [Graphics quality: normal] [Video memory usage: high] [Light scale: 25%] [DXT: low-quality]
   0.461                   [Max load threads: 32] [Max texture size: 4096] [Tex.Stream.: 1] [Low quality rotation: 1]
   0.707 Loading mod core 0.0.0 (data.lua)
   0.794 Loading mod base 0.17.5 (data.lua)
   0.997 Loading mod base 0.17.5 (data-updates.lua)
   1.102 Checksum for core: 3928040144
   1.102 Checksum of base: 3918046970
   1.632 Loading sounds...
   1.654 Info PlayerData.cpp:69: Local player-data.json unavailable
   1.654 Info PlayerData.cpp:74: Cloud player-data.json unavailable
   1.721 Crop bitmaps.
   1.922 Parallel Sprite Loader initialized (threads: 7)
   4.896 Initial atlas bitmap size is 4096
   4.901 Created atlas bitmap 4096x4096 [none]
   4.908 Created atlas bitmap 4096x4084 [none]
   4.910 Created atlas bitmap 4096x4092 [none]
   4.913 Created atlas bitmap 4096x4092 [none]
   4.915 Created atlas bitmap 4096x4072 [none]
   4.918 Created atlas bitmap 4096x4096 [none]
   4.918 Created atlas bitmap 4096x360 [none]
   4.918 Created atlas bitmap 4096x1952 [decal]
   4.918 Created atlas bitmap 4096x3824 [low-object]
   4.918 Created atlas bitmap 4096x2000 [mipmap, linear-minification, linear-magnification, linear-mip-level, no-crop, no-scale]
   4.921 Created atlas bitmap 4096x4080 [terrain, mipmap, linear-minification, linear-mip-level, no-crop]
   4.921 Created atlas bitmap 4096x4064 [terrain, mipmap, linear-minification, linear-mip-level, no-crop]
   4.921 Created atlas bitmap 4096x416 [terrain, mipmap, linear-minification, linear-mip-level, no-crop]
   4.921 Created atlas bitmap 4096x1600 [smoke, mipmap, linear-minification, linear-magnification]
   4.921 Created atlas bitmap 4096x1388 [not-compressed, mipmap, linear-minification, linear-magnification, linear-mip-level, no-crop, no-scale]
   4.921 Created atlas bitmap 4096x836 [alpha-mask]
   4.925 Created atlas bitmap 4096x4096 [shadow, linear-magnification, alpha-mask]
   4.928 Created atlas bitmap 4096x4096 [shadow, linear-magnification, alpha-mask]
   4.933 Created atlas bitmap 4096x4096 [shadow, linear-magnification, alpha-mask]
   4.933 Created atlas bitmap 4096x528 [shadow, linear-magnification, alpha-mask]
   4.933 Created atlas bitmap 4096x1296 [shadow, mipmap, linear-magnification, alpha-mask]
   4.983 Created virtual atlas pages 4096x4096x2
   5.003 Error CrashHandler.cpp:515: Received SIGSEGV
Factorio crashed. Generating symbolized stacktrace, please wait ...
#1  0x000000010d1b3322 in Logger::logStacktrace(StackTraceInfo*) + 0x12
#2  0x000000010d19c92d in CrashHandler::writeStackTrace(CrashHandler::CrashReason) + 0x9d
#3  0x000000010d19d5b4 in CrashHandler::commonSignalHandler(int) + 0x74
#4  0x000000010d19c819 in CrashHandler::SignalHandler(int) + 0x9
#5  0x00007fffb5496b3a in _sigtramp + 0x1a
#6  0x00007fff9ac1c86d in <unknown> + 0x0
#7  0x00007fff9ac1682f in <unknown> + 0x0
#8  0x00007fff9ac0faa5 in <unknown> + 0x0
#9  0x00007fff9ab3736b in <unknown> + 0x0
#10 0x00007fff9ad97c1f in gldReadTextureData + 0xaaf9d
#11 0x00007fff9ad98588 in gldReadTextureData + 0xab906
#12 0x00007fff9acb5902 in <unknown> + 0x0
#13 0x00007fff9acb72d0 in <unknown> + 0x0
#14 0x00007fff9ada2e0b in gldReadTextureData + 0xb6189
#15 0x00007fff9ada282e in gldReadTextureData + 0xb5bac
#16 0x00007fff9ada26aa in gldReadTextureData + 0xb5a28
#17 0x00007fff9acb6eb7 in <unknown> + 0x0
#18 0x00007fff9acbc13f in <unknown> + 0x0
#19 0x00007fff9b0ea25e in gldBlitFramebufferData + 0x30f963
#20 0x00007fff9b0ea4e6 in gldBlitFramebufferData + 0x30fbeb
#21 0x00007fff9b0ea5d7 in gldBlitFramebufferData + 0x30fcdc
#22 0x00007fff9acbed3d in <unknown> + 0x0
#23 0x00007fff9add91ad in gldUpdateDispatch + 0x411
#24 0x00007fffa497532a in gleDoDrawDispatchCoreGL3 + 0x208
#25 0x00007fffa4926bd9 in gleDrawArraysOrElements_Entries_Body + 0x80
#26 0x00007fffa491fff0 in glDrawElements_GL3Exec + 0xcf
#27 0x000000010c992f3b in GraphicsInterfaceOpenGL::drawIndexed(VideoBuffer*, VideoBuffer*, unsigned int, unsigned int) + 0xcb
#28 0x000000010c92e71b in TextureProcessor::testGpuAcceleratedCompression(GraphicsInterface&) + 0xbcb
#29 0x000000010c92405e in AtlasSystem::createTextureProcessor() + 0x7e
#30 0x000000010c92243b in AtlasSystem::loadSprites(bool) + 0x12b
#31 0x000000010c92f70c in AtlasSystem::tryLoadSpritesWithFallbackToMinimalMode(bool) + 0x2c
#32 0x000000010c90b76a in AtlasSystem::build() + 0x1fa
#33 0x000000010c9078bd in GlobalContext::init(bool, bool, bool) + 0x22fd
#34 0x000000010cdf17ea in MainLoop::run(Filesystem::Path const&, Filesystem::Path const&, bool, bool, std::__1::function<void ()>, Filesystem::Path const&, MainLoop::HeavyMode) + 0xea
#35 0x000000010c40a5ba in main + 0x1361a
Stack trace logging done
   5.016 Error Util.cpp:97: Unexpected error occurred. If you're running the latest version of the game you can help us solve the problem by posting the contents of the log file on the Factorio forums.
Please also include the save file(s), any mods you may be using, and any steps you know of to reproduce the crash.
  14.638 Received SIGTERM, shutting down

posila
Factorio Staff
Factorio Staff
Posts: 3519
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [posila] [0.17.3] game fails to start (macOS Sierra)

Post by posila » Tue Mar 05, 2019 8:10 am

Thanks, it should be "fixed" in 0.17.6

User avatar
ThrashNeon
Burner Inserter
Burner Inserter
Posts: 11
Joined: Sun Mar 11, 2018 4:05 pm
Contact:

Re: [posila] [0.17.3] game fails to start (macOS Sierra)

Post by ThrashNeon » Tue Mar 05, 2019 5:43 pm

0.17.5 is working fine for me in 10.11.6.

Computer: Mac Pro
Model: MacPro5,1 (Mid 2010)
OS Version: 10.11.6
Processors: 2x 6-Core Intel Xeon
Processor Speed: 2.66 GHz
Processor Core Number: 12
RAM: 32 GB 1333 MHz DDR3 ECC
GPU: AMD Radeon HD 7950
GPU VRAM: 3072 MB

badams
Burner Inserter
Burner Inserter
Posts: 7
Joined: Wed Feb 27, 2019 6:58 pm
Contact:

Re: [posila] [0.17.3] game fails to start (macOS Sierra)

Post by badams » Tue Mar 05, 2019 6:42 pm

Also working for me now! Huzzah!

karock
Burner Inserter
Burner Inserter
Posts: 14
Joined: Tue Feb 26, 2019 7:17 pm
Contact:

Re: [posila] [0.17.3] game fails to start (macOS Sierra)

Post by karock » Tue Mar 05, 2019 7:09 pm

posila wrote:
Tue Mar 05, 2019 8:10 am
Thanks, it should be "fixed" in 0.17.6
0.17.6 working here!

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users