[0.16.38] Crash on loading save: "RailSegment::initFrom"

This subforum contains all the issues which we already resolved.
Locked
Bizobinator
Fast Inserter
Fast Inserter
Posts: 192
Joined: Fri May 06, 2016 10:35 pm
Contact:

[0.16.38] Crash on loading save: "RailSegment::initFrom"

Post by Bizobinator »

Playing a heavily-modded save. Yesterday, I played and saved it just fine before going to bed. This morning, I updated mods, clicked load. The loading bar filled completely, & then the game popped up an error screen (see picture below), and crashed to desktop. I tried disabling the newly updated mods, same crash. I tried disabling all mods, and it still crashed.

I've also tried loading previous autosaves, and it also crashes.

I've attached the log file, picture, and save file. My mods folder is massive (I don't have an addiction, I can quit at any time :D ), so I have posted a link to it in my google drive.


Please help: I've put a LOT of time into this save, and I don't want to lose it :(


Wow, the mods folder upload is taking ~30 min to upload. Maybe I do have a problem...

Here's the Google Drive link:
https://drive.google.com/file/d/1MA1_O6 ... sp=sharing
Attachments
Bizob.zip
Save file
(14.4 MiB) Downloaded 15 times
factorio-current.log
Crash log file
(37.24 KiB) Downloaded 20 times
Screenshot of crash screen
Screenshot of crash screen
Capture.PNG (1.67 MiB) Viewed 1137 times

Progman
Inserter
Inserter
Posts: 36
Joined: Sun Jul 10, 2016 10:45 am
Contact:

[0.16.38] Error when creating segment X, found rail [...]

Post by Progman »

When I try to join the attached multiplayer game I get the following exception:

Code: Select all

  27.579 Loading map /home/progman/factorio/saves/mp-download.zip: 39003123 bytes.
  27.599 Loading Level.dat: 97064645 bytes.
  27.605 Info Scenario.cpp:136: Map version 0.16.38-2
  36.771 Warning Logger.cpp:483: Symbols.size() == 19, usedSize == 11
Factorio crashed. Generating symbolized stacktrace, please wait ...
  42.563 Warning Logger.cpp:483: Symbols.size() == 14, usedSize == 10
#0  0x0000000000848d88 in Logging::flush() at /tmp/factorio-build-5fTpuz/src/Util/Logging.cpp:62
#1  0x0000000000871cdf in Logging::logAndAbortOrThrow(char const*, unsigned int, LogLevel, std::string const&) at /tmp/factorio-build-5fTpuz/src/Util/Logging.cpp:87
#2  0x000000000091e61d in Logging::logAndAbortOrThrow(char const*, unsigned int, LogLevel, char const*, ...) at /tmp/factorio-build-5fTpuz/src/Util/Logging.cpp:80
#3  0x0000000000bb191f in RailSegment::initFrom(Rail*, std::map<Rail*, RailPlace, std::less<Rail*>, std::allocator<std::pair<Rail* const, RailPlace> > > const&) at /tmp/factorio-build-5fTpuz/src/Rail/RailSegment.cpp:150
#4  0x0000000000bb2eb9 in IntrusiveListIterator<RailSegment, void, false>::operator++() at /tmp/factorio-build-5fTpuz/src/Util/Container/IntrusiveList.hpp:429
#5  0x0000000000c62313 in TrainManager::setup(SetupData const&) at /tmp/factorio-build-5fTpuz/src/Rail/TrainManager.cpp:88
#6  0x0000000000c68808 in Map::setupEntities(MapDeserialiser*, bool) at /tmp/factorio-build-5fTpuz/src/Map/Map.cpp:898
#7  0x000000000151a50f in TimeUtil::CpuTimer::elapsed() const at /tmp/factorio-build-5fTpuz/src/Util/TimeUtil.hpp:44
#8  0x0000000000007a99 in TimeUtil::CpuTimer::getSecondsPassed() const at /tmp/factorio-build-5fTpuz/src/Util/TimeUtil.hpp:29
#9  (nil) in Scenario::loadFactory(Filesystem::Path const*, Filesystem::Path const&, MapDeserialiser*, InputType, InputHandler*, MultiplayerManagerBase*, bool, ProgressObserver*, bool, InputListener*) at /tmp/factorio-build-5fTpuz/src/Scenario/Scenario.cpp:211
Stack trace logging done
  42.563 Error RailSegment.cpp:154: Error when creating segment 21451, found rail (straight-rail on {-203.0000000000, -541.0000000000}) already connected to segment 21450
Logger::writeStacktrace skipped.

Merged...
Attachments
mp-download.zip
(37.2 MiB) Downloaded 11 times

Kecon
Manual Inserter
Manual Inserter
Posts: 1
Joined: Sat Apr 28, 2018 5:13 pm
Contact:

Re: [16.38] Crash on loading save: "RailSegment::initFrom"

Post by Kecon »

I have the same problem as well in this version, but I don't use any mods. I was however able to load a previous autosave.

You may download my non-working save: https://kecon.se/download/my-save.zip

Code: Select all

 0.000 2018-04-28 19:08:35; Factorio 0.16.38 (build 36364, win64, steam)
   0.001 Operating system: Windows 10 (version 1709) 
   0.001 Program arguments: "C:\Program Files (x86)\Steam\steamapps\common\Factorio\bin\x64\Factorio.exe" 
   0.001 Read data path: C:/Program Files (x86)/Steam/steamapps/common/Factorio/data
   0.001 Write data path: C:/Users/Kenny/AppData/Roaming/Factorio [103257/915148MB]
   0.001 Binaries path: C:/Program Files (x86)/Steam/steamapps/common/Factorio/bin
   0.009 System info: [CPU: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz, 8 cores, RAM: 9323/32688 MB, page: 11459/34736 MB, virtual: 234/134217727 MB, extended virtual: 0 MB]
   0.010 Display options: [FullScreen: 1] [VSync: 0] [UIScale: system (100.0%)] [MultiSampling: OFF] [Screen: 255] [Lang: en]
   0.011 Available display adapters: 1
   0.011  [0]: \\.\DISPLAY1 - NVIDIA GeForce GTX 970 {0x05, [0,0], 1920x1080, 32bit, 59Hz}
   0.011 Create display on adapter 0. Size 1280x720 at position [310, 162].
   1.013 Initialised Direct3D:[0] NVIDIA GeForce GTX 970; driver: nvldumdx.dll 23.21.13.8813
   1.092   Video memory size (dedicated video/dedicated system/shared system/available): 4058/0/16344/4088 MB
   1.113 DSound: Starting _dsound_update thread
   1.113 DSound: Enter _dsound_update; tid=8832
   1.114 Device reset internal.
   1.116 Desktop composition is active.
   1.116 Graphics settings preset: extreme
   1.116 Graphics options: [Graphics quality: high] [Video memory usage: all] [Light scale: 100%] [DXT: false] [Shader: 1]
   1.116                   [Parallel sprite loading: 1] [Max texture size: 0/8192] [Bmp cache: 0] [Sprite slicing: 1] [Low quality rotation: 0]
   1.163 Loading mod core 0.0.0 (data.lua)
   1.183 Loading mod base 0.16.38 (data.lua)
   1.343 Loading mod base 0.16.38 (data-updates.lua)
   1.406 Checksum for core: 143459893
   1.406 Checksum of base: 41309181
   1.560 Loading sounds...
   1.658 Info PlayerData.cpp:67: Local player-data.json unavailable
   1.658 Info PlayerData.cpp:70: Cloud player-data.json available, timestamp 1524903734
   1.870 Loaded shader file C:/Program Files (x86)/Steam/steamapps/common/Factorio/data/core/graphics/shaders/game.cso
   1.870 Loaded shader file C:/Program Files (x86)/Steam/steamapps/common/Factorio/data/core/graphics/shaders/zoom-to-world.cso
   1.870 Loaded shader file C:/Program Files (x86)/Steam/steamapps/common/Factorio/data/core/graphics/shaders/alpha-mask.cso
   1.889 Initial atlas bitmap size is 16384
   1.918 Created atlas bitmap 16384x16383 [none]
   2.360 Created atlas bitmap 16384x4290 [none]
   2.455 Created atlas bitmap 16384x6916 [shadow]
   2.616 Created atlas bitmap 16384x2104 [decal]
   2.659 Created atlas bitmap 8192x5572 [mipmap]
   2.720 Created atlas bitmap 8192x800 [mipmap, smoke]
   2.731 Created atlas bitmap 8192x8172 [linear-minification, mipmap, terrain]
   2.832 Created atlas bitmap 8192x1360 [linear-minification, mipmap, terrain]
   2.845 Created atlas bitmap 8192x2092 [no-crop, trilinear-filtering, icon, light]
   2.870 Created atlas bitmap 8192x924 [alpha-mask]
   9.609 Sprites loaded
   9.609 Convert atlas 8192x5572 to: mipmap 
   9.721 Convert atlas 8192x800 to: mipmap 
   9.739 Convert atlas 8192x8172 to: min-linear 
   9.904 Convert atlas 8192x1360 to: min-linear 
   9.933 Convert atlas 8192x2092 to: trilinear-filtering 
   9.974 Convert atlas 8192x924 to: alpha-mask
  10.397 Custom inputs active: 0
  10.429 Factorio initialised
  14.459 Loading map C:\Users\Kenny\AppData\Roaming\Factorio\saves\Eden II.zip: 25251427 bytes.
  14.517 Loading Level.dat: 52653759 bytes.
  14.522 Info Scenario.cpp:136: Map version 0.16.38-2
Factorio crashed. Generating symbolized stacktrace, please wait ...
c:\cygwin64\tmp\factorio-build-ifixap\libraries\stackwalker\stackwalker.cpp (924): StackWalker::ShowCallstack
c:\cygwin64\tmp\factorio-build-ifixap\src\util\logger.cpp (408): Logger::writeStacktrace
c:\cygwin64\tmp\factorio-build-ifixap\src\util\logger.cpp (510): Logger::logStacktrace
c:\cygwin64\tmp\factorio-build-ifixap\src\util\logging.cpp (86): Logging::logAndAbortOrThrow
c:\cygwin64\tmp\factorio-build-ifixap\src\util\logging.cpp (80): Logging::logAndAbortOrThrow
c:\cygwin64\tmp\factorio-build-ifixap\src\rail\railsegment.cpp (150): RailSegment::initFrom
c:\cygwin64\tmp\factorio-build-ifixap\src\rail\trainmanager.cpp (88): TrainManager::setup
c:\cygwin64\tmp\factorio-build-ifixap\src\map\map.cpp (893): Map::setupEntities
c:\cygwin64\tmp\factorio-build-ifixap\src\scenario\scenario.cpp (211): Scenario::loadFactory
c:\cygwin64\tmp\factorio-build-ifixap\src\scenario\parallelscenarioloader.cpp (125): ParallelScenarioLoader::doLoad
c:\program files (x86)\microsoft visual studio\2017\buildtools\vc\tools\msvc\14.12.25827\include\thr\xthread (232): std::_LaunchPad<std::unique_ptr<std::tuple<void (__cdecl*)(ParallelScenarioLoader * __ptr64,MapDeserialiser * __ptr64,enum InputType,InputHandler * __ptr64,MultiplayerManagerBase * __ptr64,bool),ParallelScenarioLoader * __ptr64,MapDeserialiser * __ptr64,enum InputType,InputHandler * __ptr64,MultiplayerManagerBase * __ptr64,bool>,std::default_delete<std::tuple<void (__cdecl*)(ParallelScenarioLoader * __ptr64,MapDeserialiser * __ptr64,enum InputType,InputHandler * __ptr64,MultiplayerManagerBase * __ptr64,bool),ParallelScenarioLoader * __ptr64,MapDeserialiser * __ptr64,enum InputType,InputHandler * __ptr64,MultiplayerManagerBase * __ptr64,bool> > > >::_Go
c:\program files (x86)\microsoft visual studio\2017\buildtools\vc\tools\msvc\14.12.25827\include\thr\xthread (211): std::_Pad::_Call_func
d:\th\minkernel\crts\ucrt\src\appcrt\startup\thread.cpp (115): thread_start<unsigned int (__cdecl*)(void * __ptr64)>
ERROR: SymGetLineFromAddr64, GetLastError: 487 (Address: 00007FF8B7711FE4)
00007FF8B7711FE4 (KERNEL32): (filename not available): BaseThreadInitThunk
ERROR: SymGetLineFromAddr64, GetLastError: 487 (Address: 00007FF8B7ADF061)
00007FF8B7ADF061 (ntdll): (filename not available): RtlUserThreadStart
Stack trace logging done
  16.828 Error RailSegment.cpp:154: Error when creating segment 36808, found rail (straight-rail on {227.0000000000, 475.0000000000}) already connected to segment 36752
Logger::writeStacktrace skipped.
  16.828 Error Util.cpp:67: Unexpected error occurred. If you're running the latest version of the game you can help us solve the problem by posting the contents of the log file on the Factorio forums.
Please also include the save file(s), any mods you may be using, and any steps you know of to reproduce the crash.
  22.047 Uploading log file
  22.053 Error CrashHandler.cpp:227: Heap validation: success.
  22.054 Creating crash dump.
  22.247 CrashDump success

tuplex
Burner Inserter
Burner Inserter
Posts: 16
Joined: Fri May 27, 2016 6:22 pm
Contact:

Re: [16.38] Crash on loading save: "RailSegment::initFrom"

Post by tuplex »

I have the same problem, with the savegame I am using for my current Let's Play series :(

All my autosaves have the same issue. I am able to create a new game and load other saves. I restored a previous version (yesterday's save game) under Windows and that seems to work. But I would love to get today's version working, since I did a lot of work on it this morning.
Attachments
Series 9 AngelBob Series.zip
(11.85 MiB) Downloaded 11 times
factorio-current.log
(24.08 KiB) Downloaded 14 times

Teckology
Manual Inserter
Manual Inserter
Posts: 1
Joined: Sun Apr 29, 2018 11:06 am
Contact:

Re: [16.38] Crash on loading save: "RailSegment::initFrom"

Post by Teckology »

Same for me, I have a pure vanilla game. I've made a save file 2 hours before with another name, pure coinsidence, so the "old" save (with another name) still works, but all the autosaves and the new savefile all craches.

Maybe this an another crash, but I have the same pop-up. Happened this morning.

(sorry for my English)
Attachments
factorio-dump-current.dmp
(541.94 KiB) Downloaded 13 times
factorio-current.log
(6.41 KiB) Downloaded 13 times

Roberth
Burner Inserter
Burner Inserter
Posts: 9
Joined: Mon Jul 04, 2016 7:35 am
Contact:

Re: [16.38] Crash on loading save: "RailSegment::initFrom"

Post by Roberth »

Same problem here, vanilla version 16.38, no mods.

Code: Select all

   0.001 2018-04-29 22:52:11; Factorio 0.16.38 (build 36364, win64, steam)
   0.001 Operating system: Windows 7 Service Pack 1
   0.002 Program arguments: "C:\Program Files (x86)\Steam\steamapps\common\Factorio\bin\x64\Factorio.exe" 
   0.002 Read data path: C:/Program Files (x86)/Steam/steamapps/common/Factorio/data
   0.002 Write data path: C:/Users/Al/AppData/Roaming/Factorio [151724/940328MB]
   0.002 Binaries path: C:/Program Files (x86)/Steam/steamapps/common/Factorio/bin
   0.012 System info: [CPU: AMD FX(tm)-6350 Six-Core Processor             , 6 cores, RAM: 5330/20461 MB, page: 6944/40921 MB, virtual: 173/8388607 MB, extended virtual: 0 MB]
   0.013 Display options: [FullScreen: 1] [VSync: 0] [UIScale: system (100.0%)] [MultiSampling: OFF] [Screen: 255] [Lang: en]
   0.014 Available display adapters: 2
   0.014  [0]: \\.\DISPLAY1 - NVIDIA GeForce GTX 1070 {0x05, [0,0], 1920x1080, 32bit, 144Hz}
   0.014  [1]: \\.\DISPLAY2 - NVIDIA GeForce GTX 1070 {0x01, [1920,0], 1920x1080, 32bit, 60Hz}
   0.015 Create display on adapter 0. Size 1280x720 at position [310, 162].
   0.220 Initialised Direct3D:[0] NVIDIA GeForce GTX 1070; driver: nvd3dumx.dll 23.21.13.9101
   0.226   Video memory size (dedicated video/dedicated system/shared system/available): 8077/0/9974/1653 MB
   0.263 DSound: Starting _dsound_update thread
   0.263 DSound: Enter _dsound_update; tid=8352
   0.264 Device reset internal.
   0.281 Graphics settings preset: extreme
   0.282 Graphics options: [Graphics quality: high] [Video memory usage: all] [Light scale: 25%] [DXT: false] [Shader: 1]
   0.282                   [Parallel sprite loading: 1] [Max texture size: 0/8192] [Bmp cache: 0] [Sprite slicing: 1] [Low quality rotation: 0]
   0.377 Loading mod core 0.0.0 (data.lua)
   0.397 Loading mod base 0.16.38 (data.lua)
   0.577 Loading mod base 0.16.38 (data-updates.lua)
   0.637 Checksum for core: 143459893
   0.637 Checksum of base: 41309181
   0.772 Loading sounds...
   0.868 Info PlayerData.cpp:67: Local player-data.json unavailable
   0.868 Info PlayerData.cpp:70: Cloud player-data.json available, timestamp 1525034923
   1.034 Loaded shader file C:/Program Files (x86)/Steam/steamapps/common/Factorio/data/core/graphics/shaders/game.cso
   1.034 Loaded shader file C:/Program Files (x86)/Steam/steamapps/common/Factorio/data/core/graphics/shaders/zoom-to-world.cso
   1.034 Loaded shader file C:/Program Files (x86)/Steam/steamapps/common/Factorio/data/core/graphics/shaders/alpha-mask.cso
   1.065 Initial atlas bitmap size is 16384
   1.120 Created atlas bitmap 16384x16383 [none]
   2.080 Created atlas bitmap 16384x4290 [none]
   2.278 Created atlas bitmap 16384x6916 [shadow]
   2.600 Created atlas bitmap 16384x2104 [decal]
   2.688 Created atlas bitmap 8192x5572 [mipmap]
   2.814 Created atlas bitmap 8192x800 [mipmap, smoke]
   2.832 Created atlas bitmap 8192x8172 [linear-minification, mipmap, terrain]
   3.018 Created atlas bitmap 8192x1360 [linear-minification, mipmap, terrain]
   3.038 Created atlas bitmap 8192x2092 [no-crop, trilinear-filtering, icon, light]
   3.093 Created atlas bitmap 8192x924 [alpha-mask]
  17.340 Sprites loaded
  17.341 Convert atlas 8192x5572 to: mipmap 
  17.573 Convert atlas 8192x800 to: mipmap 
  17.614 Convert atlas 8192x8172 to: min-linear 
  17.940 Convert atlas 8192x1360 to: min-linear 
  18.005 Convert atlas 8192x2092 to: trilinear-filtering 
  18.089 Convert atlas 8192x924 to: alpha-mask
  19.154 Custom inputs active: 0
  19.208 Factorio initialised
  19.240 Game is running on selected version branch on Steam.
  43.040 Loading map C:\Users\Al\AppData\Roaming\Factorio\saves\MarxsParadise.zip: 45263678 bytes.
  43.067 Loading Level.dat: 98386205 bytes.
  43.074 Info Scenario.cpp:136: Map version 0.16.38-2
Factorio crashed. Generating symbolized stacktrace, please wait ...
c:\cygwin64\tmp\factorio-build-ifixap\libraries\stackwalker\stackwalker.cpp (924): StackWalker::ShowCallstack
c:\cygwin64\tmp\factorio-build-ifixap\src\util\logger.cpp (408): Logger::writeStacktrace
c:\cygwin64\tmp\factorio-build-ifixap\src\util\logger.cpp (510): Logger::logStacktrace
c:\cygwin64\tmp\factorio-build-ifixap\src\util\logging.cpp (86): Logging::logAndAbortOrThrow
c:\cygwin64\tmp\factorio-build-ifixap\src\util\logging.cpp (80): Logging::logAndAbortOrThrow
c:\cygwin64\tmp\factorio-build-ifixap\src\rail\railsegment.cpp (150): RailSegment::initFrom
c:\cygwin64\tmp\factorio-build-ifixap\src\rail\trainmanager.cpp (88): TrainManager::setup
c:\cygwin64\tmp\factorio-build-ifixap\src\map\map.cpp (893): Map::setupEntities
c:\cygwin64\tmp\factorio-build-ifixap\src\scenario\scenario.cpp (211): Scenario::loadFactory
c:\cygwin64\tmp\factorio-build-ifixap\src\scenario\parallelscenarioloader.cpp (125): ParallelScenarioLoader::doLoad
c:\program files (x86)\microsoft visual studio\2017\buildtools\vc\tools\msvc\14.12.25827\include\thr\xthread (232): std::_LaunchPad<std::unique_ptr<std::tuple<void (__cdecl*)(ParallelScenarioLoader * __ptr64,MapDeserialiser * __ptr64,enum InputType,InputHandler * __ptr64,MultiplayerManagerBase * __ptr64,bool),ParallelScenarioLoader * __ptr64,MapDeserialiser * __ptr64,enum InputType,InputHandler * __ptr64,MultiplayerManagerBase * __ptr64,bool>,std::default_delete<std::tuple<void (__cdecl*)(ParallelScenarioLoader * __ptr64,MapDeserialiser * __ptr64,enum InputType,InputHandler * __ptr64,MultiplayerManagerBase * __ptr64,bool),ParallelScenarioLoader * __ptr64,MapDeserialiser * __ptr64,enum InputType,InputHandler * __ptr64,MultiplayerManagerBase * __ptr64,bool> > > >::_Go
c:\program files (x86)\microsoft visual studio\2017\buildtools\vc\tools\msvc\14.12.25827\include\thr\xthread (211): std::_Pad::_Call_func
d:\th\minkernel\crts\ucrt\src\appcrt\startup\thread.cpp (115): thread_start<unsigned int (__cdecl*)(void * __ptr64)>
ERROR: SymGetLineFromAddr64, GetLastError: 487 (Address: 00000000778759CD)
00000000778759CD (kernel32): (filename not available): BaseThreadInitThunk
ERROR: SymGetLineFromAddr64, GetLastError: 487 (Address: 00000000779AA561)
00000000779AA561 (ntdll): (filename not available): RtlUserThreadStart
Stack trace logging done
  48.577 Error RailSegment.cpp:154: Error when creating segment 229863, found rail (curved-rail on {-286.0000000000, -222.0000000000}) already connected to segment 229862
Logger::writeStacktrace skipped.
  48.578 Error Util.cpp:67: Unexpected error occurred. If you're running the latest version of the game you can help us solve the problem by posting the contents of the log file on the Factorio forums.
Please also include the save file(s), any mods you may be using, and any steps you know of to reproduce the crash.
 143.739 Uploading log file
 143.744 Error CrashHandler.cpp:227: Heap validation: success.
 143.745 Creating crash dump.
 143.991 CrashDump success

azu0nyan
Manual Inserter
Manual Inserter
Posts: 1
Joined: Sun Apr 29, 2018 10:26 pm
Contact:

Re: [16.38] Crash on loading save: "RailSegment::initFrom"

Post by azu0nyan »

Same. No mods.
Attachments
____________aaa.zip
(21.94 MiB) Downloaded 11 times
factorio-current.log
(6.37 KiB) Downloaded 12 times

Sakreton
Manual Inserter
Manual Inserter
Posts: 1
Joined: Tue Dec 12, 2017 6:24 pm
Contact:

Re: [16.38] Crash on loading save: "RailSegment::initFrom"

Post by Sakreton »

Getting the same Error, im using huge angels and bobs Modpack
Attachments
factorio-current.log
(99.69 KiB) Downloaded 13 times
Angelbob III.zip
(14.6 MiB) Downloaded 13 times

kovarex
Factorio Staff
Factorio Staff
Posts: 7426
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [0.16.38] Crash on loading save: "RailSegment::initFrom"

Post by kovarex »

Thanks for the report, fixed for 0.16.39

Bizobinator
Fast Inserter
Fast Inserter
Posts: 192
Joined: Fri May 06, 2016 10:35 pm
Contact:

Re: [0.16.38] Crash on loading save: "RailSegment::initFrom"

Post by Bizobinator »

kovarex wrote:Thanks for the report, fixed for 0.16.39
Yayyyyyy!!!!!!!!!!!!!!!

Locked

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users