[0.14.15] Unable to connect to / open Server

This subforum contains all the issues which we already resolved.
Post Reply
Titan21
Inserter
Inserter
Posts: 30
Joined: Sun Jun 07, 2015 7:40 am
Contact:

[0.14.15] Unable to connect to / open Server

Post by Titan21 »

When starting up the new Version, the Server doesn't properly determine its own IP
( 10.254 Info UDPSocket.cpp:27: Opening socket at (0.0.0.0:34197) )

Also when trying to connect to a Server, I get the message that the connection couldn't be established.
I've tried a few Servers running 0.14.15 in the server-browser as well as my own server in my home network, can't connect to either.

I'm hosting a Server at my own house, so I know there are no firewall issues.

// So as far as I can see Multiplayer in 0.14.15 is broken
Attachments
factorio-current.log
Client Log
(5.4 KiB) Downloaded 117 times
factorio-previous.log
Server Log
(3.65 KiB) Downloaded 89 times

User avatar
cube
Former Staff
Former Staff
Posts: 1111
Joined: Tue Mar 05, 2013 8:14 pm
Contact:

Re: [0.14.15] Unable to connect to / open Server

Post by cube »

Hi, this is fixed for 0.14.16.

The address 0.0.0.0:34197 is actually correct, it means that Factorio is listening on all network interfaces on port 34197. The problem was caused by a small change in packet format that prevented determining the external IP address.

Titan21
Inserter
Inserter
Posts: 30
Joined: Sun Jun 07, 2015 7:40 am
Contact:

Re: [0.14.15] Unable to connect to / open Server

Post by Titan21 »

Cool.
Are you going to release 0.14.16 soon or should I revert back to .14?

Post Reply

Return to “Resolved Problems and Bugs”