[cube] Crash when auth.factorio.com can't be resolved

This subforum contains all the issues which we already resolved.
Post Reply
Burner Inserter
Burner Inserter
Posts: 6
Joined: Fri Sep 16, 2016 8:36 pm

[cube] Crash when auth.factorio.com can't be resolved

Post by geekthing »

I like others have been using Google DNS which is temperamental today. When I tried to login to my local server on the lan the game would crash as soon as it tried to connect to the local server. When I changed my dns server it let me connect. So factorio crashes when it can't properly resolve auth.factorio.com.

The log:

Code: Select all

0.000 2016-10-21 14:44:55; Factorio 0.14.14 (build 25084, mac, steam)
   0.000 Operating system: Mac OS X 10.12.0
   0.000 Program arguments: "/Users/hudson/Library/Application Support/Steam/steamapps/common/Factorio/factorio.app" 
   0.000 Read data path: /Users/hudson/Library/Application Support/Steam/steamapps/common/Factorio/factorio.app/Contents/data
   0.000 Write data path: /Users/hudson/Library/Application Support/factorio
   0.000 Binaries path: /Users/hudson/Library/Application Support/Steam/steamapps/common
   0.014 System info: [CPU: Intel(R) Core(TM) i7 CPU         870  @ 2.93GHz, 8 cores, RAM: 12288MB]
   0.019 Display options: [FullScreen: false] [VSync: true] [UIScale: 99%] [MultiSampling: OFF] [Screen: 255]
   0.019 Available display adapters: 1
   0.019  [0]: resolution 2560x1440px at [0,0]
   0.019 Create display on adapter 0. Size 1280x720 at position [630, 342].
   0.109 Initialised OpenGL:[0] ATI Radeon HD 5750 OpenGL Engine; driver: 2.1 ATI-1.44.68
   0.278 Graphics options: [Graphics quality: normal] [Video memory usage: high] [Light scale: 100%] [DXT: auto]
   0.375 Loading mod core 0.0.0 (data.lua)
   0.381 Loading mod base 0.14.14 (data.lua)
   0.483 Loading mod ScreenshotHotkey 13.10.1 (data.lua)
   0.558 Loading mod Foreman 1.1.0 (data.lua)
   0.634 Loading mod ModuleInserter 1.0.0 (data.lua)
   0.714 Loading mod YARM 0.7.107 (data.lua)
   0.818 Loading mod rso-mod 2.2.3 (data-updates.lua)
   0.906 Loading mod ModuleInserter 1.0.0 (data-final-fixes.lua)
   1.010 Checksum for core: 1620335853
   1.010 Checksum for mod base: 538937375
   1.010 Checksum for mod rso-mod: 1874398137
   1.010 Checksum for mod ScreenshotHotkey: 1754889110
   1.010 Checksum for mod Foreman: 889675380
   1.010 Checksum for mod ModuleInserter: 1557794654
   1.010 Checksum for mod undecorator: 0
   1.010 Checksum for mod YARM: 3348033433
   1.412 Info PlayerData.cpp:55: Local player-data.json available, timestamp 1477028237
   1.412 Info PlayerData.cpp:60: Cloud player-data.json available, timestamp 1477028236
   1.659 Initial atlas bitmap size is 16384
   1.661 Created atlas bitmap 16384x3851
   1.663 Created atlas bitmap 4096x4096
   1.665 Created atlas bitmap 4096x4088
   1.665 Created atlas bitmap 4096x3992
   1.665 Created atlas bitmap 4096x968
   1.666 Created atlas bitmap 4096x3660
  12.890 Sprites loaded
  12.890 Convert atlas 4096x4096 to: compressed 
  13.152 Convert atlas 4096x4088 to: compressed 
  13.395 Convert atlas 4096x3992 to: compressed 
  13.606 Convert atlas 4096x968 to: trilinear-filtering 
  13.649 Convert atlas 4096x3660 to: mipmap 
  13.824 Loading sounds...
  15.629 Custom inputs active: 4
  15.684 Factorio initialised
  19.475 Info UDPSocket.cpp:27: Opening socket at port (34196)
  19.475 Info UDPSocket.cpp:27: Opening socket at port (0)
  21.663 Info UDPSocket.cpp:153: Socket closed
  21.663 Info UDPSocket.cpp:153: Socket closed
  21.664 Joining game
  21.664 Info UDPSocket.cpp:27: Opening socket at port (0)
  21.664 Info ClientMultiplayerManager.cpp:538: MapTick(-1) changing state from(Ready) to(Connecting)
  21.721 Connection refused
  21.721 Info ClientMultiplayerManager.cpp:177: Quitting multiplayer connection.
  21.721 Info ClientMultiplayerManager.cpp:538: MapTick(-1) changing state from(Connecting) to(Disconnected)
  21.721 Info HttpSharedState.cpp:44: Downloading https://auth.factorio.com/generate-user-server-key
  21.722 code:6, 6; Couldn't resolve host 'auth.factorio.com'
  21.722 Info HttpSharedState.cpp:111: Status code: 0
  21.722 Info AuthServerConnector.cpp:15: Downloading from auth server failed: Couldn't resolve host 'auth.factorio.com'
  21.723 Error CrashHandler.cpp:230: Received SIGSEGV
Factorio crashed. Generating symbolized stacktrace, please wait ...
#0  0x00000001006e2742 in Logger::logStacktrace(StackTraceInfo*) (in factorio) (Logger.cpp:388)
#1  0x00000001006d5f79 in CrashHandler::writeStackTrace() (in factorio) (CrashHandler.cpp:106)
#2  0x00000001006d5f0e in CrashHandler::SignalHandler(int) (in factorio) (CrashHandler.cpp:235)
#3  0x00007fff9c34fbba in 0x00007fff9c34fbba
#4  0x000000015f4defa0 in 0x000000015f4defa0
#5  0x000000010051b942 in MainLoop::mainLoopStep(WorkerThread&, MainLoop::HeavyMode) (in factorio) (MainLoop.cpp:277)
#6  0x0000000100518f9e in MainLoop::run(boost::filesystem::path const&, boost::filesystem::path const&, bool, bool, bool, std::__1::function<void ()>, boost::filesystem::path const&, MainLoop::HeavyMode) (in factorio) (MainLoop.cpp:208)
#7  0x0000000100515855 in _al_mangled_main (in factorio) (Main.cpp:794)
#8  0x0000000100a70b57 in +[AllegroAppDelegate app_main:] (in factorio) (osx_app_delegate.m:218)
#9  0x00007fff88a9e30d in 0x00007fff88a9e30d
#10 0x00007fff9c359abb in 0x00007fff9c359abb
#11 0x00007fff9c359a07 in 0x00007fff9c359a07
#12 0x00007fff9c359231 in 0x00007fff9c359231
  22.519 Error Util.cpp:77: Unexpected error occurred. If you're running the latest version of the game you can help us solve the problem by posting the contents of the log file on the Factorio forums.
Please also include the save file(s), any mods you may be using, and any steps you know of to reproduce the crash.

User avatar
Global Moderator
Global Moderator
Posts: 816
Joined: Sat Oct 04, 2014 5:00 pm

Re: Crash when auth.factorio.com can't be resolved

Post by Smarty »

that topic has some details why it might not be able to resolve but the game shouldnt crash


User avatar
Former Staff
Former Staff
Posts: 1111
Joined: Tue Mar 05, 2013 8:14 pm

Re: [cube] Crash when auth.factorio.com can't be resolved

Post by cube »

This was already fixed by one of the many 0.15 changes :)

Post Reply

Return to “Resolved Problems and Bugs”