[0.11.22]Train going into automode when stopped by biters

This subforum contains all the issues which we already resolved.
Post Reply
Choumiko
Smart Inserter
Smart Inserter
Posts: 1273
Joined: Fri Mar 21, 2014 10:51 pm
Contact:

[0.11.22]Train going into automode when stopped by biters

Post by Choumiko » Fri May 01, 2015 1:43 pm

I noticed that a manually controlled train switches to automated mode, when being stopped by biters.

ImageImage
To the right is a nest where the biters come from. I think it's not related to the locomotive being FARL, as i managed to circle the nest with rails, change to a vanilla locomotive and it also switched to automode once it got stopped (the dark image is with a vanilla locomotive). Also FARL doesn't register a ontrainchangedstate event, nor does it change train.manualmode.
I don't know how automated trains react when stopped by biters but maybe this behaviour is also applied for manual controlled trains, forcing them into automode?

Savegame
FARL
To reproduce, simply load the save with the mod loaded and keep (slowly) driving towards the east. Sooner or later you'll be stopped and the No path message appears, indicating that you're now in automode.

kovarex
Factorio Staff
Factorio Staff
Posts: 7287
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [0.11.22]Train going into automode when stopped by biters

Post by kovarex » Tue Jun 30, 2015 8:35 am

Thank you for the report, it is now fixed for 0.12

FishSandwich
Smart Inserter
Smart Inserter
Posts: 1847
Joined: Sun Feb 23, 2014 3:37 pm
Contact:

Re: [0.11.22]Train going into automode when stopped by biters

Post by FishSandwich » Sun Jul 19, 2015 9:05 pm

kovarex wrote:Thank you for the report, it is now fixed for 0.12
Sorry to revive this one, but I'm having a similar issue.

Whilst manually driving a train, I hit another train that was driving automatically, and it put the manual train into automatic mode(even though it had no schedule).

Happened on 0.12

Choumiko
Smart Inserter
Smart Inserter
Posts: 1273
Joined: Fri Mar 21, 2014 10:51 pm
Contact:

Re: [0.11.22]Train going into automode when stopped by biters

Post by Choumiko » Wed Jul 22, 2015 9:32 am

Can confirm that this one is still there in 0.12.
I was put into automode by biters attacking FARL and one time hitting a tree when driving on a curve. With the biters it seemed to not happen every time as it was in 0.11

User avatar
HanziQ
Former Staff
Former Staff
Posts: 630
Joined: Fri Mar 27, 2015 7:07 am
Contact:

Re: [0.11.22]Train going into automode when stopped by biters

Post by HanziQ » Thu Jul 23, 2015 10:35 am

Thank you for re-reporting this one, it will be fixed in the next release.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users