Search found 144 matches

by doktorstick
Tue Oct 25, 2016 7:29 pm
Forum: Implemented Suggestions
Topic: Allow in-game name to be different from Factorio login name
Replies: 14
Views: 2197

Allow in-game name to be different from Factorio login name

I would like to have two name fields under the preferences--one for my Factorio login and one for the in-game name. I realize you can change the name used and that will appear in-game, but as soon as you want to interact with downloads you need to change it back to re-auth and then revert it to your...
by doktorstick
Mon Oct 10, 2016 9:40 pm
Forum: Mods
Topic: [MOD 0.13.17+] Rampant
Replies: 597
Views: 162351

Re: [MOD 0.13.17] Rampant - 0.14.3

Veden wrote:I have no idea what is causing it, but I will take a look at your save when i get some time.
Good news. They were able to reproduce it and it will be fixed in 0.14.14.
by doktorstick
Mon Oct 10, 2016 2:55 pm
Forum: Resolved Problems and Bugs
Topic: [posila] Deserialisation: unexpected symbol near "."
Replies: 7
Views: 2852

Re: Deserialisation: unexpected symbol near "."

Seems like the mod 'Rampant_0.14.3' is causing this issue, Okay, thanks. I've posted in the Rampant thread. It appears someone else has seen the same problem. Somehow the mod table has become misformed Do you have a notion on what can cause this? Is it how a mod stores it's global data, and what--a...
by doktorstick
Mon Oct 10, 2016 1:58 pm
Forum: Mods
Topic: [MOD 0.13.17+] Rampant
Replies: 597
Views: 162351

Re: [MOD 0.13.17] Rampant - 0.14.3

Indeed, I reported a deserialization bug and Klonan said it appears to be caused by Rampant. The save and mods are attached as part of my report. It so happened that I updated both to Factorio 0.14.13 and Rampant 0.14.3 before starting the play session that corrupted my saves.
by doktorstick
Mon Oct 10, 2016 11:54 am
Forum: Resolved Problems and Bugs
Topic: [posila] Deserialisation: unexpected symbol near "."
Replies: 7
Views: 2852

[posila] Deserialisation: unexpected symbol near "."

Version: 0.14.13. Map Version: 0.14.13-2. Game started around 0.14.10. Error while running deserialisation: [string "do local _={regionMap={[1]={[1]={[1]=7.840999..."]:1: unexpected symbol near '.' Main save and three autosaves all have this error. I updated to 0.14.13 and played for a whi...
by doktorstick
Thu Sep 29, 2016 3:38 am
Forum: Mods
Topic: [MOD 0.18.x] Natural Evolution - All things Alien!
Replies: 848
Views: 288572

Re: [MOD 0.12.x | 0.14.x] Natural Evolution - All things Alien!

TheSAGuy, Howdy. I play a more slow, defensive game and I run into artifact problems quite frequently (due to my play style and biter settings). In fact, I have to horde them for science and I'm not able to (often) experience the other parts of your building mod. To remedy this for players of my pla...
by doktorstick
Sun Sep 25, 2016 3:01 pm
Forum: Mods
Topic: [MOD 0.13.X] Killkrog's Blueprint Manager
Replies: 93
Views: 25413

Re: [MOD 0.13.X] Killkrog's Blueprint Manager

Howdy. Could you add a couple of (hopefully) minor features, perhaps under an option sub-menu to the right of the flip icons? 1) Keybind to open/close KBM window; 2) Auto-dismiss KBM window when restoring to blueprint; 3) Can use non-empty blueprints; 4) Load the cursor with the selected blueprint. ...
by doktorstick
Sat Sep 24, 2016 10:59 pm
Forum: Mods
Topic: [MOD 0.15] SmartTrains 2.0.5
Replies: 608
Views: 207462

Re: [MOD 0.13|0.14] SmartTrains 1.1.2|1.0.3

I have a section of track that looks like: ====== ST1 ======= ST2 ======= The two "ST"s are Smart Train stations, both with the name Iron Depot. What I'm trying to do is get the train to pass the first Iron Depot and if there's no train at the second. I want to keep the logic localized--me...
by doktorstick
Sat Sep 24, 2016 3:29 pm
Forum: Modding help
Topic: Need help turning a biter-spawner into an assembler
Replies: 12
Views: 2429

Re: Need help turning a biter-spawner into an assembler

:D Works great, thank you kindly. You've gotten me over my hurdle and I appreciate the extra effort you went through.
by doktorstick
Fri Sep 23, 2016 11:12 pm
Forum: Ideas and Suggestions
Topic: Performance of LuaTransportLine
Replies: 6
Views: 1119

Re: Performance of LuaTransportLine

Not sure why this was moved to suggestions. The OP is about the performance of the APIs with the context of where and how it's important.
by doktorstick
Fri Sep 23, 2016 6:06 pm
Forum: Mods
Topic: [MOD 0.15] Hacked Splitters - bring balance to the belts
Replies: 17
Views: 7459

Re: [MOD 0.14] Hacked Splitters - bring balance to the belts

great mod! what are your thoughts on having the recipe mirror the vanilla splitters in that red hacked splitters would require a yellow hacked splitter (instead of a red hacked splitter requiring a red regular splitter)? atm, unless we're playing with a recycling mod, hacked splitters of the curren...
by doktorstick
Fri Sep 23, 2016 4:59 pm
Forum: Ideas and Suggestions
Topic: Performance of LuaTransportLine
Replies: 6
Views: 1119

Performance of LuaTransportLine

Howdy. First some context for this post. I've a mod called Hacked Splitters that changes the behavior of splitters from one that maintains line affinity to one that balances outputs regardless of inputs. To do this, I have to manage eight lines (four input, four output) per splitter. The APIs I use ...
by doktorstick
Fri Sep 23, 2016 4:31 pm
Forum: Modding help
Topic: Need help turning a biter-spawner into an assembler
Replies: 12
Views: 2429

Re: Need help turning a biter-spawner into an assembler

I'll give this a try on Saturday! Thanks for the detailed look.
by doktorstick
Fri Sep 23, 2016 4:29 pm
Forum: Mods
Topic: [MOD 0.15] Hacked Splitters - bring balance to the belts
Replies: 17
Views: 7459

Re: [MOD 0.14] Hacked Splitters - bring balance to the belts

I'm trying to understand the numbers in the debug console, because show_time_used_percent has "Mod-hacked-splitters" at a number between 15 and 19 and that looks weird if it's a percentage... It's in milliseconds. I'm releasing a version that improves performance today. Eventually you wil...
by doktorstick
Wed Sep 21, 2016 8:27 pm
Forum: Modding help
Topic: Need help turning a biter-spawner into an assembler
Replies: 12
Views: 2429

Re: Need help turning a biter-spawner into an assembler

Actually it seems easier to make assembler to look like spawner and create units around it with lua. Or make an extra entity under the assembler that is a spawner (I have to imagine that the spawning logic is better than what a mod can do easily) Oh, hah, yeah, that's not what I want. It isn't spaw...
by doktorstick
Wed Sep 21, 2016 8:25 pm
Forum: Modding help
Topic: Need help turning a biter-spawner into an assembler
Replies: 12
Views: 2429

Re: Need help turning a biter-spawner into an assembler

You can't make entity of one kind to behave like another. Spawner type doesn't support the pipe connections, if you want to make those visible, you'll have to write them in sprite definitions. If you wan them to behave like pipes, you'll have to hack new entity and place it beside the spawner. Actu...
by doktorstick
Wed Sep 21, 2016 5:52 pm
Forum: Mods
Topic: [MOD 0.18.x] Natural Evolution - All things Alien!
Replies: 848
Views: 288572

Re: [MOD 0.12.x | 0.14.x] Natural Evolution - All things Alien! - 6.3.1

I've unzip'd all of the NE mods--NEB 6.3.3, NEEx 6.3.1, and NEE 6.3.1. There isn't a locale for the small-alien-artifact . This causes the item to be displayed as "unknown key: small-alien-artifact" for the name. $ find Natural_Evolution* -type f -name "*.cfg" | xargs grep -i sma...
by doktorstick
Wed Sep 21, 2016 2:10 pm
Forum: Modding help
Topic: Need help turning a biter-spawner into an assembler
Replies: 12
Views: 2429

Re: Need help turning a biter-spawner into an assembler

I don't. It's not even a mod per se--i'm tinkering/exploring. I'll see about packaging a zip together, but it won't be for a long while. Busy day today.
by doktorstick
Wed Sep 21, 2016 12:09 pm
Forum: Modding help
Topic: Need help turning a biter-spawner into an assembler
Replies: 12
Views: 2429

Need help turning a biter-spawner into an assembler

Howdy. I need an assist. I've successfully turned a biter-spawner into an assembler. The main change I had to do was change the animations to animation and pick one of the spawner_idle_animations . However, I'm running into a problem with pipe connections. I can't seem to get fluid-boxes definition ...
by doktorstick
Mon Sep 19, 2016 4:22 am
Forum: Modding discussion
Topic: My interesting findings on LuaTransportLine.insert_at...
Replies: 8
Views: 2488

Re: My interesting findings on LuaTransportLine.insert_at...

Since belt's exit is 0 and entrance is 1, inserting items at >=0.5 should be more reasonable than inserting at <0.5. And my mod works well by inserting items at 0.859375 (1 - 0.28125 * 0.5). So I really want to know why it doesn't work for you. :? Ahh. An important datapoint I didn't indicate. The ...

Go to advanced search