Search found 51 matches

by kasandraen
Tue Apr 02, 2019 8:59 am
Forum: Modding help
Topic: [0.17.23] Assembly machine with a speed module switches status to low power
Replies: 2
Views: 226

Re: [0.17.23] Assembly machine with a speed module switches status to low power

Ah that would explain it! I had a lengthy discussion with someone on discord about how to deal with that and we kinda settled on there being more work(both writing it and in data time ingame) comparing the inventories than what I would be to just overwrite it, but now I see that it has a side-effect...
by kasandraen
Sat Mar 30, 2019 5:34 pm
Forum: Modding help
Topic: [0.17.23] Assembly machine with a speed module switches status to low power
Replies: 2
Views: 226

[0.17.23] Assembly machine with a speed module switches status to low power

Hi I'm trying to make a machine that has both a burner fuel (a mold that's being used up) and electrical supply. To achieve this I create a dummy invisible assembly machine under the one I want and use it to drain electrical energy. Using control code I check if the machine has energy, if it has and...
by kasandraen
Sun Mar 10, 2019 3:37 pm
Forum: Resolved Problems and Bugs
Topic: [0.17.8] building status switching between working and low power
Replies: 4
Views: 635

Re: [0.17.8] building status switching between working and low power

Oh I'm so sorry, I didn't notice the forum, this was the first hit through google and I saw the date was two days ago and I was unsure if the .9 version included it since this was posted about the .8 one or not
by kasandraen
Sun Mar 10, 2019 3:18 pm
Forum: Resolved Problems and Bugs
Topic: [0.17.8] building status switching between working and low power
Replies: 4
Views: 635

Re: [0.17.8] building status switching between working and low power

Has this been fixed? Ive been working on a modded machine that creates a dummy machine to drain power for it, and using wheter that machine runs fine to determine if my machine can run. It works flawlessly untill I add a speed module, then it randomly gets the status "low-power" and stops my script....
by kasandraen
Mon Mar 04, 2019 6:19 pm
Forum: Resolved Problems and Bugs
Topic: 0.17.x Ore generation issues
Replies: 5
Views: 1170

Re: 0.17.x Ore generation issues

I too came to the same conclusion after testing it earlier: viewtopic.php?f=25&t=66128
Glad they fixed it!
by kasandraen
Sat Mar 02, 2019 6:44 pm
Forum: Modding help
Topic: Anyone know how to use the new Fluid Energy type?
Replies: 10
Views: 669

Re: Anyone know how to use the new Fluid Energy type?

For future readers: The issue was that the fluid was at the default temperature which the minimum temperature. The fluid has to have a higher temperature than the minimum temperature to be able to extract energy from it. Yeah, thank you soo much for your help on discord For anyone else that is look...
by kasandraen
Sat Mar 02, 2019 12:24 pm
Forum: Modding help
Topic: Anyone know how to use the new Fluid Energy type?
Replies: 10
Views: 669

Re: Anyone know how to use the new Fluid Energy type?

I have gotten this far
Image
but the machine doesnt run. As the image show it does recoginize the recipe (iron-ore -> liquid iron)
But I dont know how to configure the Consumption. It says 0.0/s but I dont know what option to change to increase it
by kasandraen
Sat Mar 02, 2019 3:42 am
Forum: Modding help
Topic: Anyone know how to use the new Fluid Energy type?
Replies: 10
Views: 669

Anyone know how to use the new Fluid Energy type?

Looking through the patch notes

Code: Select all

Added "fluid" energy_source type can be used for both fuel-value based fluids, and heat capacity based fluids configured the same was as the generator entity.
How do I use this? I cant seem to find anything using it
by kasandraen
Fri Mar 01, 2019 6:18 pm
Forum: Modding help
Topic: Ore Generation issues
Replies: 2
Views: 294

Re: Ore Generation issues

It's not only limited to mod ores. I seen iron or copper do this - I think they might have underflow/overflow kind of error somewhere in the code that gets triggered when you use minimum frequency. When I looked at how probability is defined in data stage (expression tree with 100+ elements) I did ...
by kasandraen
Fri Mar 01, 2019 2:51 pm
Forum: Modding help
Topic: Ore Generation issues
Replies: 2
Views: 294

Ore Generation issues

Hi I'm trying to generate some ores for my mod and I'm running into some issue. I have followed the doings of other mods, but it seems they all rely on Bobs'library ore functions and even with those I cant get it to seem right. Ingame when you reduce the frequency the ore patches grow in size instea...
by kasandraen
Fri Feb 22, 2019 6:54 am
Forum: Resource Spawner Overhaul
Topic: RSO ignoring place in spawn settings
Replies: 1
Views: 426

RSO ignoring place in spawn settings

Hi I'm trying to make my life easier and tried adding Zinc to the spawn area, I did it both through the rso spawn config files with "starting={richness=1000, size=10, probability=1}," and through the mods own files I enabled in spawn = true. But it still wont generate the zinc ores in the spawn area...
by kasandraen
Sun Sep 25, 2016 4:40 pm
Forum: Not a bug
Topic: Detected modification of the global 'log' function."
Replies: 12
Views: 1966

Re: Detected modification of the global 'log' function."

and what is this function for? there is not a single mention of a global function named log in the documentation.. Ah found what it does. Would be nice if that was documented, it could be usefull to people.. Like I could draw dicks in the logs file and nobody would ever know it was me since the mod...
by kasandraen
Sun Sep 25, 2016 3:57 pm
Forum: Not a bug
Topic: Detected modification of the global 'log' function."
Replies: 12
Views: 1966

Re: Detected modification of the global 'log' function."

and what is this function for? there is not a single mention of a global function named log in the documentation.. Ah found what it does. Would be nice if that was documented, it could be usefull to people.. Like I could draw dicks in the logs file and nobody would ever know it was me since the mod...
by kasandraen
Tue Aug 30, 2016 2:41 am
Forum: Mods
Topic: [MOD 0.13.x] Cursed PI - v0.2.3
Replies: 42
Views: 38991

Re: [MOD 0.13.x] Cursed PI - v0.2.3

by kasandraen
Wed Aug 03, 2016 2:46 pm
Forum: Modding help
Topic: Replacing all recipe ingredient with another.
Replies: 4
Views: 552

Re: Replacing all recipe ingredient with another.

Recipe ingredients (items) can be confusing, most of them don't have a set type (type is nil ) and ingredient.name is also nil most of the time. You should be able to check if it's an item type by testing if ingredient.type == nil or ingredient.type == "item" . If you have determined that it is an ...
by kasandraen
Mon Aug 01, 2016 12:13 pm
Forum: Modding help
Topic: Replacing all recipe ingredient with another.
Replies: 4
Views: 552

Replacing all recipe ingredient with another.

Hi, I'va made this script: function ReplaceAllIngredientFluidWithFluid(Fluid1 , Fluid2) for i, recipe in pairs(data.raw.recipe) do for v, ingredient in pairs(data.raw.recipe[recipe.name].ingredients) do if ingredient.type == "fluid" then if ingredient.name == Fluid1 then ingredient.type = "fluid" in...
by kasandraen
Sat Jul 30, 2016 8:18 am
Forum: Modding help
Topic: Creating a item collector based on entity_died problems
Replies: 2
Views: 325

Re: Creating a item collector based on entity_died problems

Okay, now it works. buuuuuut
The loot drops from the unit after the events.on_entity_died, so a unit needs to die right next to it for it to move the items :<
Guess I'll have to find another way...
by kasandraen
Sat Jul 30, 2016 7:08 am
Forum: Modding help
Topic: Creating a item collector based on entity_died problems
Replies: 2
Views: 325

Creating a item collector based on entity_died problems

Hi I'm trying to make a item collector based on entity_died event. When a unit dies, it scan around the corpse for item (to find its own loot), thenit scans a 64x64 area for a chest named "loot-chest". If it finds a chest it insert the items into the inventoy. My problem is that the "for _, item in ...
by kasandraen
Fri Jul 29, 2016 6:50 am
Forum: Resolved Problems and Bugs
Topic: [Rseding91] [0.13.11]Adding Prereq to a tech that is that tech crashes
Replies: 2
Views: 961

[Rseding91] [0.13.11]Adding Prereq to a tech that is that tech crashes

Its a stupid bug, but I somehow managed to do it. I added a new tech, advanced-processing-unit, and later in the script added advanced-processing-unit as a Prerequisites to advanced-processing-unit. The game loaded fine, except when you are ingame and select it, the game crashes with the following e...
by kasandraen
Wed Jul 27, 2016 4:47 pm
Forum: Won't implement
Topic: Reques: access/manipulate more game.entity_prototype values
Replies: 1
Views: 454

Reques: access/manipulate more game.entity_prototype values

Hi I'v like to make a mod that increases a machines crafting speed after it has heated up (specific time / crafted x items after eachother) and that required acces to for example the entity.crafting_speed. Also, I just made a mode to change a generators output priority, but this isnt accesable in ga...

Go to advanced search