Search found 6 matches

by RoseQuartz
Fri Mar 13, 2020 2:18 pm
Forum: News
Topic: Friday Facts #338 - The (real) Character GUI
Replies: 89
Views: 11986

Re: Friday Facts #338 - The (real) Character GUI

Love the new character GUI in general and the logistic toggle in particular, but item/recipe icons with black outlines and shadows on dark gray background make the details on a lot of them really hard to see and the low contrast will make the GUI harder to use. Making the active tab card dark gray a...
by RoseQuartz
Thu Jan 09, 2020 12:58 pm
Forum: Mods
Topic: [Mod 0.18] Power Armor MK3
Replies: 93
Views: 22982

Re: [Mod 0.17] Power Armor MK3

when I disable the fusion battery in the settings, the power armor mk4 recipe still requires it, even though I am unable to craft any
by RoseQuartz
Wed May 08, 2019 11:38 pm
Forum: Not a bug
Topic: [0.17.37] Setting seed for custom map preset does not work
Replies: 3
Views: 188

Re: [0.17.37] Setting seed for custom map preset does not work

Thanks for the correction on me using the wrong documentation here and in the other thread. What exactly does "Read by the game, but not used or set in the GUI. " mean? If I pick the preset and dont touch anything, the seed is not used. How exactly is the seed being "read by the game"? Is there any ...
by RoseQuartz
Wed May 08, 2019 10:03 am
Forum: Not a bug
Topic: [0.17.37] Setting seed for custom map preset does not work
Replies: 3
Views: 188

[0.17.37] Setting seed for custom map preset does not work

Action create a mod with the following data.lua data.raw["map-gen-presets"]["default"]["foo"] = { order = "d", basic_settings = { seed = 392430818 } } (key MapGenSettings.seed from https://lua-api.factorio.com/latest/Concepts.html#MapGenSettings) Expected Result Preset has seed 392430818 Actual Res...
by RoseQuartz
Wed May 08, 2019 9:47 am
Forum: Resolved Problems and Bugs
Topic: [TOGoS] [0.17.31] Map generation preset mod setting "research_queue_from_the_start" does not work
Replies: 4
Views: 1109

Re: [TOGoS] [0.17.31] Map generation preset mod setting "research_queue_from_the_start" does not work

Thanks for the fix and the documentation update. I think it would also be a lot easier to understand the documentation for this if a) the section for MapGenSettings mentioned the advanced_settings field b) there was a section for the advanced settings type / dictionary c) the section for advanced se...
by RoseQuartz
Sun Apr 14, 2019 11:52 pm
Forum: Resolved Problems and Bugs
Topic: [TOGoS] [0.17.31] Map generation preset mod setting "research_queue_from_the_start" does not work
Replies: 4
Views: 1109

[TOGoS] [0.17.31] Map generation preset mod setting "research_queue_from_the_start" does not work

Action create a mod with the following data.lua data.raw["map-gen-presets"]["default"]["foo"] = { order = "1", basic_settings = { research_queue_from_the_start = "always" } } (key "research_queue_from_the_start" from https://lua-api.factorio.com/latest/Concepts.html#MapGenSettings) Expected Result ...

Go to advanced search