Search found 20 matches

by newllama
Fri Jul 03, 2020 11:09 pm
Forum: News
Topic: Friday Facts #354 - Launch party and HR power switch
Replies: 33
Views: 11475

Re: Friday Facts #354 - Launch party and HR power switch

Will there be a rotated version? Currently you're forced to always use a left/right power switch.
by newllama
Mon Aug 05, 2019 10:14 pm
Forum: News
Topic: Friday Facts #306 - Experimental Demo
Replies: 155
Views: 35421

Re: Friday Facts #306 - Experimental Demo

In the old campaign, "A New Hope" level 2 the player discovers a large base that has been decimated by biters. I remember that this was the level that my imagination really kicked into high gear. I think that without that glimpse into the future I might not have had the curiosity to contin...
by newllama
Thu Jul 11, 2019 1:23 pm
Forum: Resolved Problems and Bugs
Topic: [0.17.50] Crashes at max zoom in radar view w/ turret range visible
Replies: 5
Views: 1158

Re: [0.17.50] Crashes at max zoom in radar view w/ turret range visible

posila wrote: ↑
Thu Jul 04, 2019 4:22 am
Does it still crash in 0.17.53?
I'm traveling right now. I'll be able to tell you in a week!
by newllama
Thu Jul 04, 2019 1:50 pm
Forum: Won't fix.
Topic: [0.17.52] Damaged rail tracks prevent robots from placing curved segments
Replies: 3
Views: 1089

Re: [0.17.52] Damaged rail tracks prevent robots from placing curved segments

Thanks for the report. I don't consider this scenario worth the code complication and bugs it will introduce to try to account for it when building by robots. You'll simply have to repair the rail before the robots try to use it. I'd like to point out one additional thing.. The bots seem to actuall...
by newllama
Mon Jul 01, 2019 6:31 pm
Forum: Resolved Problems and Bugs
Topic: [Oxyd] [0.17.52] Biters have just given up on attacking
Replies: 11
Views: 4137

Re: [0.17.52] Biters have just given up on attacking

Can you post a log file please. Sure. 0.001 2019-06-28 18:36:18; Factorio 0.17.52 (build 45814, mac, steam) 0.001 Operating system: macOS 10.14.5 0.001 Program arguments: "/Users/marcel/Library/Application Support/Steam/steamapps/common/Factorio/factorio.app/Contents/MacOS/factorio" "...
by newllama
Sun Jun 30, 2019 9:55 pm
Forum: Resolved Problems and Bugs
Topic: [Oxyd] [0.17.52] Biters have just given up on attacking
Replies: 11
Views: 4137

[Oxyd] [0.17.52] Biters have just given up on attacking

I'm about 210 hours into a vanilla deathworld marathon map (default settings, no mods) and the biters don't aggro on artillery anymore. It seems like they will form a platoon and get ready to attack but never quite make it. It's making clearing new territory really painful because I first have to se...
by newllama
Fri Jun 28, 2019 9:49 pm
Forum: Won't fix.
Topic: [0.17.52] Damaged rail tracks prevent robots from placing curved segments
Replies: 3
Views: 1089

[0.17.52] Damaged rail tracks prevent robots from placing curved segments

Steps to reproduce: - Place some train tracks - Turn off personal roboport and damage a single straight segment with 'C' key (damage, not destroy) - Deconstruct the tracks - At this point your inventory should contain 1 damaged rail track - Place a curved track ghost What happens: A construction rob...
by newllama
Wed Jun 26, 2019 5:21 am
Forum: Resolved Problems and Bugs
Topic: [0.17.50] Crashes at max zoom in radar view w/ turret range visible
Replies: 5
Views: 1158

Re: [0.17.50] Crashes at max zoom in radar view w/ turret range visible

Does still crash in 0.17.52? Is there a way to update drivers for the external GPU or are you stuck with whatever the current version of macOS has? Yeah, it's still broken in 0.17.52. I haven't been able to reproduce the graphical issue with the flame turret range though. I did some testing and con...
by newllama
Sat Jun 22, 2019 7:13 pm
Forum: Resolved Problems and Bugs
Topic: [0.17.50] Crashes at max zoom in radar view w/ turret range visible
Replies: 5
Views: 1158

[0.17.50] Crashes at max zoom in radar view w/ turret range visible

I'm running a weird machine configuration here so let me first get that out of the way. I'm using a 2019 MacBook Pro on macOS Mojave 10.14.5. I have an external GPU [Radeon RX Vega 56] attached via thunderbolt 3. Plugged into the Radeon is an Acer XR382CQK 37.5" display and I leave the laptop's...
by newllama
Thu May 02, 2019 12:37 am
Forum: Resolved Problems and Bugs
Topic: [kovarex] [0.17.34] Undo doesn't restore power switch wire connections
Replies: 1
Views: 1312

[kovarex] [0.17.34] Undo doesn't restore power switch wire connections

If you deconstruct a power switch and then undo it, the wire connections don't come back. Cut + paste works fine, assuming you also ctrl+x the poles it connected to. Here is a basic blueprint. You can place it, deconstruct the whole thing, and then undo to see the error. 0eNqVkd2KgzAQRt9lrmOJShVy28d...
by newllama
Fri Apr 26, 2019 11:57 pm
Forum: Won't fix.
Topic: [0.17.32] "Mining" construction bots counts against Ctrl+Z history
Replies: 4
Views: 913

Re: [0.17.32] "Mining" construction bots counts against Ctrl+Z history

Lol fair enough. As a counterpoint I'd like to point out that personal roboports leave a lot to be desired late game. I carry around a second armor with this loadout: - 4 fusion reactor - 4 battery mk2 - 6 personal roboport mk2 - nightvision I'll switch to this armor when placing larger blueprints a...
by newllama
Wed Apr 24, 2019 8:57 pm
Forum: Resolved Problems and Bugs
Topic: [Twinsen][0.17.32] "Not enough rails" message after successful track placement
Replies: 1
Views: 1534

[Twinsen][0.17.32] "Not enough rails" message after successful track placement

If you place rail tracks down using the non-ghost planner and part of the track overlaps an existing section, you might get the "Not enough rails" error message even though the rail was successfully placed. You can reproduce this by placing a straight run of tracks of any length. Now that ...
by newllama
Wed Apr 24, 2019 8:26 pm
Forum: Won't fix.
Topic: [0.17.32] "Mining" construction bots counts against Ctrl+Z history
Replies: 4
Views: 913

[0.17.32] "Mining" construction bots counts against Ctrl+Z history

"Mining" construction bots by holding down right click affects the undo history. This happens to me a lot while placing down large blueprints with personal roboports. Eventually the roboports run out of charge and the construction bots will hover near the engineer waiting for a charge. To ...
by newllama
Wed Apr 24, 2019 6:32 pm
Forum: Duplicates
Topic: [0.17.32] Train wagon doesn't open when blueprint is rotated
Replies: 1
Views: 418

[0.17.32] Train wagon doesn't open when blueprint is rotated

I noticed an issue where a train stop I created behaves differently when I rotate the whole stop (like when I take a blueprint, pickup all the track, and rotate the whole thing including the tracks). The final train car does not open when the track is facing north, but it does open when the track is...
by newllama
Tue Apr 02, 2019 6:11 pm
Forum: Resolved Problems and Bugs
Topic: 0.17 personal roboport shows construction area even when toggled off
Replies: 5
Views: 1770

0.17 personal roboport shows construction area even when toggled off

In 0.17.x (up to at least 0.17.24) if you toggle your personal roboport off and then hold a blueprint in your hand the green construction area for your personal roboport is still drawn. It makes it difficult to judge the area that your stationary roboports cover. I wasn't sure if this should be post...
by newllama
Fri Mar 15, 2019 11:06 pm
Forum: Technical Help
Topic: 0.17.x sometimes fails to start up with external GPU on OS X
Replies: 4
Views: 843

Re: 0.17.x sometimes fails to start up with external GPU on OS X

Thanks, this works. Am I just going to have to use these flags forever? Am I losing anything with safe mode on? Alternativelly, you can disable gpu-accelerated-compression in config.ini, but using --gfx-safe-mode is fine. It disables GPU accelerated texture compression during sprite loading, and fo...
by newllama
Sat Mar 09, 2019 2:49 am
Forum: Technical Help
Topic: 0.17.x sometimes fails to start up with external GPU on OS X
Replies: 4
Views: 843

Re: 0.17.x sometimes fails to start up with external GPU on OS X

posila wrote: ↑
Fri Mar 08, 2019 4:26 pm
Hello, try to open Factorio properties in Steam Library and set launch options to

Code: Select all

--gfx-safe-mode --max-texture-size=8192
Thanks, this works. Am I just going to have to use these flags forever? Am I losing anything with safe mode on?
by newllama
Thu Mar 07, 2019 10:50 pm
Forum: Technical Help
Topic: 0.17.x sometimes fails to start up with external GPU on OS X
Replies: 4
Views: 843

0.17.x sometimes fails to start up with external GPU on OS X

I'm running a weird machine configuration here so let me first get that out of the way. I'm using a 2015 MacBook Pro on macOS Mojave 10.14.2. I have an external GPU [Radeon RX Vega 56] attached via thunderbolt 3. Plugged into the Radeon is an Acer XR382CQK 37.5" display and I leave the laptop's...
by newllama
Mon Mar 04, 2019 10:08 pm
Forum: Outdated/Not implemented
Topic: 0.17 what i wish to see in a demo
Replies: 4
Views: 1188

Re: 0.17 what i wish to see in a demo

Yeah I really enjoyed the train level in the old campaign as well. I was hoping to see more of that in the new campaign. After you finish the new campaign if you hit "continue playing" it opens the map up a little more and there's a weird bunker with a few electric furnaces up to the north...

Go to advanced search