Search found 67 matches

by Jorn86
Sun Aug 02, 2020 6:56 am
Forum: Duplicates
Topic: [mod portal] Login flow is weird
Replies: 1
Views: 65

[mod portal] Login flow is weird

When I first open a page on the mod portal, it shows an option to log in. When I click it, without having to do anything else, I then see a page with "Success - you are logged in", and a 404 message below it. This sounds to me as if my login is actually remembered, as it should be, but it's not reco...
by Jorn86
Wed Jul 15, 2020 1:35 pm
Forum: Implemented mod requests
Topic: LuaPlayer::get_hand_index / LuaPlayer::set_hand_index or similar
Replies: 5
Views: 750

Re: LuaPlayer::get_hand_index / LuaPlayer::set_hand_index or similar

From the changelog description, I was hoping this would give me a way to read the player's actual mouse cursor without them triggering an action (like use capsule).

Oh well.
by Jorn86
Sat May 30, 2020 6:24 pm
Forum: Angels Mods
Topic: Bugs & FAQ
Replies: 3263
Views: 414521

Re: Bugs & FAQ

The new version of Angel's Refining (0.11.11) crashes on startup if Angel's Smelting is not enabled. The error is:

Code: Select all

Failed to load mods: Path __angelssmelting__/graphics/icons/ore-bauxite.png does not match any enabled mod.: __angelssmelting__/graphics/icons/ore-bauxite.png
by Jorn86
Sun Apr 19, 2020 12:43 pm
Forum: Duplicates
Topic: [0.18.18] Game throws error popup when deleting save game
Replies: 1
Views: 140

[0.18.18] Game throws error popup when deleting save game

I deleted a save file from the "Load game" dialog. The file was deleted just fine, but two seemingly unrelated errors popped up simpy as Windows error dialog boxes. The game then continued to run just fine, no crash. I checked, the messages are in the log file. So here you go. Relevant bit: 307.022 ...
by Jorn86
Wed Apr 15, 2020 9:28 am
Forum: Wiki Talk
Topic: [0.18.18] Broken link in documentation
Replies: 1
Views: 330

[0.18.18] Broken link in documentation

The radius_visualisation_specification property links to RadiusVisualisationSpecification, but that page does not exist.

Edit: Same problem for water_reflection
by Jorn86
Mon Apr 13, 2020 7:46 am
Forum: Resolved Problems and Bugs
Topic: [0.18.18] Command triggered event without player_index
Replies: 3
Views: 476

[0.18.18] Command triggered event without player_index

I received a bug report for one of my mods, that seems to indicate a console command event was fired, without containing the player index. That field isn't optional according to the docs , so I thought it was good to mention it. The offending line code in my mod (as mentioned in the stacktace, line ...
by Jorn86
Wed Mar 25, 2020 6:49 pm
Forum: Logistic Train Network
Topic: [1.12.7] Crash while running event on_train_changed_state
Replies: 6
Views: 328

Re: [1.12.7] Crash while running event on_train_changed_state

I'm not sure what else I can tell you beyond it happened :) But since it never happened again and won't be easy to reproduce, I guess we'll have to leave it be.
by Jorn86
Wed Mar 25, 2020 6:05 pm
Forum: Logistic Train Network
Topic: [1.12.7] Crash while running event on_train_changed_state
Replies: 6
Views: 328

Re: [1.12.7] Crash while running event on_train_changed_state

The stop names do have rich text (icons), but they all do so that should be fine. I guess it's possible someone was changing the station settings or signals at the time, but it'd be pretty hard to reproduce if it hat to be at that exact tick.
by Jorn86
Tue Mar 24, 2020 10:00 pm
Forum: Logistic Train Network
Topic: [1.12.7] Crash while running event on_train_changed_state
Replies: 6
Views: 328

Re: [1.12.7] Crash while running event on_train_changed_state

I wasn't doing anything LTN related at the time, just minding my own business when it crashed. I can't speak for the other players, but since the error happens in an event handler I doubt it's related to anything they did either. We restarted the game and played for several more hours, and the crash...
by Jorn86
Tue Mar 24, 2020 7:25 pm
Forum: Logistic Train Network
Topic: [1.12.7] Crash while running event on_train_changed_state
Replies: 6
Views: 328

[1.12.7] Crash while running event on_train_changed_state

Factorio version 0.18.15. We were playing multiplayer, 3 players connected. Let me know if you need more info.

Screenshot with stacktrace is attached
by Jorn86
Tue Feb 18, 2020 6:03 pm
Forum: Bug Reports
Topic: [0.17.79] Weird Behavior with Biter Pathfinding or something similar.
Replies: 6
Views: 666

Re: [0.17.79] Weird Behavior with Biter Pathfinding or something similar.

I've seen similar behaviour in my Islands World (mod, not the vanilla Island) map. It seems like once biters have decided there's nothing to attack, they are content to just stand around forever even if something to attack does arrive.
by Jorn86
Wed Feb 12, 2020 2:14 pm
Forum: Resolved Problems and Bugs
Topic: [boskid][0.18.6] Current station indicator is off by one
Replies: 4
Views: 758

Re: [0.18.6] Current station indicator is off by one

That's an extensive test! Thanks for making the effort.
by Jorn86
Wed Feb 12, 2020 1:42 pm
Forum: Modding help
Topic: Freeplay remote interface not available in game upgraded from 0.17.79
Replies: 1
Views: 175

Freeplay remote interface not available in game upgraded from 0.17.79

I'm running into this weird issue where a save game created in 0.17.79, will not have access to the freeplay remote interface when loaded in 0.18.4-6. Starting a new game in that version will have access just fine. If I re-save the game in 0.18.6 and then reload, it'll also be fine. Is there somethi...
by Jorn86
Wed Feb 12, 2020 1:04 pm
Forum: Resolved Problems and Bugs
Topic: [boskid][0.18.6] Current station indicator is off by one
Replies: 4
Views: 758

[boskid][0.18.6] Current station indicator is off by one

I have a big stacker at my main base which has stations reading the logistics network content. They all have the same name, and serve as parking for trains with many different items waiting until their load is needed. When I click on one of these stations, it shows a list of all trains with that sta...
by Jorn86
Tue Feb 11, 2020 7:59 pm
Forum: Resolved Problems and Bugs
Topic: [0.18.5] Graphics lock up when zooming in on distant areas on map in multiplayer
Replies: 5
Views: 1536

Re: [0.18.5] Graphics lock up when zooming in on distant areas on map in multiplayer

Same exact issue here. I can provide a log if needed. This happens for me and my friend, but my other friend (with a potato for a pc) doesn't have the issue. Update: Only happens under certain conditions. Might be related to the bot building warnings, the allied player that was there, or a specific ...
by Jorn86
Sun Feb 09, 2020 9:45 am
Forum: Resolved Problems and Bugs
Topic: [Oxyd] [0.18.4] Research progress of current tier shows for next queued tier
Replies: 4
Views: 747

[Oxyd] [0.18.4] Research progress of current tier shows for next queued tier

If I have multiple tiers of the same research queued, the progress of the current tier will show as a green bar on all the next queued tiers too.
See attached screenshot: Mining prod 6 already has progress while researching mining prod 5.
by Jorn86
Sun Jan 12, 2020 7:38 am
Forum: Modding help
Topic: How to move item from inventory to cursor?
Replies: 10
Views: 493

Re: How to move item from inventory to cursor?

That's a good point! Is there something I can do (with the LUA api) to prevent that?
by Jorn86
Fri Jan 10, 2020 8:26 am
Forum: Ideas and Suggestions
Topic: Custom hotkey for using modded capsule
Replies: 2
Views: 214

Re: Custom hotkey for using modded capsule

I've already got a workaround for that: If you bind a lua action to the same key as the custom use capsule action (or currently, the build action), both will trigger. Effectively, that would already work as you describe.

The difference is, your suggestion is not a hack ;)

Go to advanced search